Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 236701 - [gnome overlay] gnome-base/gdm-2.23.90 start-stop-daemon in startDM.sh needs -b option
Summary: [gnome overlay] gnome-base/gdm-2.23.90 start-stop-daemon in startDM.sh needs ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2008-09-04 14:47 UTC by Florian Steinel
Modified: 2008-10-19 09:45 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
startDM.patch (startDM.patch,397 bytes, patch)
2008-09-04 14:49 UTC, Florian Steinel
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Steinel 2008-09-04 14:47:10 UTC
without the -b option, "xdm start" never finishes.

Reproducible: Always

Steps to Reproduce:
Comment 1 Florian Steinel 2008-09-04 14:49:51 UTC
Created attachment 164565 [details, diff]
startDM.patch
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-09-06 08:46:43 UTC
patching startDM.sh is not the solution, upstream needs to make gdm backward compatible.

please also note that is _masked_ and in _overlay_ so you better work with upstream for this kind of bug (and pass by on irc before that if you don't feel so confortable, have a chat with us on #gentoo-desktop).
Comment 3 Mart Raudsepp gentoo-dev 2008-09-06 18:54:28 UTC
I think the issue was that startDM.sh is used for launching other desktop managers as well (xdm, kdm and so on), and as those don't take a -b argument, it'll break those. That's at least what I heard from remi or someone - for some clarification. Feel free to check if my recalling of this #gentoo-desktop chat is true
Comment 4 Peter Sääf 2008-10-14 15:56:36 UTC
Upstream bug #550170 has a patch to restore the previous behaviour of forking unless run with --nodaemon.

http://bugzilla.gnome.org/attachment.cgi?id=120573&action=view
Comment 5 Gilles Dartiguelongue gentoo-dev 2008-10-15 06:56:44 UTC
don't you see we are CCed there already ? Thanks for not adding noise if not needed.
Comment 6 Gilles Dartiguelongue gentoo-dev 2008-10-19 09:45:09 UTC
this has fixed in overlay since monday or so.