Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 236521 (CVE-2008-3916) - sys-apps/ed <1.0 strip_escapes() Heap-based buffer overflow (CVE-2008-3916)
Summary: sys-apps/ed <1.0 strip_escapes() Heap-based buffer overflow (CVE-2008-3916)
Alias: CVE-2008-3916
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Security
Whiteboard: A2 [glsa]
: 243242 (view as bug list)
Depends on:
Reported: 2008-09-02 23:25 UTC by Robert Buchholz (RETIRED)
Modified: 2020-04-10 11:34 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Robert Buchholz (RETIRED) gentoo-dev 2008-09-02 23:25:15 UTC
From ChangeLog:
2008-08-21  Antonio Diaz  <>

	* Version 1.0 released.
	* configure: Added option `--program-prefix'.
	* signal.c (strip_escapes): Buffer overflow fixed.
	* signal.c (resize_buffer): Pointer aliasing warning fixed.

base-system, please bump.
Comment 1 Doug Goldstein (RETIRED) gentoo-dev 2008-09-03 13:31:07 UTC
Added an ebuild to the tree.
Comment 2 Robert Buchholz (RETIRED) gentoo-dev 2008-09-03 14:01:23 UTC
Arches, please test and mark stable:
Target keywords : "alpha amd64 arm hppa ia64 m68k ppc ppc64 s390 sh sparc x86"
Comment 3 Brent Baude (RETIRED) gentoo-dev 2008-09-03 14:59:46 UTC
ppc and ppc64 done.
Comment 4 Ferris McCormick (RETIRED) gentoo-dev 2008-09-03 15:34:07 UTC
Sparc stable.
Comment 5 Raúl Porcel (RETIRED) gentoo-dev 2008-09-03 15:42:41 UTC
alpha/ia64/x86 stable
Comment 6 Tobias Heinlein (RETIRED) gentoo-dev 2008-09-03 18:13:54 UTC
amd64 stable
Comment 7 Jeroen Roovers (RETIRED) gentoo-dev 2008-09-03 19:55:13 UTC
Stable for HPPA.
Comment 8 Robert Buchholz (RETIRED) gentoo-dev 2008-09-14 11:31:22 UTC
req. filed
Comment 9 Pierre-Yves Rofes (RETIRED) gentoo-dev 2008-09-23 21:59:26 UTC
GLSA 200809-15
Comment 10 Dan Wallis 2008-10-11 14:50:16 UTC
What I don't get is: why when I run "emerge --update --deep --newuse world" (or system for that matter), sys-apps/ed is not updated, and when I run "emerge --depclean" it's not removed. So what's installed it and why doesn't it get updated properly? Should I raise a separate bug for this?
Comment 11 Robert Buchholz (RETIRED) gentoo-dev 2008-10-11 15:26:51 UTC
are you certain you do not have ed 1.0 installed already? please post your emerge --info
Comment 12 Dan Wallis 2008-10-11 15:33:49 UTC
dan@huia ~ $ glsa-check -vt all 
This system is affected by the following GLSAs:
200809-15 ( GNU ed: User-assisted execution of arbitrary code ) 
dan@huia ~ $ emerge -pv1 sys-apps/ed 

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] sys-apps/ed-1.0 [0.8] 67 kB 

Total: 1 package (1 upgrade), Size of downloads: 67 kB
dan@huia ~ $ emerge -pvuDN world 

These are the packages that would be merged, in order:

Calculating world dependencies... done!

Total: 0 packages, Size of downloads: 0 kB
dan@huia ~ $ emerge --info 
Portage (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r7 i686)
System uname: 2.6.25-gentoo-r7 i686 Pentium II (Deschutes)
Timestamp of tree: Sat, 11 Oct 2008 02:45:01 +0000
app-shells/bash:     3.2_p33
dev-lang/python:     2.5.2-r7
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
CFLAGS="-O2 -march=i686 -pipe"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X acl acpi alsa apm bash-completion berkdb bzip2 cairo cdr cli cracklib crypt cups dbus divx dri dvd dvdr dvdread eds emboss encode esd evo fam firefox fortran gdbm geoip gif gpm gstreamer gtk hal iconv ipv6 isdnlog javascript jpeg jpeg2k kerberos ldap libwww logrotate mad midi mikmod mp3 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp oss pam pcre pdf perl png pppd python qt3support quicktime readline real realmedia reflection sdl session sound spell spl ssl svg syslog tcpd theora tiff tk truetype unicode vim-syntax vorbis win32codecs wmp x86 xinerama xml xorg xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB" USERLAND="GNU" VIDEO_CARDS="mach64 mga r128 radeon vesa vga"

dan@huia ~ $ 
Comment 13 Dan Wallis 2008-10-11 15:39:17 UTC
Oh, and same results for "emerge -pvuDN system" as for "emerge -pvuDN world". Also, it's not just this one box, all my boxes have this (although I've manually updated most of them now).
Comment 14 Stefan Behte (RETIRED) gentoo-dev Security 2008-10-22 16:42:05 UTC
*** Bug 243242 has been marked as a duplicate of this bug. ***