Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 236274 - >media-sound/amarok-1.4.8 hangs on huge playlist with shuffle
Summary: >media-sound/amarok-1.4.8 hangs on huge playlist with shuffle
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-31 16:54 UTC by Johannes H.
Modified: 2008-10-06 12:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes H. 2008-08-31 16:54:34 UTC
Huge playlists cause amarok to hang when playing the next track. This occurs on automatic track changes and when I click next song and if shuffle is turned on (and only with 'Random: Tracks'). It does not occur when I select a track from the playlist (double click or rigth-click->play) if shuffle is turned on. The longer the playlist, the longer amarok hangs. A playlist with >3500 songs causes amarok to hang >4secs!

This affects 1.4.10-r1 as well.

Reproducible: Always

Steps to Reproduce:
1. Open amarok and create a huge playlist
2. Enable 'Random: Tracks'
3. Play a song and hit "next track"

Actual Results:  
Read above.

Expected Results:  
It should be faster :)

emerge --info
Portage 2.2_rc8 (default/linux/x86/2008.0, gcc-4.3.1, glibc-2.7-r2, 2.6.25-gentoo-r4-mactel i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r4-mactel-i686-Genuine_Intel-R-_CPU_1300_@_1.66GHz-with-glibc2.0
Timestamp of tree: Sat, 30 Aug 2008 01:17:02 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"
LANG="de_DE.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="   "
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X arts bzip2 crypt dbus hal hardened ipv6 jpeg kde kdeenablefinal kdehiddenvisibility mmx mmxext nls ntpl ntplonly opengl pch pic python readline sse sse2 ssl threads unicode x86" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw copy dshare dsnoop extplug file hooks ladspa lfloat linear meter mulaw multi null rate route share shm asym dmix empty iec958 ioplug plug softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIRC_DEVICES="macmini" USERLAND="GNU" VIDEO_CARDS="fbdev vesa i810"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Johannes H. 2008-10-05 19:41:41 UTC
I have new info on this. My collection resides on a different computer, accessed via cifs. All versions >1.4.8 seem to access every file in the current playlist if shuffle is turned on before "chosing a file to play". This of course is slow over a network-connection with a huge playlist. I ran tcpdump and there is MUCH more traffic to the server with the affected version when I select "next song", therefore my assumption. I reported this on the KDE-Bugtracker, but they won't fix this because they are focusing on the new release.
For reference: http://bugs.kde.org/show_bug.cgi?id=166617

Pls help me out :)
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2008-10-06 12:59:27 UTC
I'm sorry, but this is clearly an upstream issue.
Please reopen the bug when they commit a fix for this.