Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 235786 - net-misc/openssh-4.7_p1-r6 and net-misc/openssh-5.1_p1-r1 does not compile because of a wrong sys-libs/zlib version check. it needs sys-libs/zlib at version 1.2.3 or greater whereas it's already installed at version 1.2.3
Summary: net-misc/openssh-4.7_p1-r6 and net-misc/openssh-5.1_p1-r1 does not compile be...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2008-08-26 13:57 UTC by Rod
Modified: 2008-09-01 16:39 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

config log for installation of net-misc/openssh-5.0p1 (config.log,147.75 KB, text/plain)
2008-08-26 14:01 UTC, Rod
Build log for net-misc/openssh-5.0_p1-r2 (build.log,11.82 KB, text/plain)
2008-08-26 14:05 UTC, Rod
ebuild environnement used for installation of net-misc/openssh-5.0_p1-r2 (ebuildenv.log,118.92 KB, text/plain)
2008-08-26 14:07 UTC, Rod
Environnement definition conf (,724 bytes, text/plain)
2008-08-28 09:04 UTC, Rod
Openssh 5.0p1 configure script (configure,768.18 KB, text/plain)
2008-08-28 09:05 UTC, Rod

Note You need to log in before you can comment on or make changes to this bug.
Description Rod 2008-08-26 13:57:14 UTC
Upgrade of net-misc/openssh to version 4.7-r1 and after is impossible since it detects a sys-lib/zlib version older than 1.2.3 whereas sys-libs/zlib-1.2.3-r1 is installed.
emerge -auv system is not finished since this package lasts unupgraded.

Reproducible: Always

Steps to Reproduce:
No special setup.
My system has the following sys-libs/zlib version :
*  sys-libs/zlib
      Latest version available: 1.2.3-r1
      Latest version installed: 1.2.3-r1


1. emerge -av openssh
   ACCEPT_KEYWORDS="~x86" emerge -av openssh

Actual Results:  
Installation fails after sys-libs/zlib version check with following message :
checking for possibly buggy zlib... yes
configure: error: *** zlib too old - check config.log ***
Your reported zlib version has known security problems.  It's possible your
vendor has fixed these problems without changing the version number.  If you
are sure this is the case, you can disable the check by running
"./configure --without-zlib-version-check".
If you are in doubt, upgrade zlib to version 1.2.3 or greater.
See for details.

Expected Results:  
Installation should have been continued since the system has got a good sys-libs/zlib version.

Here is my emerge --info :

Portage (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.22-gentoo-r5RodTouch i686)
System uname: 2.6.22-gentoo-r5RodTouch i686 Intel(R) Pentium(R) 4 CPU 2.80GHz
Timestamp of tree: Thu, 31 Jul 2008 09:30:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.4-r13, 2.5.2-r5
dev-python/pycrypto: 2.0.1-r6
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/grass60/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="en fr"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/portage/local/layman/science /usr/local/portage /usr/local/portage/xeffects/trunk /usr/local/portage/xeffects/experimental"
USE="3dfx X acl acpi alsa apache2 arts berkdb cairo cdr cli cracklib crypt cups dbus dri dts dv dvd dvdr dvdread dvix4linux emboss encode esd evo exif fam firefox fortran gcj gdbm gif glut gnustep gpm gps gstreamer gtk gtk2 hal iconv imlib ipv6 isdnlog jbig jpeg kerberos mad midi mikmod mmx mp3 mp4 mpeg msn mudflap mysql ncurses nls nptl nptlonly objc ogg opengl openmp oss pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba sdl session spell spl ssl svg tcltk tcpd tiff tk truetype unicode vorbis win32codecs wxwindows x86 xml xml2 xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en fr" USERLAND="GNU" VIDEO_CARDS="v4l vga vesa fbdev i810"
Comment 1 Rod 2008-08-26 14:01:10 UTC
Created attachment 163817 [details]
config log for installation of net-misc/openssh-5.0p1
Comment 2 Rod 2008-08-26 14:05:10 UTC
Created attachment 163818 [details]
Build log for net-misc/openssh-5.0_p1-r2
Comment 3 Rod 2008-08-26 14:07:35 UTC
Created attachment 163820 [details]
ebuild environnement used for installation of net-misc/openssh-5.0_p1-r2
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2008-08-26 18:02:14 UTC
found zlib version 1.2.1 (1020100)

Do you have anything like that in /usr/local/lib or somewhere in /opt? Maybe you should post your /etc/ too, or at least read it and find the offending library.
Comment 5 Rod 2008-08-28 08:43:05 UTC
Hello Jeroen,

I don't know where you found zlib 1.2.1. It may help you tell me where.
By the way I had a look to my /usr/local/lib/ and I've found a static libz.a
that I've used for personal libraries. I couldn't exactly determine it's version
but it is reported different from /usr/lib/libz.a by diff.
I attached my /etc/

Here may be the evidence that /usr/local/lib/llibz.a is at version 1.2.1
$ strings /usr/lib/libz.a > foo1
$ strings /usr/local/lib/libz.a > foo2
$ diff foo1 foo2 
< adler32_combine
< compress.o/     1214222324  0     0     100644  1528      `
< \[^_]
< \[^_]
< 1.2.3
< GCC: (GNU) 4.1.2 (Gentoo 4.1.2 p1.0.1)
> compress.o/     1160413712  0     0     100644  1380      `
> 1.2.1
> GCC: (GNU) 3.4.6 (Gentoo 3.4.6-r1, ssp-3.4.5-1.0, pie-8.7.9)

So I took  /usr/local/lib/libz.a away and did an env-update && source /etc/profile
I may not do it right so just tell me.
The only dynamic libraries of zlib I have are in /lib and /usr/lib
/lib/ ->
/lib/ ->
/usr/lib/ (GNU ld script)

I reinstall zlib just to be sure :
$ emerge -a =sys-libs/zlib-1.2.3-r1

Then I try again to install openssh 4.7_p1-r6 or 5.0_p1-r2:

$ emerge -auv =net-misc/openssh-4.7_p1-r6
$ ACCEPT_KEYWORDS="~x86" emerge -av =net-misc/openssh-5.0_p1-r2

Both fails as I have already reported : sys-libs/zlib version is detected to be lesser than 1.2.3-r1

So in my view this bug can not be tagged as RESOLVED. But if you have more info tell me,
ask me things and if it is still not obviously resolved then tag it back to NEW.. REOPEN.

How can I check more strictly the version of zlib ?
Comment 6 Rod 2008-08-28 09:03:07 UTC
Ok pardon me !

It's the configure script which is in fault. so this BUG should be reported upstream.

It seems like whatever the version of zlib is, the message "zlib too old" which precedes
the installation failure always appears if the option --without-zlib-version-check is not used 
in the configure script.

If someone checks the configure script then check the line 10672 :
one can see that the script checks if the variable $zlib_check_nonfatal is set :
[line10672] if test -z "$zlib_check_nonfatal" ; then
    - If the variable $zlib_check_nonfatal is set then "zlib too old" does not happen.

The big problem is that the only other place where $zlib_check_nonfatal could be set
is at line 10598 :
[line 10598] zlib_check_nonfatal=1

which ONLY happens if --without-zlib-version-check is used.

May be my mistake... so if someone could check that and have a correct zlib version check
that would be nice.

Best regards.
Comment 7 Rod 2008-08-28 09:04:20 UTC
Created attachment 163968 [details]
Environnement definition conf
Comment 8 Rod 2008-08-28 09:05:34 UTC
Created attachment 163969 [details]
Openssh 5.0p1 configure script
Comment 9 Rod 2008-09-01 16:39:49 UTC

The configure script was checking /usr/local/include/zlib.h which is from a local zlib version 1.2.1

I removed /usr/local/include/zlib.h and installation works fine.

Thanks an bye.