Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 235486 - app-emulation/vmware-workstation-6.0.4.93057 incredibly slow/broken refresh rate in XP guest
Summary: app-emulation/vmware-workstation-6.0.4.93057 incredibly slow/broken refresh r...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo VMWare Bug Squashers [disabled]
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-22 20:26 UTC by rholgstad
Modified: 2008-08-23 21:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rholgstad 2008-08-22 20:26:57 UTC
I am running vmware-workstation-6.0.4.93057 on x86 gentoo with a windows xp guest.  I have a decent laptop ( t9300, 4gb ram) and I am giving the guest 1gb of ram which should be more than enough and its put very little load on the host, but the redrawing speed makes the guest unusable. minimizing and maximizing application windows takes 5-10 seconds at least and nothing can be done in the meantime.

As a workaround I have been using rdesktop to the guest and the response time is much better and pretty usable. It seems to me like there is regression/bug in the svga driver in this version of workstation.

Notes: I have vmware tools installed, hardware acceleration on, and I realize this package is not marked as stable yet, but I only have a valid license for vmware workstation 6.x

Reproducible: Always

Steps to Reproduce:
1. boot guest
2. try to max/min application windows


Actual Results:  
very slow/unusable redraw/refresh rates


emerge --info
Portage 2.1.4.4 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r7 i686)
=================================================================
System uname: 2.6.25-gentoo-r7 i686 Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50GHz
Timestamp of tree: Wed, 20 Aug 2008 16:45:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r13
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.61-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/shar                  
e/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-r                  
ebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://www.gtlib.gate                  
ch.edu/pub/gentoo "
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole                  
-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X aac accessibility acl alsa ap apache2 arts berkdb bzip2 cairo cli cracklib crypt cups db                  
us device-mapper dri dvd dvdread encode faad faad2 ffmpeg flaac flac gd gdbm gif gnutls gpm gtk                  
 gzip hal iconv imlib isdnlog java jpeg jpg kde lame ldap lm_sensors mad man midi mmx mp3 mpeg                   
mpg mplayer msn mudflap mysql ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf                  
 perl png pppd python qt qt3 qt4 readline reflection sdl session spl sse sse2 sse3 sse4 ssl syn                  
aptic sysfs tcl tcpd tk unicode v4l v4l2 vorbis vx wifi win32codecs x86 xcompisite xine xml xor                  
g xv xvid xvmc zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dsh                  
are dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw mu                  
lti null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_ali                  
as authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_                  
host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expi                  
res ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magi                  
c negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="g                  
libc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd                  
44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="vesa fbdev nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PO                  
RTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

------------
uname -a
Linux fallout 2.6.25-gentoo-r7 #6 SMP Wed Aug 20 21:04:50 CDT 2008 i686 Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50GHz GenuineIntel GNU/Linux
Comment 1 Mike Auty gentoo-dev 2008-08-23 21:51:01 UTC
I'm sorry, I don't see how this can be fixed by the package installer?  It seems as though it's a bug with the closed-source vmware program.  There's very little we can do to change how the program works, since we can't patch it, or really affect in many ways at all.  Your best bet is to file a report with vmware directly.

Please note, that if you mention you're running it on Gentoo, they'll tell you it's an unsupported host platform and will be unlikely to offer you any further support (although you can always try and see if they've changed their tune).

If you find out that this is in fact a specific problem with the way Gentoo's ebuild installs vmware (or find a workaround), then feel free to reopen this bug with the details.  Until then, I'm afraid I'm going to mark this as CANTFIX.  5:(