Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 235473 - media-sound/ardour-2.5 - (ardour-2.5:4652): glibmm-CRITICAL **: Glib::Interface::Interface(const Glib::In terface_Class&): assertion `gobject_ != 0' failed
Summary: media-sound/ardour-2.5 - (ardour-2.5:4652): glibmm-CRITICAL **: Glib::Interfa...
Status: RESOLVED DUPLICATE of bug 247249
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Professional Audio Applications Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-22 19:08 UTC by Carsten
Modified: 2009-03-24 09:01 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
stack trace and emerge --info (additional info,6.73 KB, text/plain)
2008-08-22 19:11 UTC, Carsten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carsten 2008-08-22 19:08:34 UTC
Every time I try to start my freshly installed ardour-2.5 it crashes after I tried to create a new project wit an error related to glibmm

I recently had some troubles installing, it crashed saying that it needed dev-cpp/gtkmm with USE=accessibility, after re-emerging , adev-cpp/gtkmm-2.12.7 with new use, ardour installed fine

Reproducible: Always

Steps to Reproduce:
1.Install media-sound/ardour-2.5
2.Satrt ardour
3.Create a new project

Then it Crashes

Actual Results:  
(ardour-2.5:4652): glibmm-CRITICAL **: Glib::Interface::Interface(const Glib::In
terface_Class&): assertion `gobject_ != 0' failed
Speicherzugriffsfehler

(The last word is German for: segmentation fault )
Comment 1 Carsten 2008-08-22 19:11:07 UTC
Created attachment 163566 [details]
stack trace and emerge --info

The command line output of ardour and my emerge --info
Comment 2 Jeroen Roovers gentoo-dev 2008-08-22 19:31:27 UTC
# ardour2
WARNING: Your system has a limit for maximum amount of locked memory!
This might cause Ardour to run out of memory before your system runs out of memo
ry. You can view the memory limit with 'ulimit -l', and it is normally controlle
d by /etc/security/limits.conf

(ardour-2.5:4652): glibmm-CRITICAL **: Glib::Interface::Interface(const Glib::In
terface_Class&): assertion `gobject_ != 0' failed
Comment 3 Wily Unrest 2008-08-28 02:31:43 UTC
Same issue:

open("/etc/ardour2/ardour.menus", O_RDONLY|O_LARGEFILE) = 11
fstat64(11, {st_mode=S_IFREG|0644, st_size=26415, ...}) = 0
read(11, "<ui>\n\n    <menubar name=\'Main\' a"..., 26415) = 26415
close(11)                               = 0
brk(0xa9aa000)                          = 0xa9aa000
brk(0xa9cb000)                          = 0xa9cb000
write(2, "\n(ardour-2.5:1685): glibmm-CRITI"..., 131
(ardour-2.5:1685): glibmm-CRITICAL **: Glib::Interface::Interface(const Glib::Interface_Class&): assertion `gobject_ != 0' failed
) = 131
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Comment 4 Wily Unrest 2008-08-28 07:01:14 UTC
I was able to rectify this issue by rebuilding gnome-base/libgnomecanvas and dev-cpp/libgnomecanvasmm, after rebuilding dev-cpp/gtkmm with the "accessibility" useflag.
Comment 5 Wily Unrest 2008-08-28 23:25:27 UTC
There is an Ardour bug about this, and the noted resolution is the same:

http://tracker.ardour.org/bug_view_advanced_page.php?bug_id=2196 
Comment 6 Alexis Ballier gentoo-dev 2008-08-29 06:28:53 UTC
(In reply to comment #4)
> I was able to rectify this issue by rebuilding gnome-base/libgnomecanvas and
> dev-cpp/libgnomecanvasmm, after rebuilding dev-cpp/gtkmm with the
> "accessibility" useflag.

this is really weird and might explain why I was never able to reproduce this problem.

@gnome-mm team: I didnt try to reproduce it, but if this is confirmed, this seems a rather grave automagic problem that had been causing lots of troubles to ardour users.
Comment 7 Rémi Cardona gentoo-dev 2008-08-29 10:16:23 UTC
Hum I don't know what could be causing this. A couple things though :

 1) glibmm and friends _really_ don't like being built with different C(XX)FLAGS. Check VDB to make sure they have all been built the same way. In doubt, rebuild them :) (glibmm, gtkmm, basically all *mm ...)

 2) The accessibility USE flag should only add the atkmm stuff. But I don't really know how far the changes go...

I really suggest going back to USE=-accessibility and trying out option #1 first. It's caused us a few nasty bug reports in the past, with really weird error messages.
Comment 8 Razvan Cojocaru 2008-09-22 14:25:50 UTC
Not sure if this helps, but after trying to figure out what the problem is and re-emerging the hell out of all of ardour's dependencies, I just gave up on the Gentoo version, and went with what I used to do on my Slackware system: got the source code for Ardour, and simply compiled it with VST support (scons VST=1).

Now it works just fine. All the dependencies are the same ones that the Gentoo build was using, I've added nothing else other than VST support.

scons --version:

SCons by Steven Knight et al.:
        script: v1.0.0.r3266, 2008/08/12 07:31:01, by knight on bangkok
        engine: v1.0.0.r3266, 2008/08/12 07:31:01, by knight on bangkok
Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008 The SCons Foundation
Comment 9 Alexis Ballier gentoo-dev 2008-09-22 17:11:41 UTC
(In reply to comment #8)
> Now it works just fine. All the dependencies are the same ones that the Gentoo
> build was using, I've added nothing else other than VST support.

Wrong, by default it doesn't use 'SYSLIBS' and thus you rebuild a good part of the gnomemm bindings just for ardour. No wonder you're not seeing the problem anymore by building without SYSLIBS.
Comment 10 Razvan Cojocaru 2008-09-24 09:42:31 UTC
(In reply to comment #9)
> Wrong, by default it doesn't use 'SYSLIBS' and thus you rebuild a good part of
> the gnomemm bindings just for ardour. No wonder you're not seeing the problem
> anymore by building without SYSLIBS.

Well, at least it's a temporary solution until the more abstract fix happens. As it is now, there's no other way to have ardour working on the latest Gentoo version - there's no other ebuild file in media-sound/ardour other than ardour-2.5.ebuild, and some of us really need ardour (and the latest version, at that) pretty badly.
Comment 11 Mart Raudsepp gentoo-dev 2009-03-23 08:40:13 UTC
This looks like another case or variation of bug 247249?
Comment 12 Alexis Ballier gentoo-dev 2009-03-24 09:01:23 UTC
(In reply to comment #11)
> This looks like another case or variation of bug 247249?

I tend to agree, the only time I had hit that bug is when I enabled the "accessibility" useflag because ardour needed it, on a fresh system with it enabled since the beginning I don't hit that bug.


*** This bug has been marked as a duplicate of bug 247249 ***