Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 235310 - x11-misc/read-edid-1.4.1-r1 build failed with linux-headers-2.6.26
Summary: x11-misc/read-edid-1.4.1-r1 build failed with linux-headers-2.6.26
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Desktop Misc. Team
URL:
Whiteboard:
Keywords:
: 235455 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-08-20 19:05 UTC by Leonard Khoo
Modified: 2010-07-16 07:15 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
kix for read-edid + linux-2.6.26 (read-edid-1.4.1-kernel-2.6.26.patch,516 bytes, patch)
2008-08-22 14:42 UTC, Matthew Kern
Details | Diff
x11-misc/read-edid/read-edid-2.0.0.ebuild (read-edid-2.0.0.ebuild,597 bytes, text/plain)
2008-10-21 08:56 UTC, steveb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leonard Khoo 2008-08-20 19:05:52 UTC
configure: creating ./config.status
config.status: creating Makefile
config.status: executing depfiles commands
i686-pc-linux-gnu-gcc -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"read-edid\" -DVERSION=\"1.4.1\" -I.     -O2 -march=native -pipe -fomit-frame-pointer -MT get-edid.o -MD -MP -MF .deps/get-edid.Tpo -c -o get-edid.o get-edid.c
i686-pc-linux-gnu-gcc -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"read-edid\" -DVERSION=\"1.4.1\" -I.     -O2 -march=native -pipe -fomit-frame-pointer -MT lrmi.o -MD -MP -MF .deps/lrmi.Tpo -c -o lrmi.o lrmi.c
i686-pc-linux-gnu-gcc -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"read-edid\" -DVERSION=\"1.4.1\" -I.     -O2 -march=native -pipe -fomit-frame-pointer -MT parse-edid.o -MD -MP -MF .deps/parse-edid.Tpo -c -o parse-edid.o parse-edid.c
lrmi.c: In function ‘set_regs’:
lrmi.c:305: error: ‘IF_MASK’ undeclared (first use in this function)
lrmi.c:305: error: (Each undeclared identifier is reported only once
lrmi.c:305: error: for each function it appears in.)
lrmi.c:305: error: ‘IOPL_MASK’ undeclared (first use in this function)
lrmi.c: In function ‘run_vm86’:
lrmi.c:784: error: ‘VIF_MASK’ undeclared (first use in this function)
lrmi.c:784: error: ‘TF_MASK’ undeclared (first use in this function)
lrmi.c: In function ‘LRMI_int’:
lrmi.c:873: error: ‘IF_MASK’ undeclared (first use in this function)
lrmi.c:873: error: ‘IOPL_MASK’ undeclared (first use in this function)
make: *** [lrmi.o] Error 1
make: *** Waiting for unfinished jobs....
mv -f .deps/parse-edid.Tpo .deps/parse-edid.Po
mv -f .deps/get-edid.Tpo .deps/get-edid.Po
 *
 * ERROR: x11-misc/read-edid-1.4.1-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2517:  Called _eapi0_src_compile
 *               ebuild.sh, line  604:  Called _eapi2_src_compile
 *               ebuild.sh, line  638:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"
 *  The die message:
 *   emake failed



Will try without LDFLAGS and get back to you.


Reproducible: Always




Portage 2.2_rc8 (default/linux/x86/2008.0, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.26-rc8-zen1.0 i686)
=================================================================
System uname: Linux-2.6.26-rc8-zen1.0-i686-Intel-R-_Core-TM-2_CPU_6300_@_1.86GHz-with-glibc2.0
Timestamp of tree: Wed, 20 Aug 2008 04:39:20 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.2-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.62-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu"
LINGUAS="en_GB en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl alsa amr berkdb bzip2 cli cracklib crypt cups dbus dri dts dvd flac fortran gdbm gpm hal iconv ipv6 isdnlog ithreads jpeg kde kdeenablefinal kdehiddenvisibility logrotate midi mmx mmxext mp3 mudflap ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre perl png pppd python qt3 readline reflection samba sane scanner sdl session speex spl sse sse2 ssl svga sysfs tcpd theora threads tiff truetype unicode v4l vcd vorbis win32codecs x264 x86 xanim xcb xorg xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard evdev mouse vmmouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en" USERLAND="GNU" VIDEO_CARDS="nvidia vmware vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Rafał Mużyło 2008-08-20 21:28:50 UTC
Googling suggests that those errors are caused by virtual/os-headers 2.6.26
or, more exactly, by the fact that those flags were either moved or renamed
to X86_EFLAGS_*.
But somebody else, who actually knows this stuff, should confirm.
Comment 2 Michal Kurgan (RETIRED) gentoo-dev 2008-08-21 03:49:33 UTC
Thanks Rafal for this valuable info.
Comment 3 Leonard Khoo 2008-08-21 14:48:06 UTC
comfirmed its linux-headers-2.6.26. Masking and downgrading linux-headers allows svgalib to compile cleanly.
Comment 4 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-08-22 14:29:25 UTC
*** Bug 235455 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-08-22 14:30:47 UTC
(In reply to comment #4)
> *** Bug 235455 has been marked as a duplicate of this bug. ***
> 


FYI,
pyrophobicman has supplied a patch in bug 235455.
Comment 6 Matthew Kern 2008-08-22 14:42:17 UTC
Created attachment 163557 [details, diff]
kix for read-edid + linux-2.6.26

here's the fix from the other bug, btw.
Comment 7 Yu Yuwei 2008-08-28 12:35:08 UTC
(In reply to comment #6)
> Created an attachment (id=163557) [edit]
> kix for read-edid + linux-2.6.26
> 
> here's the fix from the other bug, btw.
> 

Thanks! works for me :)
Comment 8 Andrew Muhametshin 2008-09-01 16:26:12 UTC
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../../../include -I../../../hw/kdrive/src -I../../../miext/damage -I../../../miext/shadow -I../../../Xext -I../../../fb -I../../../mi -I../../../hw/kdrive/linux -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/include/freetype2 -I/usr/include/pixman-1 -I/usr/include/hal -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include   -I../../../include -I../../../include -I../../../Xext -I../../../composite -I../../../damageext -I../../../xfixes -I../../../Xi -I../../../mi -I../../../miext/shadow  -I../../../miext/damage -I../../../render -I../../../randr -I../../../fb -DHAVE_KDRIVE_CONFIG_H     -march=pentium-m -O2 -pipe -fomit-frame-pointer -D_GNU_SOURCE -MT vm86.o -MD -MP -MF .deps/vm86.Tpo -c -o vm86.o vm86.c
vm86.c: In function 'Vm86DoInterrupt':
vm86.c:213: warning: too few arguments for format
vm86.c:225: error: 'IF_MASK' undeclared (first use in this function)
vm86.c:225: error: (Each undeclared identifier is reported only once
vm86.c:225: error: for each function it appears in.)
vm86.c:225: error: 'IOPL_MASK' undeclared (first use in this function)
vm86.c: In function 'Vm86Debug':
vm86.c:746: warning: format '%04lX' expects type 'long unsigned int', but argument 2 has type 'int'
vm86.c:746: warning: format '%04lX' expects type 'long unsigned int', but argument 3 has type 'int'
vm86.c:746: warning: format '%04lX' expects type 'long unsigned int', but argument 4 has type 'int'
vm86.c:746: warning: format '%04lX' expects type 'long unsigned int', but argument 5 has type 'int'
vm86.c:746: warning: format '%04lX' expects type 'long unsigned int', but argument 6 has type 'int'
make[3]: *** [vm86.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/x11-base/xorg-server-1.4.2/work/xorg-server-1.4.2/hw/kdrive/vesa'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/x11-base/xorg-server-1.4.2/work/xorg-server-1.4.2/hw/kdrive'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-base/xorg-server-1.4.2/work/xorg-server-1.4.2/hw'
make: *** [all-recursive] Error 1
 *
 * ERROR: x11-base/xorg-server-1.4.2 failed.



WARNING: repository at /usr/local/portage/special is missing a repo_name entry
Portage 2.2_rc8 (default-linux/x86/2007.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r2 i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r2-i686-Intel-R-_Celeron-R-_M_processor_1.40GHz-with-glibc2.0
Timestamp of tree: Mon, 01 Sep 2008 16:03:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.1/env /usr/kde/4.1/share/config /usr/kde/4.1/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="ru_RU.UTF-8"
LDFLAGS=""
LINGUAS="ru en"
MAKEOPTS=""
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/kdesvn-portage /usr/local/portage/special"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 7zip X a52 aac accessibility acl acpi aiglx akode alsa amarok arts audiofile battery beep berkdb bluetooth bzip2 cairo cdparanoia cdr cdrom cli cpudetection cpufreq cracklib crypt css cups dbus dga dhcp disk-partition divx djvu dri dvd dvdnav dvdr dvdread eds emboss encode esd evo fam fame ffmpeg firefox flac foomaticdb gdbm gif gimp glade glibc-omitfp gnokii gphoto2 gpm gstreamer gtk hal iconv id3 ieee1394 imagemagick imlib irda isdnlog jabber jack java java5 javascript jpeg kde kdexdeltas kdrive kqemu lame lcms ldap lirc lm_sensors mad midi mikmod mjpeg mmx mmxext mp2 mp3 mp4 mp4live mpeg mudflap ncurses networkmanager nfs nls nptl nptlonly ntfs obex ogg openexr opengl openmp oss pam pcmcia pcre pdf perl png pulseaudio python qt3 qt3support qt4 quicktime rar rcc rdesktop readline reflection regex rtc samba scanner sdl sdl-image sdl-sound session slang sockets socks5 sox spell spl sqlite3 sse sse2 ssl svg tcpd theora tiff truetype unicode usb utf8 v4l v4l2 vcd vidix vnc vncviewer vorbis wacom wav wavpack wifi win32codecs wma wmf x86 xcomposite xft xine xml xorg xosd xpm xrandr xrender xscreensaver xv xvmc yv12 zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1    emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m       maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse wacom synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" USERLAND="GNU" VIDEO_CARDS="i810 vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 9 Conrad Kostecki 2008-09-29 19:19:33 UTC
So is it going to be commited to portage? :)
Comment 10 Matthew Kern 2008-09-29 19:26:58 UTC
(In reply to comment #9)
> So is it going to be commited to portage? :)

looking to get 2.0.0 into portage instead - this bug made me maintainer of read-edid - see http://polypux.org/projects/read-edid/

2.0.0 works on 32 and 64 bit x86, and *may* work on other archs too.

Now seems to only not work with nvidia drivers.
Comment 11 James L. Hammons 2008-10-06 15:34:45 UTC
Confirmed it works on my setup (~x86). In the meantime, it would be nice to push this patch into the tree as -r2 so that this bug can be closed out. :-)
Comment 12 Bob Raitz 2008-10-16 06:15:09 UTC
(In reply to comment #11)
> Confirmed it works on my setup (~x86). In the meantime, it would be nice to
> push this patch into the tree as -r2 so that this bug can be closed out. :-)
> 

I agree. I just modified the ebuild, and this works. Nice.

Blessed be!
Pappy
Comment 13 steveb 2008-10-21 08:56:39 UTC
Created attachment 169272 [details]
x11-misc/read-edid/read-edid-2.0.0.ebuild

A quickly made ebuild for 2.0.0
Comment 14 neo86 2008-11-10 22:51:49 UTC
Can this finally be merged?
Comment 15 Matthew Kern 2008-11-10 23:30:19 UTC
(In reply to comment #14)
> Can this finally be merged?
> 

please... I don't know what's taking you devs so long :P
Comment 16 Ben de Groot (RETIRED) gentoo-dev 2008-11-11 15:11:43 UTC
Committed both 1.4.2 and 2.0.0. Please test and report any problems.
Comment 17 Benjamin Börngen-Schmidt 2009-01-22 21:26:07 UTC
Hi there,

the bug doesn't seem to be solved. I get the exact same error when i try to compile the package with the header files 2.6.27.

# emerge --info
Portage 2.1.6.4 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.27-gentoo-r8 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-i686-AMD_Athlon-tm-_XP_2800+-with-glibc2.0
Timestamp of tree: Wed, 21 Jan 2009 21:15:01 +0000
distcc 3.0 i686-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-lang/python:     2.4.4-r6, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer -mno-tls-direct-seg-refs"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer -mno-tls-direct-seg-refs"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.intergenia.de http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ "
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acl apache2 berkdb bzip2 cli cracklib crypt dri fortran gdbm gpm iconv isdnlog lm_sensors midi mudflap mysql ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection samba session slang snmp spl ssl sysfs tcpd unicode x86 xorg xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 18 steveb 2009-01-22 22:50:32 UTC
(In reply to comment #17)
> the bug doesn't seem to be solved. I get the exact same error when i try to
> compile the package with the header files 2.6.27.
> 
Hmm... let me look in my magic crystal ball and let me guess what version of edid you used and/or what patch you tried? Hmmm... I see, I see... NOTHING!

Hey! How about giving some real information what you have done and not just saying it does not work without giving information what edid version you tried and if you have used the patch from this bug report or not?
Comment 19 Benjamin Börngen-Schmidt 2009-01-23 12:28:57 UTC
Okay,

I really dont know what info I need to give to you. As you can see I'm using the stable tree x86, with the newest available kernel 2.6.27.

I tried to reemerge my whole system with emerge -e world, since it has been a time I last updated, well basicly to be sure everything works.

I did not apply any patch nor do I have any packages in my keywords file. Maybe I should try to add this package to the keywords file. But since it seems all those folks using the patched packages do not have problems, maybe it is possible to add those to the stable tree??

Comment 20 steveb 2009-01-23 13:20:43 UTC
(In reply to comment #19)
> Okay,
> 
> I really dont know what info I need to give to you.
>
To me? You don't have to give anything to me.


> As you can see I'm using
> the stable tree x86, with the newest available kernel 2.6.27.
> 
Okay.


> I tried to reemerge my whole system with emerge -e world, since it has been a
> time I last updated, well basicly to be sure everything works.
> 
> I did not apply any patch nor do I have any packages in my keywords file. Maybe
> I should try to add this package to the keywords file. But since it seems all
> those folks using the patched packages do not have problems, maybe it is
> possible to add those to the stable tree??
> 
How about reading comment #16 and emerging on of the mentioned revisions and report any issues back here? Your original message was that it does not work. What does not work? read-edid-2.0.0? read-edid-1.4.2? Or the stable read-edid-1.4.1-r1? If you are emerging read-edid-1.4.1-r1 and it does not work, then your message here in this bug report is WRONG! Try emerging read-edid-1.4.2 or read-edid-2.0.0 and report back if they are not working, but don't complain here that read-edid-1.4.1-r1 is not working for you because this bug report here is all about read-edid-1.4.1-r1 not working with newer kernel revisions and we know that because that's the reason for this bug report here.

// Steve

Comment 21 Benjamin Börngen-Schmidt 2009-01-23 15:40:37 UTC
Okay Steve,

then I got something wrong. I was trying to emerge 1.4.1-r1, which obviously doesn't work.

I'm sorry for mixing up things.
Comment 22 Carlos Costa 2009-02-19 12:35:55 UTC
(In reply to comment #21)
> Okay Steve,
> 
> then I got something wrong. I was trying to emerge 1.4.1-r1, which obviously
> doesn't work.
> 
> I'm sorry for mixing up things.
> 

Please, try to use the ~x86 version instead the stable one. It worked for me. You should use nano to edit /etc/portage/package.keywords to add the keyword:

=x11-misc/read-edid-1.4.2 ~x86 

Save and run emerge again.
Comment 23 Luca Santarelli 2009-03-04 21:34:12 UTC
1.4.2 working here on x86, Pentium III Coppermine, with no monitor attached. Yes, it has been dragged into by lm_sensors.

If I may say so freely, I feel rather uneasy seeing that two stable packages have been conflicting for six months and the "RESOLUTION FIXED" means "please, use ~x86".