Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 234916 - media-libs/libpng-1.2.30 error: x[DA]bd: invalid chunk type (unable to load images)
Summary: media-libs/libpng-1.2.30 error: x[DA]bd: invalid chunk type (unable to load i...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: 235130 (view as bug list)
Depends on: 235072
Blocks:
  Show dependency tree
 
Reported: 2008-08-16 13:19 UTC by David Heidelberg (okias)
Modified: 2009-10-30 11:18 UTC (History)
23 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Heidelberg (okias) 2008-08-16 13:19:01 UTC
~ $ psi                                                        
libpng warning: cHRM: CRC error                                               
libpng error: x[DA][A4][93]: invalid chunk type                               
Iconset::load(): Couldn't load image/png (appearance.png) graphic for the psi/appearance icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error                                                                                                         
libpng error: x[DA]b[FC]: invalid chunk type                                                                                            
Iconset::load(): Couldn't load image/png (account.png) graphic for the psi/account icon for the Crystal - System (default) iconset      
libpng warning: cHRM: CRC error                                                                                                         
libpng error: x[DA]d[93]: invalid chunk type                                                                                            
Iconset::load(): Couldn't load image/png (add.png) graphic for the psi/addContact icon for the Crystal - System (default) iconset       
libpng warning: cHRM: CRC error                                                                                                         
libpng error: x[DA]b[DC]: invalid chunk type                                                                                            
Iconset::load(): Couldn't load image/png (disco.png) graphic for the psi/disco icon for the Crystal - System (default) iconset          
libpng warning: cHRM: CRC error                                                                                                         
libpng error: x[DA]b[FC]: invalid chunk type                                                                                            
Iconset::load(): Couldn't load image/png (events.png) graphic for the psi/events icon for the Crystal - System (default) iconset        
libpng warning: cHRM: CRC error                                                                                                         
libpng error: x[DA]bd: invalid chunk type                                                                                               
Iconset::load(): Couldn't load image/png (groupchat.png) graphic for the psi/groupChat icon for the Crystal - System (default) iconset  
libpng warning: cHRM: CRC error                                                                                                         
libpng error: x[DA]b[FC]: invalid chunk type                                                                                            
Iconset::load(): Couldn't load image/png (vcard.png) graphic for the psi/vCard icon for the Crystal - System (default) iconset          
libpng warning: cHRM: CRC error                                                                                                         
libpng error: [38][8D][AD][91]: invalid chunk type                                                                                      
Iconset::load(): Couldn't load image/png (configure_toolbars.png) graphic for the psi/toolbars icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error                                                                                                               
libpng error: x[DA]b[F8]: invalid chunk type                                                                                                  
Iconset::load(): Couldn't load image/png (play_sounds.png) graphic for the psi/playSounds icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: x[DA]b[F8]: invalid chunk type
Iconset::load(): Couldn't load image/png (play_sounds.png) graphic for the psi/voice icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: x[DA]b[FC]: invalid chunk type
Iconset::load(): Couldn't load image/png (psimain.png) graphic for the psi/main icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: [38][8D]mS: invalid chunk type
Iconset::load(): Couldn't load image/png (remove.png) graphic for the psi/remove icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: x[DA]b[FC]: invalid chunk type
Iconset::load(): Couldn't load image/png (status.png) graphic for the psi/status icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: x[DA]b[FC]: invalid chunk type
Iconset::load(): Couldn't load image/png (send.png) graphic for the psi/sendMessage icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: x[DA][EC][7D]: invalid chunk type
Iconset::load(): Couldn't load image/png (logo_128.png) graphic for the psi/logo_128 icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: x[DA]b[F8]: invalid chunk type
Iconset::load(): Couldn't load image/png (smile.png) graphic for the psi/smile icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: x[DA]b[FC]: invalid chunk type
Iconset::load(): Couldn't load image/png (send.png) graphic for the psi/email icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: x[DA]b[FC]: invalid chunk type
Iconset::load(): Couldn't load image/png (play.png) graphic for the psi/play icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: x[DA]b[FC]: invalid chunk type
Iconset::load(): Couldn't load image/png (upload.png) graphic for the psi/upload icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: x[DA]b[FC]: invalid chunk type
Iconset::load(): Couldn't load image/png (download.png) graphic for the psi/download icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: [00][FF][00][FF]: invalid chunk type
Iconset::load(): Couldn't load image/png (show_offline.png) graphic for the psi/show_offline icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: [00][FF][00][FF]: invalid chunk type
Iconset::load(): Couldn't load image/png (show_away.png) graphic for the psi/show_away icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: x[DA]b[FA]: invalid chunk type
Iconset::load(): Couldn't load image/png (show_hidden.png) graphic for the psi/show_hidden icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: x[DA]b[FC]: invalid chunk type
Iconset::load(): Couldn't load image/png (whiteboarding/translate.png) graphic for the psi/translate icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: x[DA]b[8C]: invalid chunk type
Iconset::load(): Couldn't load image/png (whiteboarding/rotate.png) graphic for the psi/rotate icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: [00][FF][00][FF]: invalid chunk type
Iconset::load(): Couldn't load image/png (whiteboarding/draw_ellipses.png) graphic for the psi/drawEllipses icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: [00][FF][00][FF]: invalid chunk type
Iconset::load(): Couldn't load image/png (whiteboarding/draw_circles.png) graphic for the psi/drawCircles icon for the Crystal - System (default) iconset
libpng warning: cHRM: CRC error
libpng error: [00][FF][00][FF]: invalid chunk type
Iconset::load(): Couldn't load image/png (whiteboarding/draw_rectangles.png) graphic for the psi/drawRectangles icon for the Crystal - System (default) iconset

This happening after updating to lastest libpng.

Reproducible: Always

Steps to Reproduce:
1. Update to version: libpng-1.2.30
2. Run psi-0.11
3.

Actual Results:  
Not working psi with lastest libpng

Expected Results:  
Working psi with lastest libpng
Comment 1 Vasilis Lourdas 2008-08-16 13:37:14 UTC
I also experience problems with the latest ~ libpng (1.2.30) and a few png files (not all). Reverting back to 1.2.27 and all is fine.
Comment 2 Yar Odin 2008-08-16 14:18:37 UTC
(In reply to comment #0)
same to me on libpng-1.2.30 with some png icons on all soft with libpng dependence
Comment 3 David Bařina 2008-08-16 16:44:57 UTC
same problem is with games-strategy/hedgewars-0.9.6, games-strategy/boswars-2.5, games-action/extreme-tuxracer-0.4, games-fps/cube-20050829-r1 and many others; only media-libs/libpng-1.2.30 affected
Comment 4 F. Di Milia (root_tux_linux) 2008-08-16 19:40:18 UTC
same problem here with  lastes libpng.

can't see icons in firefox, kopete and i cant see my  png wallpaper.
Comment 5 Billy DeVincentis 2008-08-16 22:43:16 UTC
Same here, made me crazy because I had just resized partitions on my box, I thought that somehow files had been corrupted. Seems like some png images work fine while others don't.
Comment 6 Oldrich Jedlicka 2008-08-17 06:21:05 UTC
Same here. My KDE's icons got ruined (only some displayed). Isn't this version of libpng a candidate for hard-masking?
Comment 7 Oldrich Jedlicka 2008-08-17 06:36:53 UTC
Just to note: downgrading to 1.2.27 fixed the problem for me.
Comment 8 Joël 2008-08-17 10:56:25 UTC
Same here, and works fine with 1.2.27. Please hardmask 1.2.30 for now...
Comment 9 Àngel Díaz 2008-08-17 11:11:11 UTC
Same as #7 and #8
Comment 10 Àngel Díaz 2008-08-17 11:15:13 UTC
http://www.libpng.org/pub/png/libpng.html says that current version is 1.2.29 but I can't see 1.2.30.

Comment 11 Andreas Proteus 2008-08-17 13:07:56 UTC
(In reply to comment #10)
> but I can't see 1.2.30.
> 
It there all right (http://libpng.sourceforge.net/) but no good.

Same problems here.  My heart missed a beat or two, but everything was fixed when I downgraded to 1.2.27.  I masked the blighter. 

Thank you all.
Comment 12 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2008-08-17 19:11:43 UTC
vapier: you put it in, should we block it for now?
Comment 13 Lars Wendler (Polynomial-C) gentoo-dev 2008-08-18 01:25:48 UTC
Before I upgraded libpng to version 1.2.30 I used version 1.2.29 from an ebuild in my local overlay. That version did not have the bug described here so this is a bug newly introduced with version 1.2.30 I suppose.
Comment 14 Geert Vanhaute 2008-08-18 16:24:53 UTC
Please, block it.
I had problems with icons disappearing in Nero.
I thought it was a problem with Nero but reinstalling and erasing config didn't
help.
Until I downgraded libpng to 1.2.29... Problem solved.
Comment 15 Tomáš Chvátal (RETIRED) gentoo-dev 2008-08-18 18:01:01 UTC
This is only 64b issue, can't reproduce on 32b machine.... so please mask it on amd64
Comment 16 Ulrich Müller gentoo-dev 2008-08-18 18:18:24 UTC
(In reply to comment #15)
> This is only 64b issue, can't reproduce on 32b machine.... so please mask
> it on amd64

Nope, it definitely is an issue on x86 as well. For example, games-strategy/wesnoth-1.4.4 cannot load some of its terrain images.
Comment 17 Peter Volkov (RETIRED) gentoo-dev 2008-08-18 18:21:06 UTC
*** Bug 235130 has been marked as a duplicate of this bug. ***
Comment 18 coran.fisher@gmail.com 2008-08-18 18:22:49 UTC
I am operating in 32bit and experienced this issue.  Some programs liked shared Skype would crash when opening a chat giving the errors listed in the original description.  I also get those errors on the console if I run something like kcontrol.  Downgrading fixed it.  
Comment 19 Piotr 2008-08-18 18:46:35 UTC
Same here on 64-bit platform.
I was wondering why some icons have disapeared.
Comment 20 Bob Raitz 2008-08-18 20:54:56 UTC
Actually, I can now verify that this bug also causes problems with 32 bit x86. After masking libpng-1.3.0 on my old Toshiba laptop, my KDE icons have come back. And here I thought they went away because of a crash. 

I can't begin to tell y'all how much time and effort was saved. I was going to do a full world reemerge to try to fix my KDE. WHEW!

EMERGE --INFO FOR MACHINE IN QUESTION:

Portage 2.2_rc8 (default-linux/x86/2007.0, gcc-4.2.3, glibc-2.8_p20080602-r0, 2.6.26-gentoo i686)
=================================================================
System uname: Linux-2.6.26-gentoo-i686-Intel-R-_Celeron-TM-_CPU_1066MHz-with-glibc2.0
Timestamp of tree: Mon, 18 Aug 2008 05:33:01 +0000
distcc 2.18.3 i486-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.12
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i486-pc-linux-gnu"
CFLAGS="-march=pentium3 -O2 -pipe"
CHOST="i486-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=pentium3 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distcc distlocks metadata-transfer parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS=""
LINGUAS="en"
MAKEOPTS="-j32"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://192.168.0.130/gentoo-portage"
USE="X a52 aac aalib acl alsa avi berkdb bitmap-fonts cairo cdr cli cracklib crypt css cups dbus dri dv dvd dvdr dvdread eds emboss encode fam ffmpeg flac foomatic foomaticdb fortran gdbm gif gpm gtk hal iconv ipv6 isdnlog jpeg kde kdgraphics lame ldap live mad midi mikmod mmx mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdcre pdf perl php png ppds pppd python qt3 quicktime readline reflection samba sdl session slang slp spell spl sse ssl swat tcpd truetype udev unicode vorbis wifi win32codecs wxwindows x86 xml xorg xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 	emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m 	maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="i810"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


THANKS AGAIN!!!

Blessed be!
Pappy
Comment 21 Joël 2008-08-18 21:01:54 UTC
Ha, for me it happened right after a power failure and fsck. So I thought my icons were corrupted...

Yes it happens on x86 too.
Comment 22 Stephan Friedrichs 2008-08-18 21:46:01 UTC
I load some png files using imlib2-1.4.1 and I get the same errors when working with png files. A Downgrade from libpng-1.2.30 to 1.2.27 seems to fix the problem.
Comment 23 Andreas Westin 2008-08-19 07:20:40 UTC
According to a mail on the libpng mailing list it has been fixed and 1.2.31 will be released on Aug 21 if no other bugs are found.
Comment 24 Peter Volkov (RETIRED) gentoo-dev 2008-08-19 08:16:43 UTC
This problem makes applications to behave in rather unpredictable way (e.g. psi cleaned all my contacts after attempt to start it with libpng-1.2.30) so I went ahead and bumped libpng to libpng-1.2.31rc01 which is supposed to fix (and fixes here) this problem.

http://sourceforge.net/mailarchive/message.php?msg_id=e56ccc8f0808182029q1a676ca8s4722f86d42707540%40mail.gmail.com

FIXED.
Comment 25 Bob Raitz 2008-08-19 18:40:47 UTC
This came into portage about 3:00 08-19-2008 AM CST, and I can report that it does fix the problem, on both 32 and 64 bit systems.

Thanks all!

Blessed be!
Pappy