Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 233835 - app-admin/eselect-opengl - /usr/include/GL/glext.h:1:3: error: invalid preprocessing directive #Copyright
Summary: app-admin/eselect-opengl - /usr/include/GL/glext.h:1:3: error: invalid prepro...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-03 19:32 UTC by Tonko Mulder
Modified: 2009-02-27 19:53 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
The build.log (build.log,57.34 KB, text/plain)
2008-08-03 20:27 UTC, Tonko Mulder
Details
My glext.h file (glext.h,11.03 KB, text/plain)
2008-08-07 05:19 UTC, Tonko Mulder
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tonko Mulder 2008-08-03 19:32:47 UTC
While emerging =media-libs/glitz-0.5.6 a lot of /usr/include/GL/glext.h error messages appear and emerge stops

Reproducible: Always

Steps to Reproduce:
1. emerge =media-libs/glitz-0.5.6
Actual Results:  
emerge glitz fails

Expected Results:  
emerge glitz succeeds

Zebaoth ~ # emerge --info
Portage 2.2_rc6 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r0, 2.6.26-gentoo-MSI x86_64)
=================================================================
System uname: Linux-2.6.26-gentoo-MSI-x86_64-AMD_Athlon-tm-_64_X2_Dual-Core_Processor_TK-55-with-glibc2.2.5
Timestamp of tree: Sun, 03 Aug 2008 18:15:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r14, 2.5.2-r7
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=x86-64 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=x86-64 -pipe"
DISTDIR="/home/portage/distfiles/"
FEATURES="ccache distcc distlocks metadata-transfer nodoc noinfo parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.muntinternet.net/pub/gentoo/"
LDFLAGS="-Wl,-O1"
LINGUAS="nl nl_NL en en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp/"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/x11 /usr/local/portage/layman/gentopia /usr/local/portage/layman/desktop-effects"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 asf aspell bash-completion berkdb bluetooth branding bzip2 cairo cdb cdda cddb cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo exif fam firefox fortran gdbm gif gnome gnome-keyring gpm gstreamer gtk hal iconv ieee1394 ipv6 isdnlog java jpeg kerberos laptop ldap libnotify lm_sensors mad madwifi midi mikmod mmx mono motif mp3 mpeg msn mudflap multilib mysql ncurses networkmanager nls nptl nptlonly nsplugin ogg opengl openmp pam pcmcia pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba sdl session sox spell spl sse sse2 ssl startup-notification svg sysfs syslog tcpd theora tiff truetype unicode usb vim-syntax vorbis xcomposite xine xml xorg xulrunner xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="nl nl_NL en en_US" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Gilles Dartiguelongue gentoo-dev 2008-08-03 19:41:15 UTC
please let componet set to ebuilds as instructed by bugzilla.
Comment 2 Tonko Mulder 2008-08-03 20:27:25 UTC
Created attachment 162155 [details]
The build.log

Attached build.log with detailled information
Comment 3 Carsten Lohrke (RETIRED) gentoo-dev 2008-08-04 14:20:33 UTC
The ebuild depends correctly on virtual/opengl. You probably didn't set a valid OpenGL implementation. Use `eselect opengl` etc. to do so.
Comment 4 Tonko Mulder 2008-08-04 15:15:56 UTC
(In reply to comment #3)
> The ebuild depends correctly on virtual/opengl. You probably didn't set a valid
> OpenGL implementation. Use `eselect opengl` etc. to do so.
> 

I have the following eselect list

Zebaoth ~ # eselect opengl list
Available OpenGL implementations:
  [1]   xorg-x11 *
It's there and set as default
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2008-08-04 15:24:15 UTC
See if `eselect opengl set 1' fixes the issue.
Comment 6 Tonko Mulder 2008-08-04 16:13:36 UTC
(In reply to comment #5)
> See if `eselect opengl set 1' fixes the issue.
> 

I get the same error after setting it to '1'
Comment 7 Jeroen Roovers (RETIRED) gentoo-dev 2008-08-05 17:20:48 UTC
Which version of media-libs/mesa do you have? (`emerge -vp media-libs/mesa')
Comment 8 Tonko Mulder 2008-08-05 20:17:22 UTC
(In reply to comment #7)
> Which version of media-libs/mesa do you have? (`emerge -vp media-libs/mesa')
> 

I have media-libs/mesa-9999 the live git ebuild.
I have a git X enviroment, otherwise X freezes if I use the portage version
Comment 9 Jeroen Roovers (RETIRED) gentoo-dev 2008-08-07 01:54:10 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > Which version of media-libs/mesa do you have? (`emerge -vp media-libs/mesa')
> > 
> 
> I have media-libs/mesa-9999 the live git ebuild.

When did you emerge that?

> I have a git X enviroment, otherwise X freezes if I use the portage version

Maybe you need a live git ebuild for glitz...
Comment 10 Doug Goldstein (RETIRED) gentoo-dev 2008-08-07 02:03:15 UTC
Attach your /usr/include/GL/glext.h, it's going to be clearly bogus C code based on the error messages.
Comment 11 Tonko Mulder 2008-08-07 05:19:49 UTC
Created attachment 162406 [details]
My glext.h file

If I try the git ebuild of glitz it fails on autoconf. And so does cairo, I heard on the mailinglist that this was a known issue.
Comment 12 Doug Goldstein (RETIRED) gentoo-dev 2008-08-07 22:53:04 UTC
(In reply to comment #11)
> Created an attachment (id=162406) [edit]
> My glext.h file
> 
> If I try the git ebuild of glitz it fails on autoconf. And so does cairo, I
> heard on the mailinglist that this was a known issue.
> 

That's not a C header file... that's an eselect, so it's bash code. Something is wrong with your OpenGL setup. Wouldn't be surprised that there's an issue with the mesa or opengl virtual.

Bring in the mesa/opengl folks to figure this one out.
Comment 13 Jeroen Roovers (RETIRED) gentoo-dev 2008-08-08 01:00:00 UTC
OK, let's blame eselect-opengl...
Comment 14 Łukasz Damentko (RETIRED) gentoo-dev 2008-10-30 16:54:47 UTC
Reassigning to herd since eradicator has left Gentoo.
Comment 15 Rémi Cardona gentoo-dev 2009-02-27 19:53:05 UTC
glitz is unmainted. Last commit in the upstream repo is almost a year-and-half old.

I think we'll remove USE=glitz from cairo very soon.

As for the eselect-opengl stuff, I have no idea how this happened. Can you still reproduce with current versions? Does "eselect opengl set {x11,nvidia,...} --impl-headers" help at all?

Don't hesitate to reopen this bug if you still have the issue.

Thanks