Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 233691 - media-libs/libsidplay-2.1.1-r1.ebuild /w gcc43 and openmode patch
Summary: media-libs/libsidplay-2.1.1-r1.ebuild /w gcc43 and openmode patch
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Hanno Böck
Depends on:
Blocks: gcc-4.3
  Show dependency tree
Reported: 2008-08-02 11:02 UTC by Steffen 'j0inty' Stollfuß
Modified: 2008-11-16 20:00 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

libsidplay-2.1.1-r1.ebuild (libsidplay-2.1.1-r1.ebuild,1.13 KB, text/plain)
2008-08-02 11:02 UTC, Steffen 'j0inty' Stollfuß
libsidplay2-gcc43.patch (libsidplay2-gcc43.patch,1.23 KB, patch)
2008-08-02 11:03 UTC, Steffen 'j0inty' Stollfuß
Details | Diff
libsidplay2-openmode.patch (libsidplay2-openmode.patch,1.23 KB, patch)
2008-08-02 11:03 UTC, Steffen 'j0inty' Stollfuß
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen 'j0inty' Stollfuß 2008-08-02 11:02:00 UTC

the actually ebuild 2.1.1 doesn't compile with gcc-4.3 so I search for bugfixes and added two patch that solved the problems.

* added gcc43.patch
* added openmode.patch


Reproducible: Always
Comment 1 Steffen 'j0inty' Stollfuß 2008-08-02 11:02:38 UTC
Created attachment 161978 [details]
Comment 2 Steffen 'j0inty' Stollfuß 2008-08-02 11:03:12 UTC
Created attachment 161980 [details, diff]
Comment 3 Steffen 'j0inty' Stollfuß 2008-08-02 11:03:34 UTC
Created attachment 161981 [details, diff]
Comment 4 Hanno Böck gentoo-dev 2008-08-02 17:47:47 UTC
I've combined them to one patch and also submitted it upstream (although they seem quite dead).
Comment 5 Christian Glindkamp 2008-11-16 15:05:15 UTC
This does not seem to have landed in portage, how is this fixed?
Comment 6 Hanno Böck gentoo-dev 2008-11-16 18:31:00 UTC
hmm, seems I've not committed the fix...

Thanks for the note, should be done now, if not please re-open.
Comment 7 Christian Glindkamp 2008-11-16 20:00:15 UTC
It works now, thanks for the fast response.