Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 233316 - media-sound/easytag-2.1.6 fails to build with sys-devel/gcc-4.3.1-r1
Summary: media-sound/easytag-2.1.6 fails to build with sys-devel/gcc-4.3.1-r1
Status: RESOLVED DUPLICATE of bug 233273
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-07-29 19:24 UTC by Nikolay Orlyuk
Modified: 2008-07-29 19:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
easytag-2.1.6-gcc43.patch (easytag-2.1.6-gcc43.patch,360 bytes, patch)
2008-07-29 19:26 UTC, Nikolay Orlyuk
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nikolay Orlyuk 2008-07-29 19:24:37 UTC
missing string.h header in src/id3lib/c_wrapper.cpp

Reproducible: Always
Comment 1 Nikolay Orlyuk 2008-07-29 19:26:36 UTC
Created attachment 161653 [details, diff]
easytag-2.1.6-gcc43.patch

put

sed -i.orig 's|^//\(#include *<string.h>\)|\1|' src/id3lib/c_wrapper.cpp

into ebuild
Comment 2 Samuli Suominen gentoo-dev 2008-07-29 19:41:26 UTC
We are not using the bundled id3lib, so..

*** This bug has been marked as a duplicate of bug 233273 ***