Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 232203 - Celtx - All-in-one media pre-production software
Summary: Celtx - All-in-one media pre-production software
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
Depends on:
Reported: 2008-07-18 14:08 UTC by sam logen
Modified: 2012-05-15 18:04 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

Initial rough ebuild, not using mozconfig script (my first ebuild file) (celtx-10.ebuild,1.69 KB, text/plain)
2008-07-18 14:11 UTC, sam logen
Licence for the software (CePL-1.2,20.57 KB, text/plain)
2008-07-21 00:02 UTC, sam logen

Note You need to log in before you can comment on or make changes to this bug.
Description sam logen 2008-07-18 14:08:40 UTC
I've been trying to write from scratch an ebuild for the program Celtx ( but without success.  I learned this program was built from the mozilla framework, so I checked several mozilla ebuilds (firefox, seamonkey, etc.).  They all have unfamiliar nonstandard scripting (mozconfig and such).  I'm wondering if anyone is familiar enough with this to arrange an ebuild for Celtx.

I'll include my rough ebuild and the output that this ebuild generated when I tried to emerge it.

Reproducible: Always

Steps to Reproduce:
Comment 1 sam logen 2008-07-18 14:11:43 UTC
Created attachment 160727 [details]
Initial rough ebuild, not using mozconfig script (my first ebuild file)

ERROR OUTPUT OF 'emerge celtx'

c++  -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic -Os -pipe -fomit-frame-pointer -msse -mfpmath=sse -mmmx -m3dnow -march=athlon-xp -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O -fPIC -shared -Wl,-z,defs -Wl,-h, -o  nsLayoutModule.o nsContentHTTPStartup.o nsContentDLF.o nsLayoutStatics.o    -Wl,-O1   -Wl,--whole-archive ../../dist/lib/libgkbase_s.a ../../dist/lib/libgkgeneric_s.a ../../dist/lib/libgkforms_s.a ../../dist/lib/libgkstyle_s.a ../../dist/lib/libgkprinting_s.a ../../dist/lib/libgktable_s.a ../../dist/lib/libgkxulbase_s.a ../../dist/lib/libgkconbase_s.a ../../dist/lib/libgkconcvs_s.a ../../dist/lib/libgkconevents_s.a ../../dist/lib/libgkconhtmlcon_s.a ../../dist/lib/libgkconhtmldoc_s.a ../../dist/lib/libgkconxmlcon_s.a ../../dist/lib/libgkconxmldoc_s.a ../../dist/lib/libgkconxbl_s.a ../../dist/lib/libgkconxulcon_s.a ../../dist/lib/libgkconxuldoc_s.a ../../dist/lib/libgkview_s.a ../../dist/lib/libjsdombase_s.a ../../dist/lib/libjsdomevents_s.a ../../dist/lib/libjsurl_s.a ../../dist/lib/libjsdomstorage_s.a  ../../dist/lib/libgkxultree_s.a ../../dist/lib/libgkxulgrid_s.a ../../dist/lib/libgkconxultmpl_s.a  ../../dist/lib/libinspector_s.a  ../../dist/lib/libgkmathmlcon_s.a ../../dist/lib/libgkmathmlbase_s.a  ../../dist/lib/libgkcontentxtf_s.a ../../dist/lib/libgkxtfbase_s.a  -Wl,--no-whole-archive -L../../dist/bin -L../../dist/lib -lgkgfx ../../dist/lib/libunicharutil_s.a -L../../dist/bin -lxpcom -lxpcom_core  -L../../dist/bin -L../../dist/lib -lplds4 -lplc4 -lnspr4 -lpthread -ldl -L../../dist/bin -lmozjs  -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0    -lcairo    -Wl,--version-script -Wl,../../build/unix/gnu-ld-scripts/components-version-script -Wl,-Bsymbolic -ldl -lm
../../dist/lib/libgkconcvs_s.a(nsCanvasRenderingContext2D.o): In function `nsCanvasRenderingContext2D::Destroy()':
nsCanvasRenderingContext2D.cpp:(.text+0x2339): undefined reference to `XFreePixmap'
../../dist/lib/libgkconcvs_s.a(nsCanvasRenderingContext2D.o): In function `nsCanvasRenderingContext2D::SetDimensions(int, int)':
nsCanvasRenderingContext2D.cpp:(.text+0x6650): undefined reference to `XRenderFindStandardFormat'
nsCanvasRenderingContext2D.cpp:(.text+0x6676): undefined reference to `XListPixmapFormats'
nsCanvasRenderingContext2D.cpp:(.text+0x66b0): undefined reference to `XFree'
nsCanvasRenderingContext2D.cpp:(.text+0x66fd): undefined reference to `XCreatePixmap'
collect2: ld returned 1 exit status
gmake[3]: *** [] Error 1
gmake[3]: Leaving directory `/var/tmp/portage/app-editors/celtx-10/work/mozilla/layout/build'
gmake[2]: *** [libs] Error 2
gmake[2]: Leaving directory `/var/tmp/portage/app-editors/celtx-10/work/mozilla/layout'
gmake[1]: *** [tier_9] Error 2
gmake[1]: Leaving directory `/var/tmp/portage/app-editors/celtx-10/work/mozilla'
make: *** [default] Error 2
 * ERROR: app-editors/celtx-10 failed.
 * Call stack:
 *     , line   49:  Called src_compile
 *             environment, line 2046:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed"
 *  The die message:
 *   emake failed
Comment 2 sam logen 2008-07-18 14:12:56 UTC
And my emerge --info

# emerge --info
Portage (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-Base-r8-Core i686)
System uname: 2.6.24-Base-r8-Core i686 AMD Athlon(tm) XP 3000+
Timestamp of tree: Sun, 13 Jul 2008 19:45:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r13
dev-python/pycrypto: 2.0.1-r6
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
CFLAGS="-Os -pipe -fomit-frame-pointer -msse -mfpmath=sse -mmmx -m3dnow -march=athlon-xp"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-Os -pipe -fomit-frame-pointer -msse -mfpmath=sse -mmmx -m3dnow -march=athlon-xp"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="en en_GB en_US"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow 3dnowext 7zip X a52 aac acl acpi ads alsa ao arts audiofile automount awe32 bzip2 cddb cdparanoia cdr cgi cli cpudetection cpufreq cracklib crypt css cups dbus directfb divx dri dts dv dvb dvd dvdr dvdread encode fbcon fbcondecor fbsplash ffmpeg fftw firefox flac fontconfig fortran fpx gdbm geoip gif gimp glut gmedia gphoto2 gpm graphviz gs gstreamer hal hdri iconv ieee1394 imagemagick ipv6 isdnlog jack java jbig jikes joystick jpeg jpeg2k kde kipi ladspa lame lash latex lcms libburn libcaca libedit libnotify lirc live lm_sensors lzo mad matroska midi mikmod mmap mmx mmxext mng moviepack moviesounds mp2 mp3 mpeg mplayer mpu401 mudflap musepack mysql ncurses networkmanager nforce2 nls nptl nptlonly nsplugin nvidia offensive ogg openexr opengl openmp oss pae pam pcre pda pdf perl pmu png ppds pppd python qt3 qt3support qt4 quicktime rar rdesktop readline real realmedia reflection rtc samba scanner sdl sensord session slang snmp speex spell spl sse ssl suid svg swat szip tcpd theora threads thunderbird tiff truetype unicode usb v4l v4l2 vcd vnc vorbis wavpack win32codecs wmf wmp x264 x86 xattr xfs xine xml xorg xpm xrandr xscreensaver xv xvid xvmc zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB en_US" USERLAND="GNU" VIDEO_CARDS="nvidia"
Comment 3 sam logen 2008-07-21 00:02:11 UTC
Created attachment 160973 [details]
Licence for the software

I just remembered.  Here is the license for Celtx.  It is based off of the Mozilla license.
Comment 4 Arne Babenhauserheide 2009-03-06 07:44:02 UTC
They just updated to celtx-2.0:
Comment 5 Matt 2010-02-10 22:16:18 UTC
any news on the ebuild for Celtx ?

I stumbled over it by looking for journal software

its current version is 2.7
Comment 6 Miroslav Šulc gentoo-dev 2010-11-22 23:45:40 UTC
sources of celtx 2.7 can be found at

i tried to compile manually just celtx but as i am not skilled with this kind of build system, i failed :-)