Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 231985 - app-emulation/vmware-modules-1.0.0.20 fails to compile against a vanilla kernel 2.6.26
Summary: app-emulation/vmware-modules-1.0.0.20 fails to compile against a vanilla kern...
Status: RESOLVED DUPLICATE of bug 227303
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo VMWare Bug Squashers [disabled]
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-16 17:04 UTC by Joshua Doll
Modified: 2008-07-17 08:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build error (build.log,3.78 KB, text/plain)
2008-07-16 18:23 UTC, Moonfire
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joshua Doll 2008-07-16 17:04:41 UTC
vmware-modules-1.0.0.20 fail to compile against a vanilla kernel 2.6.26.

Reproducible: Always

Actual Results:  
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     2.6.26
>>> Unpacking source...
>>> Unpacking VMware-player-2.0.4-93057.x86_64.tar.gz to /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work
>>> Unpacking ./vmware-player-distrib/lib/modules/source//vmmon.tar to /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work
 * Converting vmmon-only/Makefile to use M= instead of SUBDIRS= ...
  [ ok ]
>>> Unpacking ./vmware-player-distrib/lib/modules/source//vmnet.tar to /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work
 * Converting vmnet-only/Makefile to use M= instead of SUBDIRS= ...
  [ ok ]
>>> Unpacking ./vmware-player-distrib/lib/modules/source//vmblock.tar to /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work
 * Converting vmblock-only/Makefile to use M= instead of SUBDIRS= ...
  [ ok ]
 * Applying 010_all_kernel-2.6.25.patch ...
  [ ok ]
 * Applying 1.0.0.20-makefile-kernel-dir.patch ...
  [ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work ...
 * Preparing vmmon module
Using 2.6.x kernel build system.
make -C /usr/src/linux M=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-2.6.26'
make[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work/vmmon-only/linux/driver.o
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work/vmmon-only/linux/driver.c:197: error: unknown field 'nopage' specified in initializer
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work/vmmon-only/linux/driver.c:198: warning: initialization from incompatible pointer type
make[3]: *** [/var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work/vmmon-only/linux/driver.o] Error 1
make[2]: *** [_module_/var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work/vmmon-only] Error 2
make[1]: *** [sub-make] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.26'
make: *** [vmmon.ko] Error 2
 *
 * ERROR: app-emulation/vmware-modules-1.0.0.20 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3279:  Called linux-mod_src_compile
 *             environment, line 2489:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"                                               CC=\"$(get-KERNEL_CC)\"
                        LDFLAGS=\"$(get_abi_LDFLAGS)\"                                          ${BUILD_FIXES}                                          ${BUILD_PARAMS}                                                 ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *  The die message:
 *   Unable to emake HOSTCC=x86_64-pc-linux-gnu-gcc CC=x86_64-pc-linux-gnu-gcc LDFLAGS=   auto-build VMWARE_VER=VME_V604 KERNEL_DIR=/usr/src/linux KBUILD_OUTPUT=/usr/src/linux
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/temp/environment'.




Portage 2.1.4.4 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r6 x86_64)
=================================================================
System uname: 2.6.25-gentoo-r6 x86_64 Intel(R) Core(TM)2 CPU 6420 @ 2.13GHz
Timestamp of tree: Wed, 16 Jul 2008 15:00:02 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r13
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe -msse -msse2 -msse3 -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe -msse -msse2 -msse3 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US"
LC_ALL="en_US"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/desktop-effects"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 ao bash-completion berkdb bzip2 cairo cd cdda cddb cdparanoia cdr cli cpudetection cracklib crypt css cups dbus device-mapper directfb doc dri dvd dvdr dvdread dvi encode esd exif fame ffmpeg flac fontconfig foomaticdb fortran gcdmaster gdbm gif gimp gimpprint glitz gnome gphoto2 gpm gstreamer gtk hal i-qt4 iconv id3tag ieee1394 imagemagick ipod iptc isdnlog joystick jpeg jpeg2k lame libnotify libvisual mad matroska midi mmx mozilla mp3 mp4 mpeg mudflap multilib musepack musicbrainz mysql ncurses network nfs nls nptl nptlonly nsplugin nvidia offensive ogg opengl openmp oss pam pango pcre pdf perl png ppds pppd python quicktime rar raw readline reflection rtc session smp spell spl sse sse2 ssl ssse3 startup-notification svg taglib tcpd theora threads tiff truetype twolame type1 unicode usb vcd vim-syntax visualization vorbis wxwindows x264 xcb xcomposite xine xorg xpm xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="nvidia i810 nv vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Moonfire 2008-07-16 18:23:31 UTC
Created attachment 160594 [details]
build error

Same problem here. 
gcc-4.3.0
kernel 2.6.26
amd64 (x86_64)

attached build.log if needed
Comment 2 Mike Auty gentoo-dev 2008-07-17 08:13:02 UTC

*** This bug has been marked as a duplicate of bug 227303 ***