Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 231563 - mail-client/evolution 2.22.3.1 - error when compiling due to preserved nss library
Summary: mail-client/evolution 2.22.3.1 - error when compiling due to preserved nss li...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
: 240416 (view as bug list)
Depends on:
Blocks: preserve-libs
  Show dependency tree
 
Reported: 2008-07-12 08:57 UTC by daniel
Modified: 2011-05-18 16:42 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge.info,3.78 KB, text/plain)
2008-08-31 13:28 UTC, Federico Fissore
Details

Note You need to log in before you can comment on or make changes to this bug.
Description daniel 2008-07-12 08:57:59 UTC
Messages for package mail-client/evolution-2.22.3.1:

 * 
 * ERROR: mail-client/evolution-2.22.3.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3016:  Called gnome2_src_compile
 *             environment, line 2193:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure


Reproducible: Always

Steps to Reproduce:
emerge evolution
Actual Results:  
/bin/sh ../../libtool --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc  -march=nocona -msse3 -mfpmath=sse -O2 -Wall -Wmissing-prototypes  -Wno-sign-compare  $
x86_64-pc-linux-gnu-gcc -march=nocona -msse3 -mfpmath=sse -O2 -Wall -Wmissing-prototypes -Wno-sign-compare -Wl,-O1 -o .libs/contact-print-test test-print.o$
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libsoftokn3.so.11, needed by /usr/lib64/nss/libnss3.so.11, not foun$
/usr/lib64/nss/libnss3.so.11: undefined reference to `FC_GetFunctionList@NSS_3.4'
/usr/lib64/nss/libnss3.so.11: undefined reference to `NSC_ModuleDBFunc@NSS_3.4'
/usr/lib64/nss/libnss3.so.11: undefined reference to `NSC_GetFunctionList@NSS_3.4'
collect2: ld returned 1 exit status
make[4]: *** [contact-print-test] Błąd 1
make[4]: Opuszczenie katalogu `/var/tmp/portage/mail-client/evolution-2.22.3.1/work/evolution-2.22.3.1/addressbook/printing'
make[3]: *** [all-recursive] Błąd 1
make[3]: Opuszczenie katalogu `/var/tmp/portage/mail-client/evolution-2.22.3.1/work/evolution-2.22.3.1/addressbook'
make[2]: *** [all] Błąd 2
make[2]: Opuszczenie katalogu `/var/tmp/portage/mail-client/evolution-2.22.3.1/work/evolution-2.22.3.1/addressbook'
make[1]: *** [all-recursive] Błąd 1
make[1]: Opuszczenie katalogu `/var/tmp/portage/mail-client/evolution-2.22.3.1/work/evolution-2.22.3.1'
make: *** [all] Błąd 2
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m ERROR: mail-client/evolution-2.22.3.1 failed.
 ^[[31;01m*^[[0m Call stack:
 ^[[31;01m*^[[0m               ebuild.sh, line   49:  Called src_compile
 ^[[31;01m*^[[0m             environment, line 3016:  Called gnome2_src_compile
Comment 1 daniel 2008-07-12 08:59:56 UTC
Portage 2.2_rc1 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r6 x86_64)
=================================================================
System uname: Linux-2.6.25-gentoo-r6-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9300_@_2.50GHz-with-glibc2.2.5
Timestamp of tree: Sat, 12 Jul 2008 08:17:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r6, 2.5.2-r5
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -msse3 -mfpmath=sse -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -msse3 -mfpmath=sse -O2"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.mirror.pw.edu.pl/ "
LANG="pl_PL"
LC_ALL="pl_PL"
LDFLAGS="-Wl,-O1"
LINGUAS="pl en"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi aiglx alsa amd64 amr aoss asf berkdb bluetooth bzip2 cairo cdr cli cracklib crypt cups dbus dri dvb dvd dvdr examples fam ffmpeg firefox fortran gdbm gif gimp glitz gnome gpm gstreamer gtk hal iconv isdnlog java joystick jpeg libwww mad midi mikmod mmx mono mp3 mp4 mpeg mudflap multilib mysql ncurses new-login nls nptl nptlonly nsplugin odbc ogg opengl openmp pam pcre pdf perl png ppds pppd python readline reflection samba scanner session spell spl sqlite sse sse2 ssl svg symlink tcpd threads tiff truetype unicode usb vcd x264 xcomposite xine xinerama xml xorg xscreensaver xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 2 Jeroen Roovers gentoo-dev 2008-07-12 16:55:50 UTC
Please re-emerge dev-libs/nss (or run revdep-rebuild from the app-portage/gentoolkit package) and reopen this bug if mail-client/evolution gives you the same error.
Comment 3 daniel 2008-07-13 10:28:36 UTC
I've done:
1.
emerge dev-libs/nss
emerge evolution

and it didn't help


RESULT:

 * Messages for package mail-client/evolution-2.22.3.1:

 * 
 * ERROR: mail-client/evolution-2.22.3.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3017:  Called gnome2_src_compile
 *             environment, line 2194:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/mail-client/evolution-2.22.3.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/mail-client/evolution-2.22.3.1/temp/environment'.
 * 

 * GNU info directory index is up-to-date.

 * IMPORTANT: 68 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

!!! existing preserved libs:
>>> package: dev-libs/nss-3.12
 *  - /usr/lib64/nss/libnss3.so.11
 *  - /usr/lib64/nss/libsmime3.so.11
 *  - /usr/lib64/nss/libssl3.so.11
Use emerge @preserved-rebuild to rebuild packages using these libraries





2. 
emerge app-portage/gentoolkit
emerge @preserved-rebuild
revdep-rebuild
revdep-rebuild
emerge evolution

and it didn't help


RESULT:

* Messages for package mail-client/evolution-2.22.3.1:

 * 
 * ERROR: mail-client/evolution-2.22.3.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3016:  Called gnome2_src_compile
 *             environment, line 2193:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/mail-client/evolution-2.22.3.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/mail-client/evolution-2.22.3.1/temp/environment'.
 * 


Comment 4 Gilles Dartiguelongue gentoo-dev 2008-07-14 09:03:46 UTC
does rebuilding eds help ?
Comment 5 Alexandre 2008-07-14 15:09:04 UTC
Same problem for me on ~x86. 

Workaround (as suggested here : http://forums.gentoo.org/viewtopic-p-5134829.html#5134829) worked for me :

emerge --unmerge dev-libs/nss
emerge --oneshot dev-libs/nss
emerge --oneshot mail-client/evolution

Portage 2.2_rc1 (default-linux/x86/2007.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r5_001-uvesafb i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r5_001-uvesafb-i686-Intel-R-_Pentium-R-_4_CPU_3.00GHz-with-glibc2.0
Timestamp of tree: Mon, 14 Jul 2008 13:16:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r5
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     9999
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d /usr/X11R6/bin/startx"
CXXFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/var/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="ccache distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://mirror.switch.ch/mirror/gentoo/ ftp://ftp.solnet.ch/mirror/Gentoo "
LANG="fr_CH.utf8"
LC_ALL="fr_CH.utf8"
LDFLAGS=""
LINGUAS="fr fr_FR fr_CH en"
MAKEOPTS="-j2"
PKGDIR="/var/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/portage"
PORTDIR_OVERLAY="/var/portage/local/layman/haskell /var/portage/local/layman/pro-audio /var/portage/local/layman/openrc /var/portage/local/layman/science /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X aalib acl acpi alsa avahi bash-completion berkdb bzip2 cairo cdr cjk cli cracklib crypt cups dbus doc dri dvd dvdr dvdread eds emboss encode esd evo examples fam firefox fortran gdbm gif gnome gnutls gpm gstreamer gtk hal iconv isdnlog jack jpeg jpeg2k kerberos keyring krb4 ldap lua mad midi mikmod mmx mp3 mpeg mudflap ncurses nfs nls nptl nptlonly nsplugin ogg opengl openmp oss pam pcre pdf perl png pppd profile python qt3support quicktime readline reflection reiserfs sdl session slang source spell spl ssl svg tcpd tcpwrapper tiff truetype type1 unicode vorbis win32codecs x86 xinerama xml xorg xprint xsl xslt xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 	emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m 	maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR fr_CH en" USERLAND="GNU" VIDEO_CARDS="fglrx"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 6 daniel 2008-07-14 18:03:28 UTC
(In reply to comment #4)
> does rebuilding eds help ?
> 

this doesn't help
Comment 7 daniel 2008-07-14 18:26:33 UTC
(In reply to comment #5)
> Same problem for me on ~x86. 
> 
> Workaround (as suggested here :
> http://forums.gentoo.org/viewtopic-p-5134829.html#5134829) worked for me :
> 
> emerge --unmerge dev-libs/nss
> emerge --oneshot dev-libs/nss
> emerge --oneshot mail-client/evolution
> 

This "workarround" did help. Thanks a lot. But workarround is not a solution I guess, so I'm leaving this bug open.
Comment 8 Gilles Dartiguelongue gentoo-dev 2008-07-14 19:39:49 UTC
definitively looks like a portage problem, removing us from CC.
Comment 9 sagnwook Kim 2008-07-25 07:57:59 UTC
i've had exactly same problem.

And i got it fixed by
"python-update"
Comment 10 Federico Fissore 2008-08-31 13:28:41 UTC
Created attachment 164172 [details]
emerge --info

here too
Comment 11 Olexandr Shalakhin 2008-09-29 21:05:12 UTC
I've done unmerge of nss-3.12 and emerged it with --oneshot option. As the result it failes.

build.log: http://dpaste.com/81290/

I also tried re-emerging eds. :'(

What can you say me from build.log? :) I hope it help. :)

emerge --info: http://dpaste.com/hold/81291/
Comment 12 Federico Fissore 2008-09-30 07:22:29 UTC
i confirm comment #7 does the job
updating nss leaved an old .so evolution picks up when compiling, causing the error
unmerging nss, removes that old .so
Comment 13 Zac Medico gentoo-dev 2008-10-01 22:45:38 UTC
Adding gnome in CC to see about fixing the build to work while the old nss lib is preserved.
Comment 14 Gilles Dartiguelongue gentoo-dev 2008-10-01 22:59:18 UTC
err, what is expected from us here ? reading configure.in evolution picks its informations from pkgconfig so I don't see where the problem would be on evo's side.
Comment 15 Zac Medico gentoo-dev 2008-10-01 23:34:45 UTC
Well, pkgconfig appears to be maintained by the gnome herd to so perhaps you've got some ideas how to make that behave? :)
Comment 16 Gilles Dartiguelongue gentoo-dev 2008-10-07 22:44:09 UTC
*** Bug 240416 has been marked as a duplicate of this bug. ***
Comment 17 Mart Raudsepp gentoo-dev 2008-11-02 04:10:31 UTC
We have established with Zac that this can't be a pkg-config problem, as all pkg-config does is help with linker lines, and that is simply giving stuff like "-L/usr/lib64/nss -lssl3 -lsmime3 -lnssutil3 -lnss3 -Wl,-R/usr/lib64/nss", which doesn't specify anything about .so.11 vs .so.12

We also discussed things with Zac at the linker levels and he is soon going to investigate things more deeply, I understood.

However I'm not removing gnome@ from CC personally, to still follow this as something evolution doing wrong could maybe trigger this. If you do remove it (gnome team co-members), please CC me personally in its place.
Comment 18 Gilles Dartiguelongue gentoo-dev 2008-11-16 18:49:14 UTC
*** Bug 247102 has been marked as a duplicate of this bug. ***
Comment 19 Gerard 2008-11-17 03:58:20 UTC
Remove me from cc, filer of Bug 247102, because although related, it is not a duplicate.
Comment 20 JayDee 2008-12-29 17:03:29 UTC
(In reply to comment #7)

I got the same problem, and I tried the Workaround from comment #7 :

> > Workaround (as suggested here :
> > http://forums.gentoo.org/viewtopic-p-5134829.html#5134829) worked for me :
> > 
> > emerge --unmerge dev-libs/nss
> > emerge --oneshot dev-libs/nss
> > emerge --oneshot mail-client/evolution
> > 

But this didn't work. For me, the good workaround was to :
 - emerge --unmerge dev-libs/nss gnome-extra/evolution-data-server mail-client/evolution
 - emerge --oneshot dev-libs/nss
 - emerge --oneshot gnome-extra/evolution-data-server mail-client/evolution

Removing evolution too corrects the problem for me (I had also the same kind of problem with e-d-s)

I hope this will help some of you...
Comment 21 Fabian Groffen gentoo-dev 2011-02-06 15:44:08 UTC
This particular problem doesn't exist any more because libnss has been fixed and installed just in /usr/lib now, instead of /usr/lib/nss.  Before it would typically depend on itself.
Comment 22 Zac Medico gentoo-dev 2011-05-18 16:42:46 UTC
(In reply to comment #21)
> This particular problem doesn't exist any more because libnss has been fixed
> and installed just in /usr/lib now, instead of /usr/lib/nss.  Before it would
> typically depend on itself.

Ok, closing. Please re-open if this is still reproducible.