Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 230923 - net-misc/nx-3.2.0-r2 - nxagent fails with "no core keyboard" on amd64/gcc-4.3
Summary: net-misc/nx-3.2.0-r2 - nxagent fails with "no core keyboard" on amd64/gcc-4.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: NX Server Herd
URL: http://mail.kde.org/pipermail/freenx-...
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-07-06 11:01 UTC by Andrej Filipcic
Modified: 2008-07-08 12:09 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrej Filipcic 2008-07-06 11:01:08 UTC
nxagent from nx-3.2.0-r2 fails:
---------
andrej@af ~/a $ nxagent :1

NXAGENT - Version 3.2.0

Copyright (C) 2001, 2007 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Agent running with pid '29867'.
Session: Starting session at 'Sun Jul  6 12:55:54 2008'.
Info: Using alpha channel in render extension.
Info: Not using local device configuration changes.
No core keyboard
Error: Aborting session with 'Failed to initialize core devices'.
Session: Aborting session at 'Sun Jul  6 12:55:54 2008'.
Session: Session aborted at 'Sun Jul  6 12:55:54 2008'.
---------

I have checked it works with 3.2.0-r1. Also nxagent from 3.2.0-r1 works with nx-3.2.0-r2 libs.

emerge --info:
Portage 2.2_rc1 (default-linux/amd64/2007.0, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r4 x86_64)
=================================================================
System uname: Linux-2.6.25-gentoo-r4-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5600+-with-glibc2.2.5
Timestamp of tree: Fri, 04 Jul 2008 21:36:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r4, 2.5.2-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r2
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=k8 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LDFLAGS=""
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/pro-audio /usr/portage/local/layman/kde /usr/portage/local/layman/desktop-effects /usr/portage/local/layman/java-overlay /usr/portage/local/layman/xemacs /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X Xaw3d a52 aac aalib accessibility accounting acl acpi admin afs aiglx aio alsa amarok amd64 amr amrnb amrwb ansi ao apache2 applet arts asf athena atlas avahi bash-completion bcmath beagle berkdb bidi binfilter bl blas bluetooth bonjour bonobo branding bzip2 cairo calendar canvas caps cdb cddb cdio cdparanoia cdr cern chm cjk clamav cli colordiff console context cpudetection cracklib crciprec crypt css ctype cups curl curlwrappers cvs cyrillic cyrus daap dba dbm dbox2 dbus dc1394 dedicated deprecated designer-plugin device-mapper dga dia directfb diskio divx4linux djvu dlloader doc dri dssi dts dv dvb dvd dvdr dvi dxr3 edl eds elf elisp emacs emacs-w3 enblend enca encode esd exif exiv2 expat extensible extra fame fastcgi fat fbcon festival ffmpeg fftw filepicker firefox fits flac flatfile float fluidsynth font-server foomaticdb fortran fping freebox freetts ftp fuse gadu galago games gcj gcl gd gdbm gif gimp gimpprint glitz gmp gnokii gnome gnuplot gnutls gphoto2 gpm gps graphics graphviz groupwise gsf gstreamer gtk gtk2 gtkhtml guile hal hash hdhomerun hfs howl hpn htmlhandbook humanities hyperestraier ical iconv id3tag idn ieee1394 ifp imagemagick imap imlib inkjar innodb inotify iodbc ipod ipv6 irda isdnlog ithreads ivtv jack jadetex java java5 javascript jfs jingle joystick jpeg jpeg2k json junit kde kerberos keyring kig-scripting krb4 ktts ladspa lapack laptop latex lcd lcms ldap ldap-sasl ldapsam libcaca libclamav libnotify libsamplerate lirc live lm_sensors logrotate lua lyx lzo mad maps math matroska mbox mcve md5sum mdnsresponder-compat meanwhile messenger mfd-rewrites mhash midi mikmod mime mjpeg mmx mmxext mng modplug mono mozbranding mozdevelop mozilla mozsvg mp2 mp3 mp4 mpeg mpi mplayer msn mtp mudflap mule musepack music musicbrainz mysql mysqli nagios-dns nagios-ntp nagios-ping nas nautilus ncurses nemesi network networking networkmanager newxkb njb nls nptl nptlonly nsplugin ntfs nvidia nxclient objc odbc odk ogg ole omega openal openexr opengl openmp oscar oss overlays pam pcmcia pcntl pcre pda pdf pdo pear perl perlsuid php pic plotutils png pnm portaudio posix postfix postgres postgresql postscript povray ppds pppd prediction pstricks publishers pulseaudio pvr python qq qt qt-static qt3 qt3support qt4 quicktime quotas radio rar rdesktop reaa readline reflection regex reiser4 reiserfs rpc rtc ruby samba sasl sbcl scanner science sdl sdl-image seamonkey sendmail server session sift silc silvercity simplexml skey slang slp smime sms smux sndfile snmp soap sockets solver sound sox speex spell spl sql sqlite srt sse sse2 ssl ssse3 startup-notification subtitles subversion suhosin svg sysvipc t1lib taglib tcltk tcpd teletext tetex tex4ht tga theora threads thunderbird tidy tiff tk tokenizer transcode truetype truetype-fonts twolame type1-fonts unicode upnp usb utempter utf8 v4l v4l2 vcd vcdx vhosts visualization vorbis wavpack wddx webdav wifi wmf wxwindows x264 xanim xattr xcomposite xetex xface xfs xim xine xinerama xml xml2 xmlreader xmlrpc xmlwriter xmp xorg xpm xscreensaver xsl xulrunner xv xvid xvmc yaz zephyr zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x       ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3       trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias proxy auth_digest authn_dbd asis cern_meta charset_lite dbd dumpio ident imagemap log_forensic proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http version substitute" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i810 mach64       mga neomagic nv r128 radeon rendition s3 s3virge savage siliconmotion sis      sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2008-07-06 20:34:14 UTC
Maybe you should configure the core keyboard... Is there any reason you provided a version number in the Summary (other than perhaps to be generally informative)?
Comment 2 Andrej Filipcic 2008-07-06 23:31:53 UTC
Well, as I said, nxagent from net-misc/nx-3.2.0-r2 does not work. Every previous version did, up to net-misc/nx-3.2.0-r1. The trouble is that every nx session terminates due to nxagent failure when nxclient is trying to open a session window. Of course, -r2 was compiled with gcc-3.4.1 and some newer libs, but I hardly imagine this to be a problem. stracing nxagent shows the error is reported when reading /tmp/.X11-unix/X0. The xorg.conf has everything there.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2008-07-07 01:24:43 UTC
Thank you for the info!
Comment 4 Bernard Cafarelli gentoo-dev 2008-07-07 08:51:53 UTC
Confirmed on the freenx mailing list, thanks for the investigation! I'll look into it
Comment 5 Bernard Cafarelli gentoo-dev 2008-07-07 16:07:33 UTC
Correction, it looks like gcc-4.3 is the culprit: re-emerging nx-3.2.0-r2 with gcc-4.2 produced a working nxagent
Comment 6 Andrej Filipcic 2008-07-07 20:01:38 UTC
I can confirm the same. With gcc-4.2.4 it works.
Comment 7 Oleksandr Shneyder 2008-07-08 09:36:33 UTC
(In reply to comment #5)
> Correction, it looks like gcc-4.3 is the culprit: re-emerging nx-3.2.0-r2 with
> gcc-4.2 produced a working nxagent
> 

(In reply to comment #5)
> Correction, it looks like gcc-4.3 is the culprit: re-emerging nx-3.2.0-r2 with
> gcc-4.2 produced a working nxagent
> 

Hello, I'm developer of X2Go(www.x2go.org). We using nxlibs for ouer project.

Error is in file programs/Xserver/hw/nxagent/Keyboard.c 

in  function int nxagentKeyboardProc(DeviceIntPtr pDev, int onoff)

438:  #ifdef _XSERVER64
439:        {
440:          KeySym64 *keymap64;
441:          int i, len;
442:          keymap64 = XGetKeyboardMapping(nxagentDisplay,
443:                                       min_keycode,
444:                                       max_keycode - min_keycode + 1,
445:                                       &mapWidth);
446:  
447:          if (keymap == NULL)
448:          {
449:            XFreeModifiermap(modifier_keymap);
450:  
451:            return -1;
452:          }
453:  
454:          len = (max_keycode - min_keycode + 1) * mapWidth;
455:          keymap = (KeySym *)xalloc(len * sizeof(KeySym));
456:          for(i = 0; i < len; ++i)
457:            keymap[i] = keymap64[i];
458:          XFree(keymap64);
459:        }
460:  
461:  #else /* #ifdef _XSERVER64 */




line 447:          if (keymap == NULL) //keymap not initialized yet

at this line schould be if (keymap64 == NULL)

That's code explane why nxagent not work only on 64bit systems and only if assemblied with new gcc

I hope it can help you ;)

Have a nice day and sorry for bad english

Oleksandr Shneyder AKA nCryer
Comment 8 Bernard Cafarelli gentoo-dev 2008-07-08 10:54:50 UTC
Thanks a lot, I've tested it and it's working!

I'll apply the patch soon
Comment 9 Bernard Cafarelli gentoo-dev 2008-07-08 12:09:37 UTC
Fixed in nx-3.2.0-r3 in CVS, thanks!