Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 22996 - New perl modules: HTML::Mason and Alzabo
Summary: New perl modules: HTML::Mason and Alzabo
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Michael Cummings (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-06-17 06:26 UTC by rob holland (RETIRED)
Modified: 2003-08-24 05:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rob holland (RETIRED) gentoo-dev 2003-06-17 06:26:16 UTC
When you get some time (haha) can you please add these two modules + dep chain
to portage:

HTML::Mason
Alzabo

Reproducible: Always
Steps to Reproduce:
Comment 1 Michael Cummings (RETIRED) gentoo-dev 2003-06-17 07:46:52 UTC
I've got some rough draft ebuilds for everything now (hey, I write my own automation tools too!!), but YAML may be a sticking point. we'll see. I have some ideas.
Comment 2 Guy 2003-06-17 13:58:24 UTC
Mason is also requested in bug # 21549.

:-)
Comment 3 Michael Cummings (RETIRED) gentoo-dev 2003-06-26 10:31:10 UTC
Rob,

Just when you thought it might make it into portage - I've got problems with alzabo. First, I need to talk to rac about a whole new eclass, because alzabo is using Ken's new Module::Builder instead of MakeMaker, which invalidates the current eclass. Second - I know nothing about alzabo or how it's supposed to integrate. In order to do this ebuild for it I would need to know what paths it should be installing files to, etc. (run the install, you'll see what I'm talking about). Afraid I'm going to need you to do some deving for this one if you want it in portage. I can give you a rudimentry copy of the ebuild, and will work on it with you, but I can't do it alone.
Comment 4 rob holland (RETIRED) gentoo-dev 2003-06-27 06:23:59 UTC
this is waiting for me to hack at an ebuild mcummings sent me now...
Comment 5 rob holland (RETIRED) gentoo-dev 2003-07-11 02:17:10 UTC
waiting for the web-app.eclass thing 
Comment 6 Michael Cummings (RETIRED) gentoo-dev 2003-07-20 08:28:16 UTC
Rob,

Can you forward me or attach the updated ebuild with the db changes? I'd like to whack this one out of the way with the local use flag for mason. Thanks,

Mike
Comment 7 rob holland (RETIRED) gentoo-dev 2003-08-24 05:47:18 UTC
alzabo is a pig :/ too complicated to ebuild I think...to much of it is down to taste *sigh*