Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 22893 - avifile failed to merge using stage3 and i686-pc-linux-gnu
Summary: avifile failed to merge using stage3 and i686-pc-linux-gnu
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Release Team
Depends on:
Reported: 2003-06-15 18:28 UTC by Nigel Burman
Modified: 2003-11-21 23:44 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Nigel Burman 2003-06-15 18:28:17 UTC
Here's what I've done:
Installed the basic Gentoo stage 3 (latest CD ...rc4) system and performed
emerge sync, emerge -u portage, etc-update, emerge -u world, etc-update and then
continued with the rest of the configuration from stage-3. After this I emerged
xfree and configured it. Then emerged gnome. It failed on emerging

Reproducible: Always
Steps to Reproduce:
1. emerge avifile

Actual Results:  
root@gentoo3 nigel # emerge avifile
Calculating dependencies ...done!
>>> emerge (1 of 1) media-video/avifile- to /
>>> md5 src_uri ;-) avifile-0.7.32-20030219.tgz
>>> Unpacking source...
>>> Unpacking avifile-0.7.32-20030219.tgz to
>>> Source unpacked.
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
avifile configure options: --prefix=/usr --host=i686-pc-linux-gnu
--mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share
--sysconfdir=/etc --localstatedir=/var/lib --enable-samples --disable-vidix
--with-fpic --with-gnu-ld --enable-oss --disable-static --enable-freetype2
--enable-xv --enable-sdl --disable-a52 --disable-ffmpeg-a52 --enable-quiet
--enable-x86opt --enable-libz --enable-vorbis --with-x --enable-xft --without-qt
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking whether make sets $(MAKE)... yes
checking for working aclocal-1.4... found
checking for working autoconf... found
checking for working automake-1.4... found
checking for working autoheader... found
checking for working makeinfo... found
checking for i686-pc-linux-gnu-g++... i686-pc-linux-gnu-g++
checking for C++ compiler default output... configure: error: C++ compiler
cannot create executables
See `config.log' for more details.
!!! ERROR: media-video/avifile- failed.
!!! Function econf, Line 304, Exitcode 77
!!! econf failed

Expected Results:  
Expected avifile to emerge successfully.

Found a work around with the command line:
CHOST="i586-pc-linux-gnu" emerge avifile

"emerge info" gives me:

Portage 2.0.48-r1 (default-x86-1.4, gcc-3.2.2, glibc-2.3.1-r4)
System uname: 2.4.20-gentoo-r5 i686 Pentium II (Deschutes)
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config
/usr/kde/3/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="x86 oss 3dnow apm arts avi crypt cups encode gif gpm jpeg libg++ libwww
mikmod mmx mpeg ncurses nls pdflib png quicktime spell truetype xml2 xmms xv
zlib gdbm berkdb slang readline svga java guile sdl tcpd pam ssl perl python esd
imlib oggvorbis motif opengl mozilla X gtk gnome -kde -qt"
CFLAGS="-march=pentium2 -O3 -pipe"
CXXFLAGS="-march=pentium2 -O3 -pipe"
FEATURES="sandbox ccache"
Comment 1 Mike Gardiner (RETIRED) gentoo-dev 2003-06-15 20:17:00 UTC
you didnt by any chance disable "Kernel support for a.out binaries" in the "General Setup" section of your kernel configuration? here's my output of emerge audiofile,

checking for working makeinfo... found
checking for i686-pc-linux-gnu-g++... i686-pc-linux-gnu-g++
checking for C++ compiler default output... a.out
checking whether the C++ compiler works... yes

will recompile my kernel without a.out support and see if i have a similar error to you.
Comment 2 Alastair Tse (RETIRED) gentoo-dev 2003-06-16 01:21:45 UTC
i believe this is a common avifile problem and not actually a gnome bug.

the reasoning is that avifile tries to check for i686-pc-linux-gnu-gcc rather than plain gcc, and that does not exist in stage3 because it was compiled with i586-pc-linux-gnu-gcc. 

bug-wranglers, can you assign this to the avifile maintainer, if there is one?
Comment 3 Seemant Kulleen (RETIRED) gentoo-dev 2003-06-16 03:53:47 UTC
I *think* the problem is in the make.conf in stage3
Comment 4 foser (RETIRED) gentoo-dev 2003-06-16 04:53:00 UTC
we should get rid of avifile, the problem is most likely gst-plugins depending on mjpegtools (USE="jpeg mmx") depending on avifile. I've removed this dep in the latest ~ gst-plugins.

I'm not sure it's worth fixing avifile, we should probably try to get rid of it.
Comment 5 Jim Beckett 2003-06-25 06:15:20 UTC
I am pretty sure that the problem is the way the Stage 3 Tarball was created.  It has a toolkit that is set for an i586 instead of an i686.  I was able to get everything to build without difficulty by emerging gcc and then emerging my entire system all over again.  I think that the compiler settings and the USE flags were stepping all over each other and causing these problems.

To fix:
emerge gcc
emerge -e world
emerge -e (whatever you were trying to do...)
Comment 6 Nigel Burman 2003-06-30 08:02:56 UTC
Okay, I've now rebuilt gcc and re-emerged avifile (this is where the bug was showing up). No problems at all, so looks like the last suggestion about the gcc compiler needing to be compiled with CHOST="i686-pc-linux-gnu" was correct.

"emerge -e gnome" worked without any problems too.

I guess the next Gentoo gcc stage3 image will be be built for i686, otherwise this is going to reappear for other users later on.
Comment 7 Alastair Tse (RETIRED) gentoo-dev 2003-07-09 02:07:54 UTC
this is a blocker for gnome afaik. although the new experiemental stages have a pentium3 arch that uses i686-pc-linux-gnu when staging.

the i586 image probably would still have this problem. so either sans-avifile gst-plugins gets put into stable, or we make sure the i586 image has the CHOST set correctly, or both.
Comment 8 Martin Holzer (RETIRED) gentoo-dev 2003-07-09 02:41:01 UTC
It's possible that some variant of the tactic in will work here.
Comment 9 foser (RETIRED) gentoo-dev 2003-07-09 03:45:26 UTC
i don't think this is a blocker for gnome, i have removed avifile as gst-plugins dep since 0.6.0 and with 0.6.2 i also have removed the 'USE mmx' mjpegtools dep (which on its turn 'USE avi' depends on avifile).

0.6.2 is pretty much ready to go stable, which should remove all avifile deps for a clean gnome install.
Comment 10 Alastair Tse (RETIRED) gentoo-dev 2003-07-09 05:25:38 UTC
my use of the term blocker meant "from stage3 (1.4_rc3) + emerge gnome" will fail at avifile (on x86).

once the new gst-plugins goes to x86 without the avifile, then this won't be a problem for gnome.
Comment 11 SpanKY gentoo-dev 2003-07-29 08:17:12 UTC
any reason you didnt ask to see the config.log file ?
perhaps a library got screwed up somewhere and that test tried to link
said library ... ive seen it happen once or twice ...

at any rate, since the original problem isnt exactly known, and the
reporter has it working now, lets just consider the matter closed
unless someone can reproduce it
Comment 12 SpanKY gentoo-dev 2003-11-21 23:44:32 UTC