Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 228637 - net-libs/xulrunner-1.9-r2 bundles a copy of sqlite
Summary: net-libs/xulrunner-1.9-r2 bundles a copy of sqlite
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
: 258462 (view as bug list)
Depends on:
Blocks: bundled-libs
  Show dependency tree
 
Reported: 2008-06-20 22:21 UTC by Mart Raudsepp
Modified: 2009-07-20 03:29 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mart Raudsepp gentoo-dev 2008-06-20 22:21:14 UTC
net-libs/xulrunner-1.9-r2 instead of using the system sqlite, uses a copy of sqlite. This is bad for obvious reasons. It was changed to using the internal version due to bug 228305 (which I have not been affected with). Instead of that, the patched sqlite in firefox tarball should be investigated, compared to the system sqlite to see what "fixes" they apply, and see if sqlite upstream knows about it (or perhaps is already even in sqlite trunk) and port it to our system sqlite - and if they haven't notified upstream, we will have to do that ourselves.
So this bug is for tracking efforts to use system sqlite again as we ought to, and because bug 228305 was closed as "fixed" while it is not cleanly fixed yet.
Comment 1 Raúl Porcel (RETIRED) gentoo-dev 2008-06-21 09:43:16 UTC
you do it :P
Comment 2 Rafał Mużyło 2008-06-22 11:49:56 UTC
A (probably) silly question:
what is the ratio of people who got that crash against those who couldn't reproduce it,
cause though I tried, I couldn't get it to crash,
even now I'm using a version that used system sqlite.
Comment 3 Rafał Mużyło 2008-07-17 21:36:34 UTC
With the release of firefox 3.0.1 two new question arise:
1. internal sqlite was updated to 3.5.9 (at least this is the version xulrunner checks for) and if I build it to use system sqlite, crash is still irreproducible
2. (this question should have appear when xulrunner 1.9 got into the tree, don't know, maybe it did) why was that sqlite version patch needed (and still is):
were mozilla devs in the wrong and it is correct that sqlite 3.5.9 reports its version as 3.5 or is this a sqlite upstream bug and it should report as 3.5.9 ?
Comment 4 Rafał Mużyło 2008-11-17 21:49:59 UTC
As I never accepted the change to builtin sqlite,
I've been building xulrunner/firefox with system sqlite
for quite a while now.
The only time this created problems was when I was using
3.6.1 - it seems that version was leaking.
With both 3.5.9 and 3.6.4 it's working correctly.
Comment 5 Mart Raudsepp gentoo-dev 2008-12-30 13:43:49 UTC
Adding tracker bug reference
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2009-01-03 12:40:51 UTC
(In reply to comment #4)
> As I never accepted the change to builtin sqlite,
> I've been building xulrunner/firefox with system sqlite
> for quite a while now.

So did I since the change for using internal sqlite was introduced into portage. I'm now on sqlite-3.6.7 (not in portage yet) and still have never been able to reproduce any of those crashes which led to the use of internal sqlite.
Comment 7 Raúl Porcel (RETIRED) gentoo-dev 2009-02-10 16:44:50 UTC
*** Bug 258462 has been marked as a duplicate of this bug. ***
Comment 8 Hanno Zysik (geki) 2009-04-16 09:37:27 UTC
And another one here not affected by the crash but a side-effect of internal sqlite use. See:
https://forums.gentoo.org/viewtopic-t-754583.html

In short, the address bar responsiveness went down noticably with internal sqlite....
Have fun! :)
Comment 9 Jory A. Pratt gentoo-dev 2009-07-20 03:29:28 UTC
This has been resolved in xulrunner-1.9.1 I see no point in fixing xulrunner-1.9.0.x as xulrunner-1.9.1 will be unmasked in about a week.