Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 22846 - Original install seems to be autocleaning necessary components like "emerge" during first "emerge system"
Summary: Original install seems to be autocleaning necessary components like "emerge" ...
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: x86 Linux
: High blocker (vote)
Assignee: Nicholas Jones (RETIRED)
Depends on:
Reported: 2003-06-14 20:01 UTC by Jeff Cunningham
Modified: 2011-10-30 22:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

requested emerge.log (emerge.log,200.59 KB, text/plain)
2003-06-24 13:45 UTC, Jeff Cunningham

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Cunningham 2003-06-14 20:01:39 UTC
My installs are are suddenly failing after the bootstrap, when trying to emerge
system. It goes along okay for a time, and then appears to delete files after
file  in /usr/bin and maybe /usr/sbin. After that, 'emerge' itself is gone. So
is 'df'. 

I've tried installing from stages 1, 2, and 3 with the same result. I am not new
to this and have built several stage 1 Gentoo systems in the past without this
ever happening. The only difference I can see is that this machine is behind a
proxy server and is running SCSI disks, while the others are on a home LAN
running IDE drives. But the live CD picks up the SCSI disks just fine, so I
doubt that has anything to do with it. 

Most recently I used wget to download a fresh copy of the stage1 tarball from
ibiblio. It didn't make any difference. 

Reproducible: Always
Steps to Reproduce:
1.Follow install instructions to the letter up to 
# chroot /mnt/gentoo /bin/bash
# env-update
# source /etc/profile
substituting sd* for hd*, and exporting http_proxy="...", etc
2.emerge sync
3.Try emerging anything at this point. The error messages says "command/file not
found". "df" gives the same result.

Actual Results:  
System install can go no further, but I can exit the chroot and everything looks
as it should be. It seems as though portage has hosed itself. 

Expected Results:  
I don't have any listings to give you at this point, because the machine isn't
configured sufficiently for me to capture anything and move it to this one. I'm
going to try again tomorrow and will add more detail if I can obtain it.
Comment 1 Nicholas Jones (RETIRED) gentoo-dev 2003-06-22 14:19:05 UTC
portage version that was installed?
What stage was this system?

Please post /var/log/emerge.log

Comment 2 Jeff Cunningham 2003-06-24 13:45:25 UTC
Created attachment 13794 [details]
requested emerge.log

Here is my emerge.log as per your request. I'm not sure it will do any good, as
I went back and did an entire stage 1 reinstall successfully after setting
AUTOCLEAN="no" in /etc/make.conf. The version of portage I'm working with is
2.0.48-r1. I am using gentoo-sources. 

What you will notice in the log below is the incredibly frequent restarts that
are necessary to get this to emerge sync from behind this corporate firewall.
It will download at a high rate for maybe ten seconds, then stall. Once in a
while it will restart again for a few seconds, then stall again. At that point
it just times out. To get this to ever finish I had to set the rsync retries up
to 1000 and the timeout down to about 10 seconds (it would never start again
after the second stall). I don't know if there's any relationship between this
problem and portage being "autocleaned" out of existence, but I thought I'd
mention it. Feel free to email me if there's anything else I can tell you.
Comment 3 Marius Mauch (RETIRED) gentoo-dev 2003-11-21 14:27:16 UTC
Without being able to reproduce it it's hard to fix (in case it's a bug and wasn't fixed yet).
Comment 4 Jeff Cunningham 2003-12-27 10:46:24 UTC
I have left autocleaning turned off, so I don't know if this bug is fixed or not. But I'm not reading reports of others having this problem anymore either. I'm going to close this on the assumption that this bug has been fixed at some point. 
Jeff Cunningham