Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 228441 - games-arcade/apricots-0.2.6-r1 won't emerge with libtool 2.2.4
Summary: games-arcade/apricots-0.2.6-r1 won't emerge with libtool 2.2.4
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Games
Depends on:
Blocks: libtool-2.2
  Show dependency tree
Reported: 2008-06-20 02:09 UTC by Billy DeVincentis
Modified: 2009-05-06 01:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

updated build system (apri-build.tar.bz2,1.95 KB, application/octet-stream)
2008-06-20 19:16 UTC, Rafał Mużyło
apricots-0.2.6-r2.ebuild (apricots-0.2.6-r2.ebuild,1.60 KB, text/plain)
2008-07-20 22:27 UTC, Billy DeVincentis

Note You need to log in before you can comment on or make changes to this bug.
Description Billy DeVincentis 2008-06-20 02:09:54 UTC
-W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -O2 -march=native -O2 -pipe -fno-exceptions -fno-check-new -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -DAP_PATH=\"/usr/share/games/apricots/\" -DAP_AUDIO_OPENAL -MT all.o -MD -MP -MF .deps/all.Tpo -c -o all.o all.cpp
mv -f .deps/apricots.Tpo .deps/apricots.Po
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I..     -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -O2 -march=native -O2 -pipe -fno-exceptions -fno-check-new -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -DAP_PATH=\"/usr/share/games/apricots/\" -DAP_AUDIO_OPENAL -MT ai.o -MD -MP -MF .deps/ai.Tpo -c -o ai.o ai.cpp
collide.cpp: In function ‘void killbuilding(gamedata&, building&)’:
collide.cpp:322: warning: ‘shrapnel.falltype::image’ may be used uninitialized in this function
mv -f .deps/collide.Tpo .deps/collide.Po
mv -f .deps/all.Tpo .deps/all.Po
mv -f .deps/ai.Tpo .deps/ai.Po
/bin/sh ../libtool --silent --tag=CXX   --mode=link x86_64-pc-linux-gnu-g++  -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -O2 -march=native -O2 -pipe -fno-exceptions -fno-check-new -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -DAP_PATH=\"/usr/share/games/apricots/\" -DAP_AUDIO_OPENAL    -o apricots SDLfont.o shape.o setup.o sampleio.o init.o game.o finish.o fall.o drawall.o drak.o collide.o apricots.o all.o ai.o  -lalut -lopenal  -lSDL -lpthread
../libtool: line 429: CDPATH: command not found
../libtool: line 1121: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.4, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.4
libtool: and run autoconf again.
make[3]: *** [apricots] Error 63
make[3]: Leaving directory `/var/tmp/portage/games-arcade/apricots-0.2.6-r1/work/apricots-0.2.6/apricots'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/games-arcade/apricots-0.2.6-r1/work/apricots-0.2.6/apricots'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/games-arcade/apricots-0.2.6-r1/work/apricots-0.2.6'
make: *** [all] Error 2
 * ERROR: games-arcade/apricots-0.2.6-r1 failed.
 * Call stack:
 *     , line   49:  Called src_compile
 *             environment, line 2830:  Called games_src_compile
 *             environment, line 1820:  Called die
 * The specific snippet of code:
 *           emake || die "emake failed"
 *  The die message:
 *   emake failed
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/games-arcade/apricots-0.2.6-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/games-arcade/apricots-0.2.6-r1/temp/environment'.

Reproducible: Always

emerge --info
Portage (default/linux/amd64/2008.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r4 x86_64)
System uname: 2.6.25-gentoo-r4 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Timestamp of tree: Fri, 20 Jun 2008 01:03:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe"
FEATURES="buildpkg distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/portage/local/miscellaneous /usr/portage/local/desktop-effects"
USE="3dnow S3TC X a52 aac aalib accessibility acl acpi alsa amarok amd64 apm arts artworkextra audiofile automount avahi bash-completion berkdb bidi bittorrent bluetooth branding bzip2 cairo calendar cdda cdio cdparanoia cdr clamav cli cpudetection cracklib crypt css cups curl dbus deprecated devil dga directfb discouraged distribution divx doc dri dts dv dvb dvd dvdr dvdread eds elisp emacs emboss emerald encode esd etc-proposals evo examples exif extraicons fam fat fax fbcon fbcondecor fbsplash ffmpeg firefox flac flash foomaticdb fortran fuse gcj gd gdbm gedit gif gimp glitz gmedia gnome gnutls gphoto2 gpm gstreamer gtk gtkhtml hal hddtemp hfs html htmlhandbook httpd iconv idn ieee1394 imagemagick imlib inkjar ipv6 isdnlog jack java jfs joystick jpeg kde kdehiddenvisibility kerberos lcms ldap libcaca libnotify lirc live lm_sensors logrotate mad mail matroska mdnsresponder-compat midi mikmod mime mjpeg mmx mmxext mng mono mozilla mp3 mpeg mplayer mudflap multilib musicbrainz mysql nas nautilus ncurses networking new-login nforce2 nls nptl nptlonly nsplugin ntfs nvidia odbc offensive ogg opengl openmp pam parport pcre pdf perl pmu png postgres ppds pppd pulseaudio python qt3 qt3support qt4 quicktime rar rdesktop readline realmedia reflection regex reiser4 reiserfs samba scanner sdl seamonkey semantic-desktop servletapi session skins slang slp smp sndfile snmp sound sounds speex spell spl sqlite sse sse2 ssl startup-notification stream subversion svg swat symlink sysfs syslog tcpd tetex theora thesaurus threads thunderbird tidy tiff timidity tk truetype type1 unicode usb userlocales utempter utils v4l vcd vdr vlm voice vorbis vram weather wmf wmp wordperfect wxwindows xattr xcb xcomposite xforms xfs xine xml xorg xpm xprint xscreensaver xv xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Comment 1 Rafał Mużyło 2008-06-20 19:12:17 UTC
The problem here is that the author, by using kdevelop,
created a build system, that's about two orders of magnitude
more complicated, than it should have been.
I don't think there's a clean fix.
Comment 2 Rafał Mużyło 2008-06-20 19:16:03 UTC
Created attachment 157821 [details]
updated build system

However, if I delete all of the old build related files
and add these, it builds (and works) in manual build.
Old patch from the tree is needed, but without section.
Comment 3 Billy DeVincentis 2008-06-21 18:09:20 UTC
I have tried emerging it with your build files but can't.
Comment 4 Rafał Mużyło 2008-06-22 16:21:42 UTC
Cause those build files work for manual builds,
for them to work with portage, you'd have to add a lot
to the ebuild.
Simply eautoreconf would probably not be enough.
I think that before that, you'd have to at least delete old
Makefile* in all of the dirs.
Comment 5 Rafał Mużyło 2008-06-22 16:23:31 UTC
Old acinclude.m4 and aclocal.m4, too.
Comment 6 Rafał Mużyło 2008-06-22 16:25:48 UTC
It's mostly due to the way old acinclude.m4 was created,
it's so difficult to fix now.
Comment 7 Billy DeVincentis 2008-06-22 22:00:51 UTC
So what if anything can be done to fix this, I mean I know I can emerge this by temporarily downgrading libtool to 1.5, emerging apricots and then upgrading libtool again but thats really not the answer. Is there anyway of putting together the build system and repackaging it as a new apricots-r2.tar.gz and creating a new version?
Comment 8 Rafał Mużyło 2008-06-23 20:33:42 UTC
What have you changed in the ebuild,
cause I think that 
removing old Makefile*, configure*, aclocal.m4 and acinclude.m4 and
adding my files,
followed by eautoreconf should be enough (yeah, I know that's a lot).
Comment 9 Billy DeVincentis 2008-06-23 23:24:44 UTC
I have not changed anything in the ebuild, what I did was extract the apricots tar.gz file in /usr/portage/distfiles and replace and with the ones from your attachment. I noticed that in your attachment there are 2 folders , one within the other. I used only the 2 files from the data folder and didnt use the 2nd makefile in the inner apricots folder. I then compressed new apricots folder to tar.gz with your new files inside, place it in distfiles and remanifested and tried to emerge unsuccessfully. 
 Please give me exact directions as to how to use your files, all 3 files in your attachment and what else to do to emerge this.
Comment 10 Rafał Mużyło 2008-06-24 09:10:31 UTC
So you want to create a new tarball, in that case do following:
from the old tarball, remove all Makefile* (not only toplevel, all)
remove from toplevel: config*, ac*.m4
put my files were they should be
apply patch from the tree (but without block)
run 'autoreconf -fi' while in top level
run 'make dist'
This way, you should get a clean tarball.
Comment 11 Rafał Mużyło 2008-06-24 09:11:52 UTC
Yes, it won't have a few dirs, but that shouldn't impact the game.
Comment 12 Billy DeVincentis 2008-07-20 22:27:30 UTC
Created attachment 160961 [details]

Okay, I have found a simpler way of fixing this. Simply removing eautoreconf seems to fix the problem. I got stuck in that with portage 2.2, emerge @preserved-rebuild forced me to reemerge apricots and just a quick fix wasn't going to do it. I have modified the ebuild, bumped the version, and it emerges and operates perfectly. Please add this to tree.
Comment 13 Billy DeVincentis 2008-10-17 11:23:16 UTC
If you still can't emerge this, its because you need the newer openal
Comment 14 Hans Meier 2008-12-04 23:43:54 UTC
I have succesfully installed Apricots with Yours ebuild

Downloaded ebuild to


cp -a /usr/portage/games-arcade/apricots/files /usr/local/portage/local/games-arcade/apricots

ebuild apricots-0.2.6-r2.ebuil digest

update eix

emerge -a apricots
Comment 15 Peter Alfredsen (RETIRED) gentoo-dev 2009-05-06 01:44:32 UTC
+  06 May 2009; Peter Alfredsen <>
+  apricots-0.2.6-r1.ebuild:
+  Fix bug 228441 by cp'ing libtool-free admin/ to
+  acinclude.m4