Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 228227 - x11-misc/temperature-app-1.4 removal request (was: fails to build with gcc 4.3)
Summary: x11-misc/temperature-app-1.4 removal request (was: fails to build with gcc 4.3)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Desktop Misc. Team
URL:
Whiteboard:
Keywords:
: 251785 (view as bug list)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-06-18 22:27 UTC by Evil Compile Person
Modified: 2009-06-20 15:13 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
temperature-app-1.4-std-headers.patch (temperature-app-1.4-std-headers.patch,1.65 KB, patch)
2008-12-18 22:28 UTC, Santiago M. Mola (RETIRED)
Details | Diff
temperature-app-1.4-fix-url.patch (temperature-app-1.4-fix-url.patch,881 bytes, patch)
2008-12-18 22:28 UTC, Santiago M. Mola (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Evil Compile Person 2008-06-18 22:27:06 UTC
>>> Compiling source in /var/tmp/portage/x11-misc/temperature-app-1.4/work/Temperature.app-1.4 ...
c++ -O2 -pipe -Wall -pedantic -fno-rtti -fno-exceptions -O2 -I/usr/X11R6/include   -c -o Main.o Main.cc
In file included from Main.cc:22:
Temperature.h:25:21: error: fstream.h: No such file or directory
In file included from Main.cc:22:
Temperature.h:66: error: 'ifstream' has not been declared
make: *** [Main.o] Error 1
 *
 * ERROR: x11-misc/temperature-app-1.4 failed.

Portage 2.1.4.4 (default-linux/amd64/2007.0, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25.1 x86_64)
=================================================================
System uname: 2.6.25.1 x86_64 Dual-Core AMD Opteron(tm) Processor 2212 HE
Timestamp of tree: Tue, 17 Jun 2008 20:45:01 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.2-r4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.62
sys-devel/automake:  1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://216.165.129.134/gentoo http://gentoo.mirrors.tds.net/gentoo http://gentoo.osuosl.org/"
LANG="en_US"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://208.71.112.51/gentoo-portage"
USE="X acl amd64 berkdb cli cracklib crypt cups dri fortran gcj gdbm gpm iconv ipv6 isdnlog midi mmx mudflap ncurses nls nptl nptlonly objc openmp pam pcre perl pppd python readline reflection session spl sse sse2 ssl tcpd unicode xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Santiago M. Mola (RETIRED) gentoo-dev 2008-12-18 22:28:08 UTC
Created attachment 175810 [details, diff]
temperature-app-1.4-std-headers.patch

Use standard C++ headers, that way we have compatibility with gcc 4.3.
Comment 2 Santiago M. Mola (RETIRED) gentoo-dev 2008-12-18 22:28:50 UTC
Created attachment 175811 [details, diff]
temperature-app-1.4-fix-url.patch

URL to get ICAO codes is outdated.
Comment 3 Santiago M. Mola (RETIRED) gentoo-dev 2008-12-18 22:30:43 UTC
After fixing this, I get the following:
$ ./Temperature.app -s KANB
Temperature.app: could not fetch temperature (wget not found in $PATH)

It would be nice if someone can look into it and we can decide if we fix or punt it.

By the way, new HOMEPAGE is http://www.fukt.bsnet.se/~per/temperature/
Comment 4 Santiago M. Mola (RETIRED) gentoo-dev 2008-12-20 19:03:38 UTC
*** Bug 251785 has been marked as a duplicate of this bug. ***
Comment 5 Peter Alfredsen (RETIRED) gentoo-dev 2009-02-15 19:24:17 UTC
@treecleaners
Package seems broken, even with patches for gcc-4.3. Herd unresponsive.
Comment 6 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-14 00:11:05 UTC
# Jeremy Olexa <darkside@gentoo.org> (14 Apr 2009)
# Masked for removal in 60 days. Broken with gcc-4.3, doesn't work after gcc
# patches, no maintainer, dead upstream. bug 228227
x11-misc/temperature-app
Comment 7 Samuli Suominen gentoo-dev 2009-06-20 15:13:15 UTC
Removed from tree.