Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 228183 - sys-cluster/lam-mpi-7.1.4 fails with libtool 2.2
Summary: sys-cluster/lam-mpi-7.1.4 fails with libtool 2.2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Justin Bronder (RETIRED)
URL:
Whiteboard:
Keywords:
: 248415 (view as bug list)
Depends on:
Blocks: libtool-2.2
  Show dependency tree
 
Reported: 2008-06-18 22:01 UTC by Evil Compile Person
Modified: 2009-01-25 21:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
files/lam-mpi-7.1.4-libtool-compatibility.patch (lam-mpi-7.1.4-libtool-compatibility.patch,362 bytes, patch)
2008-08-05 17:34 UTC, Boian Berberov
Details | Diff
lam-mpi-7.1.4.ebuild.patch (lam-mpi-7.1.4.ebuild.patch,1.12 KB, patch)
2008-08-05 17:40 UTC, Boian Berberov
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Evil Compile Person 2008-06-18 22:01:23 UTC
config.status: creating config.h
config.status: executing depfiles commands
configure: WARNING: Unrecognized options: --without-trillium, --with-threads, --without-romio, --with-rsh, --with-fc, --enable-ltdl-convenience

configure: /bin/sh './configure' succeeded for share/libltdl
checking for libtool-supplied linker flags... libtool error!
configure: error: Cannot continue

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-cluster/lam-mpi-7.1.4/work/lam-7.1.4/config.log
 *
 * ERROR: sys-cluster/lam-mpi-7.1.4 failed.

config.log has many lines like this:
/var/tmp/portage/sys-cluster/lam-mpi-7.1.4/work/lam-7.1.4/share/libltdl/libtool: line 463: CDPATH: command not found
/var/tmp/portage/sys-cluster/lam-mpi-7.1.4/work/lam-7.1.4/share/libltdl/libtool: line 1148: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.4, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.4
libtool: and run autoconf again.
configure:39634: $? = 0

Portage 2.1.4.4 (default-linux/amd64/2007.0, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25.1 x86_64)
=================================================================
System uname: 2.6.25.1 x86_64 Dual-Core AMD Opteron(tm) Processor 2212 HE
Timestamp of tree: Tue, 17 Jun 2008 20:45:01 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.2-r4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.62
sys-devel/automake:  1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://216.165.129.134/gentoo http://gentoo.mirrors.tds.net/gentoo http://gentoo.osuosl.org/"
LANG="en_US"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://208.71.112.51/gentoo-portage"
USE="X acl amd64 berkdb cli cracklib crypt cups dri fortran gcj gdbm gpm iconv ipv6 isdnlog midi mmx mudflap ncurses nls nptl nptlonly objc openmp pam pcre perl pppd python readline reflection session spl sse sse2 ssl tcpd unicode xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Justin Bronder (RETIRED) gentoo-dev 2008-06-19 01:01:25 UTC
Be a little bit before I can mess with this as I guess I'll need a chroot.  I think I just need to remove the included libltdl stuff and use the system versions instead, but we'll see :)

Thanks for reporting and if you have better ideas/patches, let me know.
Comment 2 Boian Berberov 2008-08-05 17:34:10 UTC
Created attachment 162280 [details, diff]
files/lam-mpi-7.1.4-libtool-compatibility.patch
Comment 3 Boian Berberov 2008-08-05 17:40:42 UTC
Created attachment 162281 [details, diff]
lam-mpi-7.1.4.ebuild.patch

With these changes it compiles for me.  Unfortunately, I cannot test it.  Hope this helps.
Comment 4 Justin Bronder (RETIRED) gentoo-dev 2008-11-24 21:39:11 UTC
*** Bug 248415 has been marked as a duplicate of this bug. ***
Comment 5 Justin Bronder (RETIRED) gentoo-dev 2009-01-25 18:21:43 UTC
(In reply to comment #3)
> Created an attachment (id=162281) [edit]
> lam-mpi-7.1.4.ebuild.patch
> 
> With these changes it compiles for me.  Unfortunately, I cannot test it.  Hope
> this helps.
> 

Sadly that makes lam think it needs 'libtool: link:' in the LDFLAGS.

mejis lam-7.1.4 # mpicc --showme
x86_64-pc-linux-gnu-gcc -pthread libtool: link: -pthread -L/usr/lib64 -llamf77mpi -lmpi -llam -lutil -ldl

Haven't figure out how to strip that junk out yet.
Comment 6 Justin Bronder (RETIRED) gentoo-dev 2009-01-25 21:02:26 UTC
lam-mpi-7.1.4-r1 appears to be working.  Thanks for the patch that got me started Boian!