Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 227601 - app-pda/plptools removal request (was: 0.13 fails to build)
Summary: app-pda/plptools removal request (was: 0.13 fails to build)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo TreeCleaner Project
URL:
Whiteboard:
Keywords:
: 240101 249912 (view as bug list)
Depends on: 251363
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-06-16 18:52 UTC by Evil Compile Person
Modified: 2009-07-30 12:57 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
plptools ebuild. (plptools-1.0.8.ebuild,1.12 KB, text/plain)
2009-06-11 21:27 UTC, Nico Baggus
Details
conf.d/plptools file (psion-1.0.8.conf,94 bytes, text/plain)
2009-06-11 21:28 UTC, Nico Baggus
Details
plptools start script (psion,1.09 KB, text/plain)
2009-06-11 21:28 UTC, Nico Baggus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Evil Compile Person 2008-06-16 18:52:45 UTC
i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../include -I../intl -D_REENTRANT -O2 -O2 -march=i686 -pipe -fno-exceptions -fno-check-new -MT rfsvfactory.lo -MD -MP -MF .deps/rfsvfactory.Tpo -c rfsvfactory.cc  -fPIC -DPIC -o .libs/rfsvfactory.o
rfsvfactory.cc:40: error: specialization of 'Enum<E>::sdata::sdata() [with E = rfsvfactory::errs]' after instantiation
rfsvfactory.cc:40: error: invalid function declaration
make[1]: *** [rfsvfactory.lo] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-pda/plptools-0.13/work/plptools-0.13/lib'
make: *** [all-recursive] Error 1
 *
 * ERROR: app-pda/plptools-0.13 failed.

Portage 2.1.4.4 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.20-vs2.2.0-gentoo i686)
=================================================================
System uname: 2.6.20-vs2.2.0-gentoo i686 Intel(R) Pentium(R) D CPU 3.20GHz
Timestamp of tree: Fri, 13 Jun 2008 17:45:01 +0000
app-shells/bash:     3.2_p33
dev-lang/python:     2.4.4-r13
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.61-r1
sys-devel/automake:  1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.switch.ch/mirror/gentoo/"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X acl berkdb cli cracklib crypt cups dri fortran gcj gdbm gpm iconv ipv6 isdnlog midi mudflap ncurses nls nptl nptlonly objc openmp pam pcre perl pppd python readline reflection session spl ssl tcpd unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2008-10-21 13:19:43 UTC
*** Bug 240101 has been marked as a duplicate of this bug. ***
Comment 2 Mark Loeser (RETIRED) gentoo-dev 2008-10-26 00:10:14 UTC
@pda team: it seems we are very very far behind on versions for this package.  Could we bump up to 1.0.5?  That seems to compile just fine (I just got rid of the src_unpack part of our ebuild).  I leave the rest to you guys to determine if its still necessary.
Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2008-12-17 22:16:02 UTC
*** Bug 249912 has been marked as a duplicate of this bug. ***
Comment 4 Ryan Hill (RETIRED) gentoo-dev 2009-02-15 20:41:27 UTC
pda herd is abandoned.
Comment 5 Ryan Hill (RETIRED) gentoo-dev 2009-02-15 20:53:57 UTC
possible candidate for removal.

upstream is active, last release Dec 2008.
package last bumped 2005
tools for speciality hardware - Psion 3 PDAs produced in the 90's
http://en.wikipedia.org/wiki/Psion_3
http://en.wikipedia.org/wiki/EPOC_(computing)
Comment 6 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-14 00:17:22 UTC
(In reply to comment #5)
> possible candidate for removal.
> 
> upstream is active, last release Dec 2008.
> package last bumped 2005
> tools for speciality hardware - Psion 3 PDAs produced in the 90's
> http://en.wikipedia.org/wiki/Psion_3
> http://en.wikipedia.org/wiki/EPOC_(computing)
> 

Thanks for your analysis. In this case, I vote +1 for removal because I doubt any dev even has hardware to test.
Comment 7 Mark Loeser (RETIRED) gentoo-dev 2009-05-16 23:21:57 UTC
Please punt :)
Comment 8 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-30 01:28:52 UTC
# Jeremy Olexa <darkside@gentoo.org> (30 May 2009)
# Masked for removal in 60 days. Doesn't build, version bump pending. Designed
# for really old PDA hardware (circa '90s) - will need a maintainer that has
# hardware. bug 227601
app-pda/plptools
Comment 9 MickKi 2009-05-30 08:10:55 UTC
Hi All,

I'm no maintainer, but have the hardware.  Happy to test if that will help to not remove it from portage - I guess the fact that a bug was raised for it was because people are still using these pdas?
Comment 10 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-06-01 15:30:00 UTC
(In reply to comment #9)
> Hi All,
> 
> I'm no maintainer, but have the hardware.  Happy to test if that will help to
> not remove it from portage - I guess the fact that a bug was raised for it was
> because people are still using these pdas?
> 

Hey, 
the bug was raised because it fails to build ;) So, that will need to be fixed, then we need to find people that use this software. Even if you have hardware, it doesn't make sense to keep this package around if no one uses it.
Comment 11 MickKi 2009-06-01 18:32:57 UTC
(In reply to comment #10)

> Hey, 
> the bug was raised because it fails to build ;) 

Sure, but that means someone wanted to build it - unless this is some audit of what builds and what not with the latest toolchain?

> So, that will need to be fixed,
> then we need to find people that use this software. Even if you have hardware,
> it doesn't make sense to keep this package around if no one uses it.

Yes, fair enough.
-- 
Regards,
Mick
Comment 12 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-01 18:49:59 UTC
> > the bug was raised because it fails to build ;) 
> 
> Sure, but that means someone wanted to build it - unless this is some audit of
> what builds and what not with the latest toolchain?

Given it was Patrick reporting it, I guess it was his tinderbox; there are two duplicates, the first I can't speak about, but the second is mine and it also came out of a tinderbox. So yeah should just wither away.
Comment 13 Nico Baggus 2009-06-11 21:27:39 UTC
Created attachment 194299 [details]
plptools ebuild.

"working" ebuild.
Comment 14 Nico Baggus 2009-06-11 21:28:28 UTC
Created attachment 194300 [details]
conf.d/plptools file
Comment 15 Nico Baggus 2009-06-11 21:28:57 UTC
Created attachment 194301 [details]
plptools start script
Comment 16 Nico Baggus 2009-06-11 21:29:27 UTC
Here is an ebuild that at least builds a tool v.1.0.8
It can probably be improved.

I still do have the hardware and I guess i'm one of the last of the mohicans.
It can auto-attach if some udev rules are added (they are in the kit).
Comment 17 MickKi 2009-07-12 16:23:00 UTC
(In reply to comment #16)
> Here is an ebuild that at least builds a tool v.1.0.8
> It can probably be improved.

If this is v.1.0.8 should its header look like this?
====================================================
# $Header: /var/cvsroot/gentoo-x86/app-pda/plptools/plptools-0.16.ebuild,v 1.1 2006/11/13 12:52:57 nbaggus Exp $
====================================================

I gave it a spin but it failed like so when I tried to generate a Manifest:
====================================================
# ebuild plptools-1.0.8.ebuild manifest
/usr/lib/portage/bin/ebuild.sh: line 1818: /usr/local/portage/app-pda/plptools/plptools-1.0.8.ebuild: Permission denied
 * 
 * ERROR: app-pda/plptools-1.0.8 failed.
 * Call stack:
 *               ebuild.sh, line 1879:  Called _source_ebuild
 *               ebuild.sh, line 1818:  Called die
 * The specific snippet of code:
 *      source "${EBUILD}" || die "error sourcing ebuild"
 *  The die message:
 *   error sourcing ebuild
====================================================
-- 
Regards,
Mick
Comment 18 Víctor Ostorga (RETIRED) gentoo-dev 2009-07-12 16:51:29 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > Here is an ebuild that at least builds a tool v.1.0.8
> > It can probably be improved.
> 
> If this is v.1.0.8 should its header look like this?
> ====================================================
> # $Header: /var/cvsroot/gentoo-x86/app-pda/plptools/plptools-0.16.ebuild,v 1.1
> 2006/11/13 12:52:57 nbaggus Exp $
> ====================================================
> 
It is not needed to touch the ebuild header to make a manifest


> I gave it a spin but it failed like so when I tried to generate a Manifest:
> ====================================================
> # ebuild plptools-1.0.8.ebuild manifest
> /usr/lib/portage/bin/ebuild.sh: line 1818:
> /usr/local/portage/app-pda/plptools/plptools-1.0.8.ebuild: Permission denied

Check the permissions of the user you are trying to do the manifest.
Hint: do it as root
Comment 19 MickKi 2009-07-12 17:10:45 UTC
(In reply to comment #18)

> > /usr/local/portage/app-pda/plptools/plptools-1.0.8.ebuild: Permission denied
> 
> Check the permissions of the user you are trying to do the manifest.
> Hint: do it as root

Thanks, but the hash on my ebuild command line indicates that I did exactly that.  This is the ebuild file and its permissions:

# ls -la /usr/local/portage/app-pda/plptools/                      
total 4
drwx------ 3 root root  112 Jul 12 17:21 .
drwxr-xr-x 3 root root   72 May 11  2005 ..
drwx------ 2 root root  192 Jul 12 17:05 files
-rw-r--r-- 1 root root 1145 Jul 12 17:14 plptools-1.0.8.ebuild

Comment 20 Samuli Suominen gentoo-dev 2009-07-30 12:57:07 UTC
Removed from tree.