Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 227395 - media-libs/ctl does not compile with gcc 4.3
Summary: media-libs/ctl does not compile with gcc 4.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-06-16 09:56 UTC by Robert Piasek (RETIRED)
Modified: 2008-06-20 19:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
patch (ctl-4.3.diff,555 bytes, patch)
2008-06-16 09:59 UTC, Robert Piasek (RETIRED)
Details | Diff
ebuild (ctl-1.4.1.ebuild,832 bytes, text/plain)
2008-06-16 10:15 UTC, Robert Piasek (RETIRED)
Details
ctl-1.4.1-gcc43.patch (ctl-1.4.1-gcc43.patch,3.92 KB, patch)
2008-06-20 19:46 UTC, Peter Alfredsen (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Piasek (RETIRED) gentoo-dev 2008-06-16 09:56:52 UTC
Compile with gcc 4.3 fails because of lack of some includes

Reproducible: Always
Comment 1 Robert Piasek (RETIRED) gentoo-dev 2008-06-16 09:59:38 UTC
Created attachment 157055 [details, diff]
patch
Comment 2 Robert Piasek (RETIRED) gentoo-dev 2008-06-16 10:15:56 UTC
Created attachment 157059 [details]
ebuild
Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2008-06-20 19:46:09 UTC
Created attachment 157823 [details, diff]
ctl-1.4.1-gcc43.patch

This is the patch I committed. Yours had all of the normal compilation right, but failed during 'make check'.
Comment 4 Peter Alfredsen (RETIRED) gentoo-dev 2008-06-20 19:46:34 UTC
+  20 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+  +files/ctl-1.4.1-gcc43.patch, ctl-1.4.1.ebuild:
+  Fix gcc-4.3 compilation. Thanks to Robert Piasek
+  <robert.piasek@member.fsf.org> in bug 227395 for the first part of the
+  patch.
+