Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 227261 - No text with >=xf86-video-i810-2.2*
Summary: No text with >=xf86-video-i810-2.2*
Status: VERIFIED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Rémi Cardona
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-15 16:50 UTC by René 'Necoro' Neumann
Modified: 2008-06-24 10:55 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Xorg.log (Xorg.0.log,38.03 KB, text/plain)
2008-06-15 16:51 UTC, René 'Necoro' Neumann
Details
lspci -v output (lspci.out,9.83 KB, text/plain)
2008-06-15 16:52 UTC, René 'Necoro' Neumann
Details
xorg.conf (xorg.conf,3.21 KB, text/plain)
2008-06-15 16:54 UTC, René 'Necoro' Neumann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description René 'Necoro' Neumann 2008-06-15 16:50:25 UTC
When using the >=xf86-video-i810-2.2* on an Acer Aspire 5315 with X3100 Card (should be an Intel i965GM), no text is being displayed. The only part of the text, which is visible are the lines which normally mark a shortcut.

This does not happen with version 2.1.* - but as this has several issues with 3D apps I wanted to solve them by upgrading ...

I can't see an error in the logs, but I'll attach them nonetheless

Used xorg-server: 1.3.0.0-r6

The emerge --info output:
--------------------------

Portage 2.1.4.4 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo-r8 i686)
=================================================================
System uname: 2.6.24-gentoo-r8 i686 Intel(R) Celeron(R) CPU 530 @ 1.73GHz
Timestamp of tree: Sat, 14 Jun 2008 10:45:01 +0000
app-shells/bash:     3.2_p33
dev-lang/python:     2.5.2-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/init.d /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/var/distfiles"
FEATURES="candy distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,--as-needed -Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa asf bash-completion berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt css dbus dri dvd dvdr dvdread emboss encode evo fam firefox flac gdbm gif gpm gtk hal iconv isdnlog jpeg kdehiddenvisibility libnotify mad midi mikmod mmap mmx mp3 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp pcre pdf perl png ppds pppd python qt3support quicktime readline real reflection sdl session spell spl sse sse2 ssl ssse3 startup-notification svg tcpd threads tiff truetype unicode usb vorbis wifi win32codecs x86 xcb xml xorg xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="i810 intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 René 'Necoro' Neumann 2008-06-15 16:51:38 UTC
Created attachment 156947 [details]
Xorg.log
Comment 2 René 'Necoro' Neumann 2008-06-15 16:52:23 UTC
Created attachment 156949 [details]
lspci -v output
Comment 3 René 'Necoro' Neumann 2008-06-15 16:54:14 UTC
Created attachment 156951 [details]
xorg.conf
Comment 4 Rémi Cardona gentoo-dev 2008-06-16 13:08:02 UTC
Could you try with the latest ~arch driver (2.3.1-r2 for now)?

Thanks
Comment 5 René 'Necoro' Neumann 2008-06-16 13:20:18 UTC
Same error ...
The Xorg.0.log posted here is actually from running a 2.3.1 version (though I can't recall the correct revision)...
Comment 6 Rémi Cardona gentoo-dev 2008-06-16 13:24:56 UTC
Could you try upgrading to xorg-server 1.4.2 with its required deps?

If it works, then great :) one more reason for 1.4.x to go stable.

If it doesn't work, then it's most likely an intel specific bug, which you'll have to report upstream.

Thanks
Comment 7 René 'Necoro' Neumann 2008-06-16 13:36:56 UTC
I'll try... Though I don't expect something, as I already tried xorg-1.4.* some time ago. But I don't know now which version of the intel driver I have used then.

As this is not my own laptop, I can't test it during this week, but hopefully next weekend.
Comment 8 Rémi Cardona gentoo-dev 2008-06-16 13:41:24 UTC
(In reply to comment #7)
> As this is not my own laptop, I can't test it during this week, but hopefully
> next weekend.

Alright, so once you can test and if it still fails, please :
 - read this document : http://intellinuxgraphics.org/how_to_report_bug.html
 - report the bug over at https://bugs.freedesktop.org
 - add "remi@gentoo.org" as a CC on that bug so I can track it there

Thanks for taking the time to track it down
Comment 9 René 'Necoro' Neumann 2008-06-22 15:35:54 UTC
Ok - does not work with xorg-1.4.2 ... going to file a bug upstream
Comment 10 René 'Necoro' Neumann 2008-06-22 16:08:20 UTC
Done -> http://bugs.freedesktop.org/show_bug.cgi?id=16463
Comment 11 René 'Necoro' Neumann 2008-06-23 19:55:31 UTC
Just as a reference:
Setting AccelMethod to XAA resolved the issue :)

And together with xorg-server-1.4, even DRI works now as it should (same issue as in bug #219867)
Comment 12 Rémi Cardona gentoo-dev 2008-06-23 22:54:56 UTC
I don't really mind but imho, going back to XAA is not a proper solution. It can only be qualified as a temporary and ugly hack :) XAA is the old way of accelerating gfx operations which basically boils down to no acceleration at all (the graphic primitives it actually accelerates are almost unused by modern toolkits).

Let's make sure upstream is able to fix the bug for real.
Comment 13 René 'Necoro' Neumann 2008-06-24 10:55:58 UTC
I completely agree...

But as the problem itself ("it does not work") is solved (though using a workaround), I had chosen to close this Gentoo bug - leaving the upstream one open.