Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 22724 - gcc-3.2.3-r1 failed. Line 345, Exitcode 2
Summary: gcc-3.2.3-r1 failed. Line 345, Exitcode 2
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: Sparc Linux
: High normal (vote)
Assignee: Sparc Porters
Depends on:
Reported: 2003-06-12 20:26 UTC by Joe Kallar (RETIRED)
Modified: 2006-02-04 06:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Joe Kallar (RETIRED) gentoo-dev 2003-06-12 20:26:07 UTC
emerge gcc 3.2.3-r1 fails

Reproducible: Always
Steps to Reproduce:
1. ACCEPT_KEYWORDS="~sparc" emerge gcc

Actual Results:  
/usr/include/bits/sigset.h: At top level:
/var/tmp/portage/gcc-3.2.3-r1/work/gcc-3.2.3/gcc/protector.c:82: warning:
`debuginsn' defined but not used
make[2]: *** [protector.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/gcc-3.2.3-r1/work/build/gcc'
make[1]: *** [stage1_build] Error 2
make[1]: Leaving directory `/var/tmp/portage/gcc-3.2.3-r1/work/build/gcc'
make: *** [bootstrap-lean] Error 2

!!! ERROR: sys-devel/gcc-3.2.3-r1 failed.
!!! Function src_compile, Line 345, Exitcode 2
!!! (no error message)

Expected Results:  
should emerge sucessfully

# emerge info
Portage 2.0.48-r1 (default-sparc64-1.4, gcc-3.2.2, glibc-2.3.1-r4)
System uname: 2.4.20-sparc-r8 sparc64 sun4u
CONFIG_PROTECT="/etc /var/qmail/control /usr/share/config
/usr/kde/2/share/config /usr/kde/3/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="sparc arts apm avi encode esd gif gtk imlib jpeg libwww mikmod motif mpeg
oggvorbis oss spell xv xmms zlib gdbm readline pam -X -kde -java -opengl -pdflib
-qt -truetype -gnome -nls berkdb crypt cups dga directfb doc fbcon kerberos
mysql ncurses perl png python samba ssl sdl slang tcpd tiff xml xml2"
CFLAGS="-mcpu=ultrasparc -mtune=ultrasparc -O3 -pipe"
CXXFLAGS="-mcpu=ultrasparc -mtune=ultrasparc -O3 -pipe"
FEATURES="sandbox ccache"
Comment 1 Jörn Ott 2003-06-19 14:09:13 UTC
I encountered the same problem on an i586 system. After increasing the swap by around 200M, the bug was gone. I guess the sparc might need a bit more swap than the intel architecture, so you might try that solution
Comment 2 Joe Kallar (RETIRED) gentoo-dev 2003-06-19 14:14:37 UTC
# free
             total       used       free     shared    buffers     cached
Mem:        885896     870080      15816          0     135856     544008
-/+ buffers/cache:     190216     695680
Swap:       391400          0     391400

Ram is 900MB, and Swap is 384MB... :( I don't *think* that should be an issue.
Comment 3 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2003-06-21 02:29:27 UTC
I have just hit the same thing on my new dual xeon 2.66ghz at work.
Running ~x86.
1Gb Registered ECC RAM, 3gb Swap, so I don't think that is an issue.

However when I run the emerge again (nothing else done in the meantime on the system) after a little while it worked 100%.
Possibly this is either an intermittant bug with something common to all systems or a weird place that gcc hits really hard on hardware.
Comment 4 Joe Kallar (RETIRED) gentoo-dev 2003-06-21 07:45:40 UTC
Changed MAKEOPTS="-j3" and problem solved. This is an SMP system, and I noticed emerge info makes no indication of SMP.

per Keith M Wesolowski:
<wesolows> a good possibility on that gcc fail is parallel make b0rkage
<BladeMan> ah, so crank back the j4?
<wesolows> can't hurt to try

# emerge info
Portage 2.0.48-r1 (default-sparc64-1.4, gcc-3.2.3, glibc-2.3.1-r4)
System uname: 2.4.21 sparc64 sun4u
# uname -a
Linux 2.4.21 #2 SMP Thu Jun 19 13:52:23 EDT 2003 sparc64 sun4u TI UltraSparc II  (BlackBird) GNU/Linux
Comment 5 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2003-06-21 11:47:10 UTC
Thanks, that is worthwhile noting.
Could the gcc people please see about fixing their makefiles so that parallel makes work properly?
Comment 6 Jason Wever (RETIRED) gentoo-dev 2003-08-17 07:38:53 UTC