Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 227231 - sys-block/partimage-0.6.7 won't emerge with gcc 4.3.1
Summary: sys-block/partimage-0.6.7 won't emerge with gcc 4.3.1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Christian Zoffoli (RETIRED)
URL:
Whiteboard:
Keywords:
: 229261 (view as bug list)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-06-15 15:44 UTC by Billy DeVincentis
Modified: 2008-07-17 02:14 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Billy DeVincentis 2008-06-15 15:44:54 UTC
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating src/shared/Makefile
config.status: creating src/shared/pathnames.h
config.status: creating src/client/Makefile
config.status: creating src/client/fs/Makefile
config.status: creating src/server/Makefile
config.status: creating m4/Makefile
config.status: creating po/Makefile.in
config.status: WARNING:  po/Makefile.in.in seems to ignore the --datarootdir setting
config.status: creating config.h
config.status: executing default-1 commands
config.status: creating po/POTFILES
config.status: creating po/Makefile
config.status: executing depfiles commands
make  all-recursive
make[1]: Entering directory `/var/tmp/portage/sys-block/partimage-0.6.7/work/partimage-0.6.7'
Making all in m4
make[2]: Entering directory `/var/tmp/portage/sys-block/partimage-0.6.7/work/partimage-0.6.7/m4'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/var/tmp/portage/sys-block/partimage-0.6.7/work/partimage-0.6.7/m4'
Making all in po
make[2]: Entering directory `/var/tmp/portage/sys-block/partimage-0.6.7/work/partimage-0.6.7/po'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/var/tmp/portage/sys-block/partimage-0.6.7/work/partimage-0.6.7/po'
Making all in src
make[2]: Entering directory `/var/tmp/portage/sys-block/partimage-0.6.7/work/partimage-0.6.7/src'
Making all in shared
make[3]: Entering directory `/var/tmp/portage/sys-block/partimage-0.6.7/work/partimage-0.6.7/src/shared'
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/share/locale\" -D_REENTRANT -D_FILE_OFFSET_BITS=64 -I. -I../.. -I../.. -I../../src/client -I../../src/shared -I/usr/include/slang  -Wno-deprecated -I/usr/include/openssl -Wall  -march=native -O2 -pipe -MT common.o -MD -MP -MF .deps/common.Tpo -c -o common.o common.cpp
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/share/locale\" -D_REENTRANT -D_FILE_OFFSET_BITS=64 -I. -I../.. -I../.. -I../../src/client -I../../src/shared -I/usr/include/slang  -Wno-deprecated -I/usr/include/openssl -Wall  -march=native -O2 -pipe -MT access.o -MD -MP -MF .deps/access.Tpo -c -o access.o access.cpp
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/share/locale\" -D_REENTRANT -D_FILE_OFFSET_BITS=64 -I. -I../.. -I../.. -I../../src/client -I../../src/shared -I/usr/include/slang  -Wno-deprecated -I/usr/include/openssl -Wall  -march=native -O2 -pipe -MT net.o -MD -MP -MF .deps/net.Tpo -c -o net.o net.cpp
In file included from net.cpp:22:
net.h:31:22: error: iostream.h: No such file or directory
common.cpp:61: warning: deprecated conversion from string constant to ‘char*’
mv -f .deps/access.Tpo .deps/access.Po
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/share/locale\" -D_REENTRANT -D_FILE_OFFSET_BITS=64 -I. -I../.. -I../.. -I../../src/client -I../../src/shared -I/usr/include/slang  -Wno-deprecated -I/usr/include/openssl -Wall  -march=native -O2 -pipe -MT exceptions.o -MD -MP -MF .deps/exceptions.Tpo -c -o exceptions.o exceptions.cpp
make[3]: *** [net.o] Error 1
make[3]: *** Waiting for unfinished jobs....
mv -f .deps/common.Tpo .deps/common.Po
mv -f .deps/exceptions.Tpo .deps/exceptions.Po
make[3]: Leaving directory `/var/tmp/portage/sys-block/partimage-0.6.7/work/partimage-0.6.7/src/shared'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/sys-block/partimage-0.6.7/work/partimage-0.6.7/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/sys-block/partimage-0.6.7/work/partimage-0.6.7'
make: *** [all] Error 2
 *
 * ERROR: sys-block/partimage-0.6.7 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3113:  Called die
 * The specific snippet of code:
 *       emake || die "make failed"
 *  The die message:
 *   make failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-block/partimage-0.6.7/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-block/partimage-0.6.7/temp/environment'.


Reproducible: Always




emerge --info
Portage 2.1.5.5 (default/linux/amd64/2008.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.25-gentoo-r4 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Timestamp of tree: Sun, 15 Jun 2008 05:35:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS=""
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/miscellaneous /usr/portage/local/desktop-effects"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow S3TC X a52 aac aalib accessibility acl acpi alsa amarok amd64 apm arts artworkextra audiofile automount avahi bash-completion berkdb bidi bittorrent bluetooth branding bzip2 cairo calendar cdda cdio cdparanoia cdr clamav cli cpudetection cracklib crypt css cups curl dbus deprecated devil dga directfb discouraged distribution divx doc dri dts dv dvb dvd dvdr dvdread eds elisp emacs emboss emerald encode esd etc-proposals evo examples exif extraicons fam fat fax fbcon fbcondecor fbsplash ffmpeg firefox flac flash foomaticdb fortran fuse gcj gd gdbm gedit gif gimp glitz gmedia gnome gnutls gphoto2 gpm gstreamer gtk gtkhtml hal hddtemp hfs html htmlhandbook httpd iconv idn ieee1394 imagemagick imlib inkjar ipv6 isdnlog jack java jfs joystick jpeg kde kdehiddenvisibility kerberos lcms ldap libcaca libnotify lirc live lm_sensors logrotate mad mail matroska mdnsresponder-compat midi mikmod mime mjpeg mmx mmxext mng mono mozilla mp3 mpeg mplayer mudflap multilib musicbrainz mysql nas nautilus ncurses networking new-login nforce2 nls nptl nptlonly nsplugin ntfs nvidia odbc offensive ogg opengl openmp pam parport pcre pdf perl pmu png postgres ppds pppd pulseaudio python qt3 qt3support qt4 quicktime rar rdesktop readline realmedia reflection regex reiser4 reiserfs samba scanner sdl seamonkey semantic-desktop servletapi session skins slang slp smp sndfile snmp sound sounds speex spell spl sqlite sse sse2 ssl startup-notification stream subversion svg swat symlink sysfs syslog tcpd tetex theora thesaurus threads thunderbird tidy tiff timidity tk truetype type1 unicode usb userlocales utempter utils v4l vcd vdr vlm voice vorbis vram weather wmf wmp wordperfect wxwindows xattr xcb xcomposite xforms xfs xine xml xorg xpm xprint xscreensaver xv xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Chris Walters 2008-06-21 16:44:13 UTC
(In reply to comment #0)
This code snippet below is why partimage will not emerge with g++ 4.3.1.  There is no such file as iostream.h in the 4.3.* branch of the gcc suite.  It was included in previous versions of the gcc suite.  This probably should be filed with http://gcc.gnu.org

In file included from net.cpp:22:
net.h:31:22: error: iostream.h: No such file or directory

Comment 2 Chris Walters 2008-06-22 20:31:57 UTC
(In reply to comment #1)
> (In reply to comment #0)
> This code snippet below is why partimage will not emerge with g++ 4.3.1.  There
> is no such file as iostream.h in the 4.3.* branch of the gcc suite.  It was
> included in previous versions of the gcc suite.  This probably should be filed
> with http://gcc.gnu.org
> 
> In file included from net.cpp:22:
> net.h:31:22: error: iostream.h: No such file or directory

I have found that if you have an older copy of gcc on your system, or can emerge one, and copy the 'iostream.h' file from the directory there to the appropriate directory in gcc-4.3.1, partimage will build just fine.  (Just use your favorite find utility to find that file, and make sure to copy it to the same directory structure in gcc-4.3.1 as in the older one).
Comment 3 Billy DeVincentis 2008-06-22 22:04:10 UTC
Partimage is not broken on my system but I think we need to try to fix this so that new users that need to emerge this with gcc 4.3.1 will be able to and I'm not sure that manual additions to the gcc folders are the answer. I think I need to bug the guys at partimage.
Comment 4 Chris Walters 2008-06-23 09:23:10 UTC
(In reply to comment #3)
> Partimage is not broken on my system but I think we need to try to fix this so
> that new users that need to emerge this with gcc 4.3.1 will be able to and I'm
> not sure that manual additions to the gcc folders are the answer. I think I
> need to bug the guys at partimage.

I was thinking more along the lines of a patch to gcc-4.3.1 to add iostream.h to the correct directory, because I am sure other packages use it.  Remember, gcc-4.3.1 and glibc-2.8 are both testing versions, so issues like this are going to arise.  If I wasn't so bust with other things, I might have done a patch myself.
Comment 5 Carsten Lohrke (RETIRED) gentoo-dev 2008-06-24 23:36:40 UTC
*** Bug 229261 has been marked as a duplicate of this bug. ***
Comment 6 Manfred Knick 2008-07-08 07:37:42 UTC
(In reply to comment #1)
> (In reply to comment #0)
> This code snippet below is why partimage will not emerge with g++ 4.3.1.  There
> is no such file as iostream.h in the 4.3.* branch of the gcc suite.  It was
> included in previous versions of the gcc suite.  This probably should be filed
> with http://gcc.gnu.org
> 
> In file included from net.cpp:22:
> net.h:31:22: error: iostream.h: No such file or directory
> 

http://gcc.gnu.org/gcc-4.3/porting_to.html exlicitly recommends:


The table below shows some of the missing items, and the header file that will have to be added as an #include for the compile to succeed.
...
Removal of Pre-ISO headers
Various backwards and deprecated headers have been removed.
If missing 	Then include this header
...
<iostream.h> 	<iostream>
Comment 7 Manfred Knick 2008-07-14 08:24:21 UTC
Christian,

to me, this bug BLOCKS 198121.

This has nothing to do with glibc 2.8.

My Bug 229261 (_without_ wrong hint to glibc) has been closed,
the blocking dependancy has been removed without taking it here.

Please, mark this blocking and adjust the misleading summary 
by deleting the last part "and glibc 2.8" .

Thanks in advance.

Comment 8 Doug Goldstein gentoo-dev 2008-07-14 13:24:02 UTC
iostream is a C++ header. The proper way to use and reference C++ headers is:

#include <iostream>

and not

#include <iostream.h>

Versions of gcc prior to the 4.3 series had the following message when you included iostream.h:

This file includes at least one deprecated or antiquated header. \
Please consider using one of the 32 headers found in section 17.4.1.2 of the \
C++ standard. Examples include substituting the <X> header for the <X.h> \
header for C++ includes, or <iostream> instead of the deprecated header \
<iostream.h>. To disable this warning use -Wno-deprecated.

As of gcc 4.3, they held true.
Comment 9 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-16 13:16:31 UTC
*** Bug 229261 has been marked as a duplicate of this bug. ***
Comment 10 Ryan Hill (RETIRED) gentoo-dev 2008-07-17 02:14:35 UTC
Fixed.