Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 227213 - app-office/kexi-1.6.3 won't emerge with gcc 4.3.1 and glibc 2.8
Summary: app-office/kexi-1.6.3 won't emerge with gcc 4.3.1 and glibc 2.8
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 249336 (view as bug list)
Depends on:
Blocks: glibc-2.8 gcc-4.3-stable
  Show dependency tree
 
Reported: 2008-06-15 15:05 UTC by Billy DeVincentis
Modified: 2009-02-11 15:20 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
kexi-1.6.3-gcc43.patch (kexi-1.6.3-gcc43.patch,280 bytes, patch)
2008-06-21 09:50 UTC, Chris Mayo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Billy DeVincentis 2008-06-15 15:05:31 UTC
There are a couple of problems here. Firstoff is that kexi simply doesn't emerge. The second is that kexi is a blocker for Postgresql 8.3.

Windows2 billydv # equery d libpq
[ Searching for packages depending on libpq... ]
dev-db/postgresql-8.2.7 (~dev-db/libpq-8.2.7)
virtual/postgresql-base-8.2 (=dev-db/libpq-8.2*)
Windows2 billydv # equery d libpqxx
[ Searching for packages depending on libpqxx... ]
app-office/kexi-1.6.3 (postgres? <dev-libs/libpqxx-2.6.9)
Windows2 billydv # equery d kexi
[ Searching for packages depending on kexi... ]
app-office/koffice-meta-1.6.3 (~app-office/kexi-1.6.3)
app-office/kspread-1.6.3 (~app-office/kexi-1.6.3)
Windows2 billydv # equery d kspread
[ Searching for packages depending on kspread... ]
app-office/koffice-meta-1.6.3 (~app-office/kspread-1.6.2)
                              (~app-office/kspread-1.6.3)
app-office/kword-1.6.3-r2 (~app-office/kspread-1.6.2)
                          (~app-office/kspread-1.6.3)






/usr/qt/3/bin/moc ./pqxxconnection.h -o pqxxconnection.moc
/bin/sh ../../../../libtool --silent --tag=CXX --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../../../.. -I./../../.. -I/usr/kde/3.5/include -I/usr/qt/3/include -I.  -I/usr/kde/3.5/include -I/usr/include/postgresql/libpq-4 -I/usr/include -DKEXI_SCRIPTS_SUPPORT -DQT_THREAD_SUPPORT  -D_REENTRANT  -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -march=native -O2 -pipe -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -DHAVE_KNEWSTUFF -fexceptions  -include ../../../../kexi/kexi_global.h -DKEXI_NO_CURSOR_PROPERTY -DKEXI_NO_CTXT_HELP -DKEXI_NO_SUBFORM -DKEXI_DB_COMBOBOX_WIDGET -DDB_TEMPLATES -DKEXI_DEBUG_GUI -DKEXIDB_PGSQL_DRIVER_EXPORT= -D__KEXIDB__= -include ../../../../kexi/kexidb/global.h -c -o pqxxkeywords.lo pqxxkeywords.cpp
/bin/sh ../../../../libtool --silent --tag=CXX --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../../../.. -I./../../.. -I/usr/kde/3.5/include -I/usr/qt/3/include -I.  -I/usr/kde/3.5/include -I/usr/include/postgresql/libpq-4 -I/usr/include -DKEXI_SCRIPTS_SUPPORT -DQT_THREAD_SUPPORT  -D_REENTRANT  -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -march=native -O2 -pipe -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -DHAVE_KNEWSTUFF -fexceptions  -include ../../../../kexi/kexi_global.h -DKEXI_NO_CURSOR_PROPERTY -DKEXI_NO_CTXT_HELP -DKEXI_NO_SUBFORM -DKEXI_DB_COMBOBOX_WIDGET -DDB_TEMPLATES -DKEXI_DEBUG_GUI -DKEXIDB_PGSQL_DRIVER_EXPORT= -D__KEXIDB__= -include ../../../../kexi/kexidb/global.h -c -o pqxxconnection_p.lo pqxxconnection_p.cpp
/bin/sh ../../../../libtool --silent --tag=CXX --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../../../.. -I./../../.. -I/usr/kde/3.5/include -I/usr/qt/3/include -I.  -I/usr/kde/3.5/include -I/usr/include/postgresql/libpq-4 -I/usr/include -DKEXI_SCRIPTS_SUPPORT -DQT_THREAD_SUPPORT  -D_REENTRANT  -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -march=native -O2 -pipe -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -DHAVE_KNEWSTUFF -fexceptions  -include ../../../../kexi/kexi_global.h -DKEXI_NO_CURSOR_PROPERTY -DKEXI_NO_CTXT_HELP -DKEXI_NO_SUBFORM -DKEXI_DB_COMBOBOX_WIDGET -DDB_TEMPLATES -DKEXI_DEBUG_GUI -DKEXIDB_PGSQL_DRIVER_EXPORT= -D__KEXIDB__= -include ../../../../kexi/kexidb/global.h -c -o pqxxpreparedstatement.lo pqxxpreparedstatement.cpp
In file included from pqxxcursor.h:23,
                 from pqxxcursor.cpp:20:
./../../../kexidb/cursor.h:256: warning: 'typedef' was ignored in this declaration
pqxxcursor.cpp: In member function 'virtual void KexiDB::pqxxSqlCursor::drv_getNextRecord()':
pqxxcursor.cpp:158: warning: comparison between signed and unsigned integer expressions
pqxxcursor.cpp:162: warning: comparison between signed and unsigned integer expressions
pqxxcursor.cpp: In member function 'virtual void KexiDB::pqxxSqlCursor::drv_getPrevRecord()':
pqxxcursor.cpp:178: warning: comparison between signed and unsigned integer expressions
pqxxcursor.cpp:182: warning: comparison between signed and unsigned integer expressions
pqxxcursor.cpp: In member function 'virtual const char** KexiDB::pqxxSqlCursor::rowData() const':
pqxxcursor.cpp:262: error: 'malloc' was not declared in this scope
pqxxcursor.cpp:264: warning: comparison between signed and unsigned integer expressions
make[5]: *** [pqxxcursor.lo] Error 1
make[5]: *** Waiting for unfinished jobs....
make[5]: Leaving directory `/var/tmp/portage/app-office/kexi-1.6.3/work/kexi-1.6.3/kexi/kexidb/drivers/pqxx'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/var/tmp/portage/app-office/kexi-1.6.3/work/kexi-1.6.3/kexi/kexidb/drivers'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/app-office/kexi-1.6.3/work/kexi-1.6.3/kexi/kexidb'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-office/kexi-1.6.3/work/kexi-1.6.3/kexi'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-office/kexi-1.6.3/work/kexi-1.6.3'
make: *** [all] Error 2
 *
 * ERROR: app-office/kexi-1.6.3 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 4324:  Called kde-meta_src_compile
 *             environment, line 2975:  Called kde_src_compile
 *             environment, line 3140:  Called kde_src_compile 'all'
 *             environment, line 3260:  Called kde_src_compile 'myconf' 'configure' 'make'
 *             environment, line 3256:  Called die
 * The specific snippet of code:
 *                   emake || die "died running emake, $FUNCNAME:make"
 *  The die message:
 *   died running emake, kde_src_compile:make
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-office/kexi-1.6.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/kexi-1.6.3/temp/environment'.
 *


Reproducible: Always




emerge --info
Portage 2.1.5.5 (default/linux/amd64/2008.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.25-gentoo-r4 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Timestamp of tree: Sun, 15 Jun 2008 05:35:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS=""
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/miscellaneous /usr/portage/local/desktop-effects"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow S3TC X a52 aac aalib accessibility acl acpi alsa amarok amd64 apm arts artworkextra audiofile automount avahi bash-completion berkdb bidi bittorrent bluetooth branding bzip2 cairo calendar cdda cdio cdparanoia cdr clamav cli cpudetection cracklib crypt css cups curl dbus deprecated devil dga directfb discouraged distribution divx doc dri dts dv dvb dvd dvdr dvdread eds elisp emacs emboss emerald encode esd etc-proposals evo examples exif extraicons fam fat fax fbcon fbcondecor fbsplash ffmpeg firefox flac flash foomaticdb fortran fuse gcj gd gdbm gedit gif gimp glitz gmedia gnome gnutls gphoto2 gpm gstreamer gtk gtkhtml hal hddtemp hfs html htmlhandbook httpd iconv idn ieee1394 imagemagick imlib inkjar ipv6 isdnlog jack java jfs joystick jpeg kde kdehiddenvisibility kerberos lcms ldap libcaca libnotify lirc live lm_sensors logrotate mad mail matroska mdnsresponder-compat midi mikmod mime mjpeg mmx mmxext mng mono mozilla mp3 mpeg mplayer mudflap multilib musicbrainz mysql nas nautilus ncurses networking new-login nforce2 nls nptl nptlonly nsplugin ntfs nvidia odbc offensive ogg opengl openmp pam parport pcre pdf perl pmu png postgres ppds pppd pulseaudio python qt3 qt3support qt4 quicktime rar rdesktop readline realmedia reflection regex reiser4 reiserfs samba scanner sdl seamonkey semantic-desktop servletapi session skins slang slp smp sndfile snmp sound sounds speex spell spl sqlite sse sse2 ssl startup-notification stream subversion svg swat symlink sysfs syslog tcpd tetex theora thesaurus threads thunderbird tidy tiff timidity tk truetype type1 unicode usb userlocales utempter utils v4l vcd vdr vlm voice vorbis vram weather wmf wmp wordperfect wxwindows xattr xcb xcomposite xforms xfs xine xml xorg xpm xprint xscreensaver xv xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeroen Roovers gentoo-dev 2008-06-15 22:45:44 UTC
(In reply to comment #0)
> There are a couple of problems here. Firstoff is that kexi simply doesn't
> emerge. The second is that kexi is a blocker for Postgresql 8.3.

Please file one bug report per bug. This bug appears to be about kexi not emerging. Please file another one for the postgresql blocker.
Comment 2 Billy DeVincentis 2008-06-20 01:23:30 UTC
It emerges with kdeenablefinal use flag.
Comment 3 Chris Mayo 2008-06-21 09:50:16 UTC
Created attachment 157877 [details, diff]
kexi-1.6.3-gcc43.patch

Patch that fixes this for me with glibc-2.7-r2 and

USE="-arts -debug -kdeenablefinal -mysql postgres -xinerama"
Comment 4 Juergen Rose 2008-07-26 21:00:29 UTC
How I have to apply this patch?

I tried:
root@grizzly:/usr/bin(13)# cp -a /usr/portage/app-office/kexi/   /usr/local/portage/
root@grizzly:/usr/bin(14)# cd /usr/local/portage/kexi/
root@grizzly:/usr/local/portage/kexi(16)# mkdir files
root@grizzly:/usr/local/portage/kexi(17)# cp /home_condor/rose/kexi-1.6.3-gcc43.patch files/
root@grizzly:/usr/local/portage/kexi(18)# ebuild kexi-1.6.3.ebuild digest
Appending /usr/local to PORTDIR_OVERLAY...
 * 
 * ERROR: portage/kexi-1.6.3 failed.
 * Call stack:
 *               ebuild.sh, line 1704:  Called source '/usr/local/portage/kexi/kexi-1.6.3.ebuild'
 *       kexi-1.6.3.ebuild, line    7:  Called inherit 'kde-meta' 'eutils'
 *               ebuild.sh, line 1218:  Called qa_source '/usr/portage_grizzly/eclass/kde-meta.eclass'
 *               ebuild.sh, line   37:  Called source '/usr/portage_grizzly/eclass/kde-meta.eclass'
 *         kde-meta.eclass, line  103:  Called get-parent-package 'portage/kexi'
 *    kde-functions.eclass, line  339:  Called die
 * The specific snippet of code:
 *      die "Package $1 not found in KDE_DERIVATION_MAP, please report bug"
 *  The die message:
 *   Package portage/kexi not found in KDE_DERIVATION_MAP, please report bug
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * This ebuild is from an overlay: '/usr/local/'


Comment 5 Juergen Rose 2008-07-26 21:05:28 UTC
I just found the missing app-office part of the directory. Doing the 'ebuild kexi-1.6.3.ebuild digest' in /usr/local/portage/app-office/kexi, the comman was succesfull.
Comment 6 Juergen Rose 2008-07-26 22:02:38 UTC
But now emerging kexi-1.6.3 with gcc 4.3.1 works only if I set the kdeenablefinal USE flag as Billy said in comment #2.
Comment 7 Lars Wendler (Polynomial-C) gentoo-dev 2008-11-30 02:54:42 UTC
*** Bug 249336 has been marked as a duplicate of this bug. ***
Comment 8 Lars Wendler (Polynomial-C) gentoo-dev 2008-11-30 02:59:44 UTC
I wonder if this bug should become blocker of bug #225459 and maybe bug #245160 as well.
Comment 9 Lars Wendler (Polynomial-C) gentoo-dev 2008-12-18 16:16:06 UTC
Adding blockers...
Comment 10 David Kredba 2008-12-25 09:00:37 UTC
The same here with gcc-4.3.2 (Gentoo 4.3.2 p1.2, pie-10.1.2), glibc-2.9_p20081201 and dev-libs/libpqxx-2.6.9.

Regards, David.
Comment 11 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-01-29 05:18:47 UTC
Upstream (In reply to comment #3)
> Created an attachment (id=157877) [edit]
> kexi-1.6.3-gcc43.patch
> 
> Patch that fixes this for me with glibc-2.7-r2 and
> 
> USE="-arts -debug -kdeenablefinal -mysql postgres -xinerama"
> 

*ping* trivial patch exists. (Maybe make USE=kdefinalenable non optional?) Thanks.
Comment 12 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-02-06 21:22:12 UTC
(In reply to comment #11)
> Upstream (In reply to comment #3)
> > Created an attachment (id=157877) [edit]
> > kexi-1.6.3-gcc43.patch
> > 
> > Patch that fixes this for me with glibc-2.7-r2 and
> > 
> > USE="-arts -debug -kdeenablefinal -mysql postgres -xinerama"
> > 
> 
> *ping* trivial patch exists. (Maybe make USE=kdefinalenable non optional?)
> Thanks.
> 

kexi will be masked to move on with gcc-4.3 stabilization. PLEASE fix.
Comment 13 Ioannis Aslanidis (RETIRED) gentoo-dev 2009-02-11 09:52:34 UTC
(In reply to comment #11)
> Upstream (In reply to comment #3)
> > Created an attachment (id=157877) [edit]
> > kexi-1.6.3-gcc43.patch
> > 
> > Patch that fixes this for me with glibc-2.7-r2 and
> > 
> > USE="-arts -debug -kdeenablefinal -mysql postgres -xinerama"
> > 
> 
> *ping* trivial patch exists. (Maybe make USE=kdefinalenable non optional?)
> Thanks.
> 
That is an unacceptable solution.
Comment 14 Ioannis Aslanidis (RETIRED) gentoo-dev 2009-02-11 10:17:44 UTC
I advise opening a stabilization request bug in order to get dev-libs/libpqxx-2.6.9 stable and block this bug on that one.
Comment 15 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-02-11 15:20:20 UTC
I tried glibc-2.8_p20080602-r1 which is the stable candidate, gcc-4.3.(1,2,3) and kde-3.5.10 and kexi didn't fail, either enabled or disabled kdeenablefinal useflag. The only problem is the postgres flag that pulls dev-libs/libpqxx-2.6.8, that isn't patched for gcc 4.3. This issue will be fixed as soon as i contact the postgresql team. More info bug 249248
I'm marking this test-requested, please test with kde 3.5.10