Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 227167 - media-video/vdr2jpeg-0.0.12 fails to compile w/ gcc-4.3
Summary: media-video/vdr2jpeg-0.0.12 fails to compile w/ gcc-4.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo VDR Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-06-15 12:55 UTC by Michael Brakemeier
Modified: 2008-06-15 21:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
add missing includes for gcc-4.3. (vdr2jpeg-0.0.12-gcc43.patch,377 bytes, patch)
2008-06-15 12:59 UTC, Michael Brakemeier
Details | Diff
ebuild w/ gcc43 patch (vdr2jpeg-0.0.12.ebuild,781 bytes, text/plain)
2008-06-15 13:00 UTC, Michael Brakemeier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Brakemeier 2008-06-15 12:55:32 UTC
Compilation fails due to missing includes.

g++ -march=pentium-m -mtune=pentium-m -O3 -pipe -fPIC -Wall -Woverloaded-virtual -c -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -D__STDC_CONSTANT_MACROS -I/usr/include/ffmpeg   vdr2jpeg.cpp
vdr2jpeg.cpp: In function 'bool ReadRecordings(const std::string&, const std::string&, const std::vector<std::pair<tFrame, tFrame>, std::allocator<std::pair<tFrame, tFrame> > >&, int, int, bool)':
vdr2jpeg.cpp:461: error: 'memcmp' was not declared in this scope
vdr2jpeg.cpp: In function 'int option(int, char**, char, bool, std::string&, int)':
vdr2jpeg.cpp:631: error: 'strlen' was not declared in this scope
make: *** [vdr2jpeg.o] Error 1




Reproducible: Always

Steps to Reproduce:
1. emerge vdr2jpeg
2.
3.
Comment 1 Michael Brakemeier 2008-06-15 12:59:19 UTC
Created attachment 156881 [details, diff]
add missing includes for gcc-4.3.
Comment 2 Michael Brakemeier 2008-06-15 13:00:46 UTC
Created attachment 156885 [details]
ebuild w/ gcc43 patch
Comment 3 Joerg Bornkessel gentoo-dev 2008-06-15 21:20:59 UTC
fixed,

Thanks Berti :)