Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 227161 - vdr-burn-0.1.0_pre21-r4 fails to compile w/ gcc-4.3
Summary: vdr-burn-0.1.0_pre21-r4 fails to compile w/ gcc-4.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo VDR Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-06-15 12:16 UTC by Michael Brakemeier
Modified: 2008-06-15 20:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
add missing includes for gcc-4.3 (vdr-burn-0.1.0_pre21-gcc43.patch,1.81 KB, patch)
2008-06-15 12:19 UTC, Michael Brakemeier
Details | Diff
ebuild w/ gcc43 patch (vdr-burn-0.1.0_pre21-r4.ebuild,3.41 KB, text/plain)
2008-06-15 12:21 UTC, Michael Brakemeier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Brakemeier 2008-06-15 12:16:01 UTC
Compilation fails due to various missing include files spread over several source files in this ยง(&%$()-project. Patch follows...


Reproducible: Always

Steps to Reproduce:
1.emerge vdr-burn
2.
3.
Comment 1 Michael Brakemeier 2008-06-15 12:19:56 UTC
Created attachment 156871 [details, diff]
add missing includes for gcc-4.3

NOTE: this patch resides in the ../files/0.1.0_pre21/ subdirectory!
Comment 2 Michael Brakemeier 2008-06-15 12:21:11 UTC
Created attachment 156873 [details]
ebuild w/ gcc43 patch
Comment 3 Joerg Bornkessel gentoo-dev 2008-06-15 20:05:43 UTC
added fix to portage

thanks to Berti ;)