Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 227093 - vdr-extrecmenu-1.2_pre1 fails w/ gcc-4.3
Summary: vdr-extrecmenu-1.2_pre1 fails w/ gcc-4.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo VDR Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-06-15 08:59 UTC by Michael Brakemeier
Modified: 2008-06-15 21:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
include langinfo.h patch (vdr-extrecmenu-1.2_pre1-langinfo.patch,371 bytes, patch)
2008-06-15 09:00 UTC, Michael Brakemeier
Details | Diff
ebuild w/langinfo-patch (vdr-extrecmenu-1.2_pre1-r1.ebuild,804 bytes, text/plain)
2008-06-15 09:01 UTC, Michael Brakemeier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Brakemeier 2008-06-15 08:59:19 UTC
Compile vdr-extrecmenu-1.2_pre1 fails due to missing include langinfo.h.

g++ -march=pentium-m -mtune=pentium-m -O3 -pipe -fPIC -c -DCONFDIR=\"/etc/vdr\" -DUSE_CHANNELSCAN -DUSE_CMDSUBMENU -DUSE_DDEPGENTRY -DUSE_DVBSETUP -DUSE_DVLVIDPREFER -DUSE_JUMPPLAY -DUSE_LIEMIKUUTIO -DUSE_OSDMAXITEMS -DUSE_PLUGINMISSING -DUSE_TIMERINFO -DUSE_WAREAGLEICON -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"extrecmenu"' -I/usr/include -I/usr/include tools.c
tools.c: In static member function 'static void Icons::InitCharSet()':
tools.c:694: error: 'CODESET' was not declared in this scope
tools.c:694: error: 'nl_langinfo' was not declared in this scope
make: *** [tools.o] Error 1


Reproducible: Always

Steps to Reproduce:
1. emerge -av vdr-extrecmenu
2.
3.
Comment 1 Michael Brakemeier 2008-06-15 09:00:47 UTC
Created attachment 156829 [details, diff]
include langinfo.h patch
Comment 2 Michael Brakemeier 2008-06-15 09:01:27 UTC
Created attachment 156831 [details]
ebuild w/langinfo-patch
Comment 3 Joerg Bornkessel gentoo-dev 2008-06-15 21:40:55 UTC
fixed

Thanks Berti :)