Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 226721 - dev-util/gtk-doc: patch (gtk-doc-1.10-no-m4.patch) changes both autotools source and result
Summary: dev-util/gtk-doc: patch (gtk-doc-1.10-no-m4.patch) changes both autotools sou...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: bad-autotools
  Show dependency tree
 
Reported: 2008-06-14 16:20 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2010-03-12 11:34 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-06-14 16:20:27 UTC
The patch in summary is touching both Makefile.in and Makefile.am, probably to avoid autotools rebuild.

This treatment is usually reserved for a few selected system packages that cannot have their autotool scripts rebuilt.

This _could_ cause maintainermode-driven rebuild (see http://blog.flameeyes.eu/articles/2008/06/13/maintaner-mode ), which is something we should be avoiding as much as possible.

Please just patch Makefile.am and/or configure.in/.ac and rebuild autotools, unless you have very good reasons not to.
Comment 1 Rémi Cardona gentoo-dev 2008-06-14 16:23:43 UTC
That's done to split the upstream tarball into 2 separate ebuilds : gtk-doc and gtk-doc-am.

This is perfectly justified :) ie, not a bug. Closing
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-06-14 16:33:01 UTC
Err and cannot gtk-doc just patch Makefile.am and rebuild autotools like any other package?
Comment 3 Rémi Cardona gentoo-dev 2008-06-14 17:15:37 UTC
Good point.

Would only changing Makefile.in be enough for you? None of us in the gnome herd are big fans of running eautoreconf when it can be avoided. And in that particular case, it's just a matter of dropping a file from being installed. Trivial and harmless enough, ihmo.
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-06-14 17:20:37 UTC
Check my blog for why you should run eautoreconf.. I'll write something more tomorrow on why _not_ to patch just .in.
Comment 5 Gilles Dartiguelongue gentoo-dev 2008-06-14 17:29:44 UTC
why not simply remove the file at src_install ? No patch, no autoreconf, everyone is happy.
Comment 6 Pacho Ramos gentoo-dev 2010-03-12 11:34:31 UTC
(In reply to comment #5)
> why not simply remove the file at src_install ? No patch, no autoreconf,
> everyone is happy.
> 

Seems to be fixed in that way at least since 1.13:
        # Don't install those files, they are in gtk-doc-am now
        rm "${D}"/usr/share/aclocal/gtk-doc.m4 || die "failed to remove gtk-doc.m4"
        rm "${D}"/usr/bin/gtkdoc-rebase || die "failed to remove gtkdoc-rebase"