Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 226439 - app-text/gv: autotools are being rebuilt through maintainer-mode
Summary: app-text/gv: autotools are being rebuilt through maintainer-mode
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: bad-autotools
  Show dependency tree
 
Reported: 2008-06-13 20:41 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2010-06-12 22:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log for app-text/gv-3.6.4 (app-text:gv-3.6.4:20080621-073035.log,23.06 KB, text/plain)
2008-06-21 07:34 UTC, Samuli Suominen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-06-13 20:41:42 UTC
Rebuilding autotools through maintainer-mode is _not_ good, because it usually means you forget to add dependencies, and they'll magically use the same version as used by upstream, which might not be what the user have installed at all.

If you patch Makefile.am or configure.in/configure.ac you _have to_ use autotools.eclass and eautomake/eautoreconf. Exceptions are granted _only_ for system packages that would make it impossible to run autotools during stagebuilding.

Please fix your package.
Comment 1 Samuli Suominen gentoo-dev 2008-06-21 07:34:25 UTC
Created attachment 157863 [details]
build.log for app-text/gv-3.6.4

Diego, I've bumped app-text/gv to 3.6.4 and changed it to modify only Makefile.am instead of also Makefile.in, then inherited autotools and ran eautoreconf. Why am I still getting..

>>> Completed installing gv-3.6.4 into /var/tmp/portage/app-text/gv-3.6.4/image/

 * QA Notice: Automake "maintainer mode" detected:
 * 
 * 		if (/bin/sh /var/tmp/portage/app-text/gv-3.6.4/work/gv-3.6.4/missing --run makeinfo --version) >/dev/null 2>&1; then \
 * 		if /bin/sh /var/tmp/portage/app-text/gv-3.6.4/work/gv-3.6.4/missing --run makeinfo   -I . \
 * 
 * If you patch Makefile.am, configure.in,  or configure.ac then you
 * should use autotools.eclass and eautomake or eautoreconf. Exceptions
 * are limited to system packages for which it is impossible to run
 * autotools during stage building. See
 * http://www.gentoo.org/proj/en/qa/autofailure.xml for more information.
strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment

?
Comment 2 Samuli Suominen gentoo-dev 2010-06-12 22:05:24 UTC
The problem disappeared with 3.7.1. Please reopen if you can still reproduce.