Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 226315 - media-gfx/iscan: autotools are being rebuilt through maintainer-mode
Summary: media-gfx/iscan: autotools are being rebuilt through maintainer-mode
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Stefan Briesenick (RETIRED)
URL:
Whiteboard:
Keywords:
: 283980 (view as bug list)
Depends on:
Blocks: bad-autotools
  Show dependency tree
 
Reported: 2008-06-13 12:28 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-09-07 11:34 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-06-13 12:28:47 UTC
Rebuilding autotools through maintainer-mode is _not_ good, because it usually means you forget to add dependencies, and they'll magically use the same version as used by upstream, which might not be what the user have installed at all.

If you patch Makefile.am or configure.in/configure.ac you _have to_ use autotools.eclass and eautomake/eautoreconf. Exceptions are granted _only_ for system packages that would make it impossible to run autotools during stagebuilding.

Please fix your package.
Comment 1 Stefan Briesenick (RETIRED) gentoo-dev 2008-06-29 22:43:23 UTC
I use already "eautoconf". That works for me.

But if I change this to "eautoreconf" it fails:

***** aclocal *****
***** aclocal -I m4

/usr/share/aclocal/dynamite.m4:4: warning: underquoted definition of AM_PATH_LIBDYNAMITE
/usr/share/aclocal/dynamite.m4:4:   run info '(automake)Extending aclocal'
/usr/share/aclocal/dynamite.m4:4:   or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
configure.ac:199: error: unknown libltdl build type: _LTDL_TYPE
/usr/share/aclocal/ltdl.m4:242: LTDL_INIT is expanded from...
/usr/share/aclocal/ltdl.m4:368: AC_LIB_LTDL is expanded from...
configure.ac:199: the top level
autom4te-2.62: /usr/bin/m4 failed with exit status: 1
aclocal-1.10: autom4te failed with exit status: 1


any hints?
Comment 2 Peter Alfredsen (RETIRED) gentoo-dev 2008-06-29 22:58:08 UTC
   29 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+  +files/iscan-2.11.0-libltdl.patch, iscan-2.11.0.ebuild:
+  Fix libtool-2.2 breakage and do a full eautoreconf wrt bug #226315.
+
Comment 3 Stefan Briesenick (RETIRED) gentoo-dev 2008-06-30 07:15:14 UTC
well, it's not really fixed. on one machine it compiles fine, on another it fails with:

make[1]: Entering directory `/var/gentoo/portage/media-gfx/iscan-2.11.0/work/iscan-2.11.0'
Making all in include
make[2]: Entering directory `/var/gentoo/portage/media-gfx/iscan-2.11.0/work/iscan-2.11.0/include'
make[2]: Für das Ziel »all« ist nichts zu tun.
make[2]: Leaving directory `/var/gentoo/portage/media-gfx/iscan-2.11.0/work/iscan-2.11.0/include'
Making all in libltdl
make[2]: Entering directory `/var/gentoo/portage/media-gfx/iscan-2.11.0/work/iscan-2.11.0/libltdl'
make[2]: *** Keine Regel vorhanden, um das Target »acinclude.m4«,
  benötigt von »Makefile.in«, zu erstellen.  Schluss.
make[2]: Leaving directory `/var/gentoo/portage/media-gfx/iscan-2.11.0/work/iscan-2.11.0/libltdl'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/var/gentoo/portage/media-gfx/iscan-2.11.0/work/iscan-2.11.0'
make: *** [all] Fehler 2
Comment 4 Stefan Briesenick (RETIRED) gentoo-dev 2008-06-30 07:30:10 UTC
finally fixed.
Comment 5 Samuli Suominen gentoo-dev 2009-09-07 11:34:35 UTC
*** Bug 283980 has been marked as a duplicate of this bug. ***