Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 224895 - Can't find root block device when booting "Gentoo [no framebuffer]"
Summary: Can't find root block device when booting "Gentoo [no framebuffer]"
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: InstallCD (show other bugs)
Hardware: AMD64 Linux
: High normal with 1 vote (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
: 232595 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-04 14:16 UTC by Rodrigo Severo
Modified: 2011-06-19 13:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rodrigo Severo 2008-06-04 14:16:18 UTC
I can't boot 2008.0_beta2 with the "Gentoo [no framebuffer]" kernel on the single machine I tested. I get the following messages and an interrupted boot:

...
>> Determining root device...
!! Could not find the root block device in .
   Please specify another value...

The "Gentoo" kernel option doesn't have this problem.

I'm sure more info is needed. Please tell me what you need so I can provide it, ok?
Comment 1 Rodrigo Severo 2008-06-04 14:27:45 UTC
Some extra info:

The "Determining root device" message appears right after ">> Activating mdev".

It's a i386 machine with a regulat PATA drive.
Comment 2 Robert J. Brown 2008-06-11 01:15:00 UTC
I experienced the same problem on a 2.6GHz Intel dual-core quad-cpu with 4 GB ram and 5 TB SATA disk. It has a new LG Blu Ray drive that interfaces over SATA.  It uses an ASUS motherboard, no add-on boards.  See Gentoo Forums at:

http://forums.gentoo.org/viewtopic-t-695553-highlight-.html?sid=2b76e0839e05a2b0c06d0faf2c348bbb

for more details.
Comment 3 Andrew Gaffney (RETIRED) gentoo-dev 2008-07-12 16:42:52 UTC
Is this still an issue with the 2008.0 final release?
Comment 4 Rodrigo Severo 2008-07-17 14:17:39 UTC
I've just tested. The 2008.0 final release seems to be ok.
Comment 5 Andrew Gaffney (RETIRED) gentoo-dev 2008-07-17 14:23:58 UTC
Thanks for testing.
Comment 6 Rodrigo Severo 2008-07-17 23:27:54 UTC
Sorry for the incomplete info.

The x86 disk is ok but the amd64 still has the problem.
Comment 7 Gregg Casillo 2008-07-21 20:15:36 UTC
Same here with amd64 minimal 2008.0 gentoo-nofb CD.
Comment 8 Rodrigo Severo 2008-07-21 22:03:25 UTC
Just changing the hardware from "All" to "AMD64" to make the issue clearer.
Comment 9 Dawning 2009-03-26 03:17:26 UTC
So I'm seeing this issue on my fresh AMD64 install.

I can't say I'm especially motivated to resolve this. I think my return to gentoo may be experiencing an abrupt end.
Comment 10 sf 2009-07-22 11:22:07 UTC
This problem could be related to http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=8959d300a79c1b70526cdf9e00485262cf8d979f.

Booting with mem=2048M works for me.
Comment 11 Rodrigo Severo 2009-07-22 12:43:22 UTC
AFAIK this boot disk problem is solved as per 23/06/2009 version.
Comment 12 sf 2009-07-22 12:52:20 UTC
Where can one get an up-to-date install-amd64-minimal that is signed (see bug #277319)?
Comment 13 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-12-02 03:41:33 UTC
(In reply to comment #12)
> Where can one get an up-to-date install-amd64-minimal that is signed (see bug
> #277319)?

http://distfiles.gentoo.org/releases/amd64/autobuilds/current-iso/ or through one of the mirrors.

(In reply to comment #11)
> AFAIK this boot disk problem is solved as per 23/06/2009 version.

I'm closing this bug then.
If the issue returns, feel free to reopen the bug.
Comment 14 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-06-19 13:14:10 UTC
*** Bug 232595 has been marked as a duplicate of this bug. ***