Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 224781 - file collisions between www-servers/cherokee-0.7.0 and www-servers/lighttpd-1.4.19-r2
Summary: file collisions between www-servers/cherokee-0.7.0 and www-servers/lighttpd-1...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Quality Assurance Team
URL:
Whiteboard:
Keywords:
: 248486 (view as bug list)
Depends on:
Blocks: 264840
  Show dependency tree
 
Reported: 2008-06-03 16:24 UTC by gapon
Modified: 2009-04-04 07:27 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gapon 2008-06-03 16:24:56 UTC
* package www-servers/cherokee-0.7.0 NOT merged
 *
 * Detected file collision(s):
 *
 *      /var/www/localhost/htdocs/index.html
 *      /usr/bin/spawn-fcgi
 *      /usr/share/man/man1/spawn-fcgi.1.bz2
 *
 * Searching all installed packages for file collisions...
 *
 * Press Ctrl-C to Stop
 *
 * www-servers/lighttpd-1.4.19-r2
 *      /usr/bin/spawn-fcgi
 *      /usr/share/man/man1/spawn-fcgi.1.bz2


Reproducible: Always
Comment 1 Jeroen Roovers gentoo-dev 2008-06-03 16:41:45 UTC
* CC'ing bass for cherokee, www-servers for both.
* Assigning to qa. Tell me if that isn't alright.
Comment 2 Christian Hoffmann (RETIRED) gentoo-dev 2008-06-08 13:59:44 UTC
cherokee ships a patched version of lighty's spawn-fcgi. We could try to make spawn-fcgi an independent package again and patch in the additional features of cherokee based on a USE flag. Or we could introduce a "spawn-fcgi" USE flag for both lighty and cherokee and die in the ebuild if the other web server was installed with USE=spawn-fcgi as well. Any ideas?
Comment 3 Thilo Bangert (RETIRED) (RETIRED) gentoo-dev 2008-06-26 11:04:21 UTC
hoffie: yeah, others have requested such a change as well. lighty's spawn-fcgi is quite popular. also the problems surrounding its startup script could be solved as well.
Comment 4 Thilo Bangert (RETIRED) (RETIRED) gentoo-dev 2008-11-24 19:46:55 UTC
*** Bug 248486 has been marked as a duplicate of this bug. ***
Comment 5 Joost Ruis 2009-02-02 12:58:33 UTC
Same collision on www-servers/cherokee-0.98.1

 * Detected file collision(s):
 *
 *  /usr/share/man/man1/spawn-fcgi.1.bz2
 *  /usr/bin/spawn-fcgi
 *
 * Searching all installed packages for file collisions...
 *
 * Press Ctrl-C to Stop
 *
 * www-servers/lighttpd-1.4.20
 *  /usr/bin/spawn-fcgi
 *  /usr/share/man/man1/spawn-fcgi.1.bz2
 *
 * Package 'www-servers/cherokee-0.98.1' NOT merged due to file
 * collisions. If necessary, refer to your elog messages for the whole
 * content of the above message.
Comment 6 Thilo Bangert (RETIRED) (RETIRED) gentoo-dev 2009-02-02 13:22:23 UTC
does cherokee just use spawn-fcgi from lighttpd, or does it include local changes? if so, the cherokee package should probably install spawn-fcgi as cherokee-spawn-fcgi or similar.

if not, we should create a spawn-fcgi package, which installs spawn-fcgi from lighttpd (or possibly cherokee).

Comment 7 Petteri Räty (RETIRED) gentoo-dev 2009-02-03 12:46:25 UTC
As there has been no proper resolution for now, I added blockers so that users will at least be notified before the build instead after it fails.
Comment 8 Stefan Bühler 2009-03-28 15:53:39 UTC
spawn-fcgi is now a separate project:
http://redmine.lighttpd.net/projects/spawn-fcgi

It has been removed from cherokee already (http://svn.cherokee-project.com/changeset/2870), and it will be probably removed from lighttpd 1.4.23.
Comment 9 Thilo Bangert (RETIRED) (RETIRED) gentoo-dev 2009-04-01 17:17:54 UTC
this is fixed for cherokee-0.99.8
only affected version left is cherokee-0.98.1 (as well as all versions of lighttpd)
Comment 10 Thilo Bangert (RETIRED) (RETIRED) gentoo-dev 2009-04-04 07:22:56 UTC
this is fixed. recent versions of cherokee dont install the spawn-fcgi binary anymore. the only version left still block lighttpd...
the next version of lighttpd will likewise cease to install the spawn-fcgi binary - its progess is being tracked at bug #260174. meanwhile the block is still in effect.

thanks for the reports.