Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 224705 - media-gfx/feh and sci-astronomy/xephem file collision, redux
Summary: media-gfx/feh and sci-astronomy/xephem file collision, redux
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High trivial (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
: 294743 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-03 04:58 UTC by Drake Wyrm
Modified: 2010-03-16 21:26 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
files/feh-1.3.4-cam.patch (feh-1.3.4-cam.patch,796 bytes, patch)
2008-06-03 05:00 UTC, Drake Wyrm
Details | Diff
media-gfx/feh ebuild patch (feh-1.3.4-r1.ebuild.patch,894 bytes, patch)
2008-06-03 05:05 UTC, Drake Wyrm
Details | Diff
sci-astronomy/xephem ebuild patch (xephem-3.7.2.ebuild.patch,193 bytes, patch)
2008-06-03 05:06 UTC, Drake Wyrm
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Drake Wyrm 2008-06-03 04:58:35 UTC
Rather than a mutual block, I offer the attached patches to rename the cam script from feh and eliminate the collision. Also, I made a couple of enhancements to the feh ebuild.
Comment 1 Drake Wyrm 2008-06-03 05:00:43 UTC
Created attachment 155327 [details, diff]
files/feh-1.3.4-cam.patch

Patch the Makefile.am to install the script with a different name, and make a comment in the README
Comment 2 Drake Wyrm 2008-06-03 05:05:10 UTC
Created attachment 155329 [details, diff]
media-gfx/feh ebuild patch

diff from feh-1.3.4.ebuild to feh-1.3.4-r1.ebuild; applies cam patch and renames script; also installs a few more docs
Comment 3 Drake Wyrm 2008-06-03 05:06:40 UTC
Created attachment 155331 [details, diff]
sci-astronomy/xephem ebuild patch

simple patch to adjust blocker
Comment 4 Jesse Adelman 2008-08-05 05:19:41 UTC
Funny, I just e-mailed feh and xephem's respective contact e-mails regarding this filename conflict. Here's what I got from the kind Elwood C. Downey, creator of Xephem:

"Hello all,

XEphem as distributed by my company does not use, create or need in any way a file named /usr/bin/cam. I never heard
of this file before. We have no control how others choose to modify XEphem in their distributions.

Regards,


-- 
Elwood Downey, President/CTO, Clear Sky Institute, Inc.
http://www.clearskyinstitute.com"

However, I looked at the source tarball for Xephem, and it appears that ../xephem-3.7.3/GUI/xephem/tools/indi/cam.c does indeed produce "cam", but reading the README in the same directory and the source file comments indicates that the code contained in cam.c is only *example* code, not really functional. So, it would appear that this is safe to exclude on installation of Xephem.

Hope that helps!
Comment 5 Markus Dittrich (RETIRED) gentoo-dev 2008-08-05 10:31:16 UTC
(In reply to comment #4)
> Funny, I just e-mailed feh and xephem's respective contact e-mails regarding
> this filename conflict. Here's what I got from the kind Elwood C. Downey,
> creator of Xephem:

If upstream says that these pieces are indeed only example code we should
probably refrain from installing them onto people's systems. Does anybody
object if I remove their building and installation from the ebuild? 

Thanks,
Markus
Comment 6 Markus Dittrich (RETIRED) gentoo-dev 2008-08-09 02:34:47 UTC
I've removed the building and installing of the
contents of tools/indi/ from the sci-astronomy/xephem-3.7.3
ebuild and the file collision involving /usr/bin/cam
is hence gone. I've also removed media-gfx/feh as
blocker from the ebuild. 

Since the sci-herd is done with this bug I am 
removing us from the cc list. Thanks to all for the help.

Best,
Markus
Comment 7 Markus Meier gentoo-dev 2008-08-09 12:36:20 UTC
adjusted blocker in media-gfx/feh on !<sci-astronomy/xephem-3.7.3.
Comment 8 Samuli Suominen gentoo-dev 2010-02-22 08:27:20 UTC
*** Bug 294743 has been marked as a duplicate of this bug. ***
Comment 9 Samuli Suominen gentoo-dev 2010-03-16 21:26:56 UTC
And feh since 1.4.1 doesn't install 'cam' anymore, but 'feh-cam' instead. So this is solved in both ends. Stupid generic name.