Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 224563 - x11-themes/mplayer-skins removal request (was: outdated skins crash gmplayer)
Summary: x11-themes/mplayer-skins removal request (was: outdated skins crash gmplayer)
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-02 02:00 UTC by jtholl
Modified: 2009-10-07 16:09 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jtholl 2008-06-02 02:00:57 UTC
Various skins within the x11-themes/mplayer-skins package cause it to crash.
Currently using:
[I--] [  ] media-video/gnome-mplayer-0.6.0 (0)
[I--] [  ] media-video/mplayer-1.0_rc2_p26753-r1 (0)
[I--] [  ] x11-themes/mplayer-skins-0.2-r5 (0)

Reproducible: Always

Steps to Reproduce:
1.Open Mplayer
2.Right click, skin browser
3.Choose a skin like Terminator3

Actual Results:  
Crash!

Expected Results:  
Change the skin.
Comment 1 manuels 2008-06-03 21:08:28 UTC
please post emerge --info
Comment 2 Samuli Suominen gentoo-dev 2009-08-03 18:41:37 UTC
+  03 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> package.mask:
+  Mask mplayer-skins for removal since gmplayer is deprecated and these are
+  causing problems wrt #224563.
Comment 3 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-09-04 01:47:08 UTC
removed
Comment 4 heman 2009-09-08 13:26:13 UTC
This bug report is incorrect, and the fix is stupid.
 
  gnome-mplayer != gmplayer.

The Terminator3 skin works fine with gmplayer or mplayer -gui.

This is just a typical gnome user thinking they are the world.

Even if the theme was at fault, the correct fix would be at worst to remove that one theme from the pack.

However, the theme is not likely to be at fault. The application loading it is at fault. 

Whether the user used mplayer -gui, or gnome-mplayer, the crash likely represents a bug in the application not the skin.

People all round the world now have to see messages from emerge about masked mplayer skins packages just because this idiot gnome user installs a gnome application to be different, and then blames the original non-gnome application (or theme in this case) for the problem. 

Whether or not gmplayer is deprecated does not matter in this case, as the skins pack works for mplayer also (with the '-gui' flag) not just gmplayer.

This bug is a year old, is invalid anyway (gnome-mplayer vs gmplayer) and the user did not provide the requested information. The bug should have been closed as WONTFIX, not used as an excuse to remove a valid useful package.



Comment 5 Samuli Suominen gentoo-dev 2009-09-08 13:40:58 UTC
(In reply to comment #4)
> This bug report is incorrect, and the fix is stupid.
>   gnome-mplayer != gmplayer.

The gnome-mplayer listed in Comment #0 has nothing to do with this bug.

> The Terminator3 skin works fine with gmplayer or mplayer -gui.
> user did not provide the requested information. The bug should have been closed
> as WONTFIX, not used as an excuse to remove a valid useful package.

...

gmplayer in mplayer is deprecated (by upstream) and it is likely we remove the USE gmplayer entirely in near future
Comment 6 No Name 2009-10-05 16:12:49 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > This bug report is incorrect, and the fix is stupid.
> >   gnome-mplayer != gmplayer.
> 
> The gnome-mplayer listed in Comment #0 has nothing to do with this bug.
> 
> > The Terminator3 skin works fine with gmplayer or mplayer -gui.
> > user did not provide the requested information. The bug should have been closed
> > as WONTFIX, not used as an excuse to remove a valid useful package.
> 
> ...
> 
> gmplayer in mplayer is deprecated (by upstream) and it is likely we remove the
> USE gmplayer entirely in near future
> 

Whats going on now??? It is obvious that the bug reporter is a "stupid" gnome user -.- I think he doesnt even no know the difference between the gui application "gnome-mplayer" and the original mplayer (the terminal application)!

I agree with comment #4 because the mplayer-skins are NOT for other applications such as "gnome-mplayer" oder kde-mplayer or alle these noob applications...

@package maintainer
What do you think is wrong about mplayer-skins just because one single person had problem with this package and this person has never replied??

By the Way:
By me, gmplayer is rockstable!! No other video-player gui use so less ressources!!! it is very fine for users with old computers like fluxbox desktops! and only because this stupid bug reporter who has posted this WRONG bug for more than one year ago!

please add the package back to portage or a lot of people will be angry of you and primary of this... i say it again... STUPID!! bug reporter!!

you shouldnt care about if a package is deprecated or not as long as it works 100% fine!
Comment 7 jtholl 2009-10-05 23:44:12 UTC
The both of you are asshats, this bug is well over a year old now, and I've switched to a new distro anyway.  The both of you are arrogant and irritating, nowhere did I say I was the "world" or did I know for sure exactly what or how I was reporting it, I was a 'noob' then, and I have no problems admitting that, HOWEVER, being complete assholes about it is not the way to go about chastising a 1YR+ OLD BUG.  I had a problem, I didn't see anything on google about how to keep the GUI from crashing with those skins, so I tried to be useful and post what I had at the time, see if there were any fixes, however shortly after I posted it I decided I wasn't able enough to use gentoo, and went back to windows.  Regardless, screaming and moaning "STUPID BUG REPORTER" "This is just a typical gnome user thinking they are the world.", stuff like that isn't necessary, I had a problem, nobody reported it, so I figured I'd post it and see if someone could figure out what was wrong with it.  The application had the mplayer-skins listed in it, my assumption was I should be able to use them without issue.  So grow up, chill out, and stop being a self-righteous linux user.
Comment 8 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-10-06 00:14:52 UTC
I'm commenting here as a User Relations member.

@users:
Using Gentoo's Bugzilla to call names to other users and to make mean spirited and judgemental comments such as "This is just a typical gnome user thinking they are the world" is not acceptable behaviour.
Please read *very* carefully Gentoo's Code of Conduct[1]. If you continue with this attitude and behaviour, we'll have to give you a vacation from Bugzilla so that you can understand that using Gentoo's communication mediums is a privilege and not a right and that everyone needs to behave.

 [1] - http://www.gentoo.org/proj/en/council/coc.xml
Comment 9 Malisha 2009-10-06 20:49:32 UTC
I'm of the opinion that mplayer really was and is the best media-player, this is why I want the package added back to portage. 
We are not angry with the bug reporter himself and we don't want to insult him because he was a noob. I'm the last person who would insult noobs because I was one of them too.
The problem is just that he reported the bug and as a result the package was removed from portage. He changed to another distro (for example Ubuntu), where he can install and use mplayer. However, because of his report, we can't use mplayer anymore, we have the disadvantage.
Anyway, this is not a bugfix and the package only contains graphics, nothing else. 
All in all, we want to have our package back and every person, who wants to have it back too, should speak up so that mplayer will be a package in portage again.
Comment 10 jtholl 2009-10-07 10:25:53 UTC
Personally I find the usage of the term 'noob' offensive, aswell as suggesting I must be such a noob I have to use ubuntu (gag), I switched to fedora, thanks.
Overall the simple removal of the package from portage is not stopping you from getting and using mplayer, www.mplayerhq.hu aswell as many other places carry the latest builds and source.
Comment 11 Samuli Suominen gentoo-dev 2009-10-07 10:29:31 UTC
mplayer is well maintained and in portage with it's preferred gui, smplayer,
also promoted by upstream.

i guess we could fasttrack the USE gmplayer's removal...
Comment 12 Malisha 2009-10-07 16:09:47 UTC
What's your problem now? I thought that Gentoo was the distro where the users had the most freedom, where THEY could choose what they want or don't want to have in their system.
If you don't want gmplayer and its skins, don't install them, but please don't take away the chance to get gmplayer and its skins from portage for the thousands of people who want to use it. 
If you don't want the USE gmplayer, don't set it, it's as simple as that. 
Concerning smplayer, I'm of the opinion that it isn't stylish, it's just as any other media-player. And because it uses qt4, it's overloaded. Well, this is another topic. Gmplayer is the most stylish and slightest media-player.
Sorry Justin Tholl, I don't want to offend you and Ubuntu was just an example.
I will never install smplayer, no matter how many people like qt4. I think everybody has other preferences and I like gmplayer and its skins, so don't steal my chance that I can install it simply from portage. 
The best way for you would be to wait until the developers of mplayer remove gmplayer from their source code. And even there all has not been said and done.