Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 223887 - alsa-lib 1.0.16+ dmix not functioning
Summary: alsa-lib 1.0.16+ dmix not functioning
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo ALSA team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-27 19:48 UTC by Chris Henhawke (RETIRED)
Modified: 2010-01-15 01:45 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Henhawke (RETIRED) gentoo-dev 2008-05-27 19:48:26 UTC
Installing alsa-lib versions 1.0.16 and higher result in a loss of dmix functionality, regardless of having the dmix ALSA_PCM_PLUGINS setting enabled.

Reproducible: Didn't try

Steps to Reproduce:
1. Upgrade alsa to 1.0.16 or higher
2. Open your favourite music/video player that uses dmix and start playing something
3. Open firefox and try to watch a youtube video

Actual Results:  
ALSA lib pcm_dmix.c:996:(snd_pcm_dmix_open) unable to open slave 

Expected Results:  
Being able to listen to multiple sounds at once

Downgrading alsa back to pre 1.0.16 restores dmix functionality
Comment 1 Tony Vroon gentoo-dev 2008-05-27 20:19:19 UTC
emerge --info please...
Comment 2 Chris Henhawke (RETIRED) gentoo-dev 2008-05-27 20:24:27 UTC
Portage 2.1.4.4 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.18-gentoo-r6 i686)
=================================================================
System uname: 2.6.18-gentoo-r6 i686 Intel(R) Pentium(R) M processor 2.00GHz
Timestamp of tree: Tue, 27 May 2008 04:18:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r9
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium-m -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distcc distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo/"
LANG="en_US.UTF-8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync/gentoo-portage/"
USE="X a52 acl acpi aim alsa arts artswrappersuid berkdb bluetooth bzip2 cdparanoia cli connectionstatus cpudetection cracklib crypt css cups dbus divx dri drm dts dvd dvdr dvdread encode fat ffmpeg firefox flac fortran gdbm gif gimpprint gpm gtk hddtemp history iconv ieee1394 imagemagick ipod isdnlog jack java jpeg jpeg2k kde libcaca mad midi mikmod mmx mmxext mng mozbranding mozdevelop mp3 mpeg mplayer msn mudflap musicbrainz ncurses netmeeting nls nowlistening nptl nptlonly nsplugin ntfs offensive ogg opengl openmp oss pam pcre perl png pppd python qt qt3 qt4 readline reflection rtc sdl session sms speex spl sse sse2 ssl tiff truetype unicode usb v4l v4l2 vcd vorbis wifi win32codecs wmp x86 xml xorg xscreensaver xv xvid zeroconf zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 3 Chris Henhawke (RETIRED) gentoo-dev 2008-05-27 20:55:08 UTC
requested by beandog - more info:

kernel 2.6.18-gentoo-r6
sound card is Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)

'driver' is intel8x0, done by kernel (as module, but the rest of alsa is builtin)
Comment 4 Tony Vroon gentoo-dev 2008-05-27 22:00:09 UTC
Kernel is *ancient*. Upgrade to latest stable gentoo-sources at the very, very least. I can't support this configuration.
Comment 5 Chris Henhawke (RETIRED) gentoo-dev 2008-05-27 23:02:54 UTC
I'm not the only person with this problem, I've seen at least 5 threads on the forums with the same issue.

https://forums.gentoo.org/viewtopic-t-693381-highlight-alsalib.html
https://forums.gentoo.org/viewtopic-t-693689-highlight-alsalib.html
https://forums.gentoo.org/viewtopic-t-694138-highlight-alsalib.html

I can't seem to find any more at the moment.  Search seems to be eluding me.
Comment 6 Tony Vroon gentoo-dev 2008-05-27 23:17:39 UTC
(In reply to comment #5)
> https://forums.gentoo.org/viewtopic-t-693381-highlight-alsalib.html

Ancient kernel.

> https://forums.gentoo.org/viewtopic-t-693689-highlight-alsalib.html

Insufficient information. Would have been closed if it were a bug report.

> https://forums.gentoo.org/viewtopic-t-694138-highlight-alsalib.html

Ancient kernel.
 
> I can't seem to find any more at the moment.  Search seems to be eluding me.

Upgrade your kernel. 

Comment 7 Nick Currier 2009-06-02 02:04:00 UTC
This seems to be a valid bug... Just ran into this when attempting to use ardour2.  Stable amd64 2.6.27-r8 kernel... help.
Comment 8 Jacob Martin 2009-10-28 03:54:12 UTC
Same exact error here.  Looks like an "ancient kernel" isn't the cause since I have 2.6.31-gentoo


Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.9_p20081201-r2, 2.6.31-gentoo x86_64)
=================================================================
System uname: Linux-2.6.31-gentoo-x86_64-Dual_Core_AMD_Opteron-tm-_Processor_275-with-gentoo-1.12.11.1
Timestamp of tree: Fri, 23 Oct 2009 01:30:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p28
dev-java/java-config: 1.3.7-r1, 2.1.8-r1
dev-lang/python:     2.4.6, 2.5.4-r2, 2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4-r2
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.16.1-r3, 2.17-r1, 2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=opteron -mtune=opteron -O2 -pipe -msse -msse2 -funit-at-a-time -fomit-frame-pointer -frename-registers -fweb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib64/mozilla/defaults/pref /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=opteron -mtune=opteron -O2 -pipe -msse -msse2 -funit-at-a-time -fomit-frame-pointer -frename-registers -fweb"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X Xaw3d a52 aac acl acpi alsa amd amd64 apache2 arts audiofile berkdb binfilter bl blas boost branding bzip2 cairo cdb cdda cddb cli cpudetection cracklib crypt cups curl custom-optimization dbus designer-plugin dia directfb disk-partition dri dv dvb dvd dvdnav dvdr dvdread encode fam firefox flac fortran gd gdbm gif gimpprint glitz gpm graphviz gstreamer gtkhtml hou htmlhandbook iconv inkjar ipv6 isdnlog ithreads java jbig jpeg jpeg2k kde kpathsea lapack latex lcms libsamplerate lm_sensors lzo mad math mjpeg mmx mmxext mng modplug modules moonlight mozcalendar mozilla mozsvg mp2 mp3 mp4 mp4live mpeg mpeg2 mpi mplayer mudflap multilib multislot musepack mysql mysqli nas ncurses network nls nptl nptlonly nsplugin octave openexr opengl openmp pam paste64 pcre pdf perl php plasma plotutils png postscript ppds pppd python qt3 qt3support qt4 readline redland reflection restrict-javascript samba sensord session slp smp socks5 sou spell spl sql sse sse2 ssl svg sysfs tcpd tetex theora threads tiff tivo tk toolbar tools truetype tta udev unicode utempter v4l vorbis wavpack webdav webkit wma wmf x264 xanim xcomposite xine xinerama xorg xvid zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 9 Dawan 2010-01-15 00:42:06 UTC
Same bug here with both gentoo-sources 2.6.31-r6 and 2.6.31-r9, with CONFIG_SND_HDA_INTEL, CONFIG_SND_HDA_CODEC_VIA and CONFIG_SND_HDA_CODEC_ATIHDMI set (vt1708 chip) ; I will check tomorrow with 2.6.32-r1. 

Out of a hundred tests, my two instances of mplayer managed to play together once, all the other times the second one ended with the same old "pcm_dmix.c:****:(snd_pcm_dmix_open) unable to open slave", so it is kind of a "random bug"... I'm sure the problem is in dmix, no other programm ever tried to access to the sound devices during my tests, and the configuration files were taken from a working computer, and checked and re-checked.

I don't know if the problem comes from an unsupported sound card, if it is specific to gentoo, neither do I understand why so few people have this problem, but I'm pretty sure the bug is valid.
Comment 10 Daniel Cater 2010-01-15 01:45:20 UTC
I still get this with 2.6.31-gentoo-r6 and with drivers built-in or as modules.

alsa-lib 1.0.20-r1
alsa-headers 1.0.20
alsa-utils 1.0.20-r5
gst-plugins-alsa 0.10.24
adobe-flash 10.0.42.34 (since somewhere mentions this as a possible problem)

lspci -vv gives:

01:06.0 Multimedia audio controller: Creative Labs CA0106 Soundblaster
	Subsystem: Creative Labs SB0570 [SB Audigy SE]
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64 (500ns min, 5000ns max)
	Interrupt: pin A routed to IRQ 18
	Region 0: I/O ports at df20 [size=32]
	Capabilities: [dc] Power Management version 2
		Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Kernel driver in use: CA0106

This bug should be reopened, as it was closed due to not being reported with a modern kernel, and now it has been, more than once.

No /etc/asound.conf or ~/.asoundrc

$ euse --info alsa arts esd jack oss pulseaudio 
global use flags (searching: alsa arts esd jack oss pulseaudio)
************************************************************
[+  D ] alsa - Adds support for media-libs/alsa-lib (Advanced Linux Sound Architecture)
[-    ] arts - Adds support for aRts: the KDE sound daemon
[-    ] esd - Adds support for media-sound/esound (Enlightened Sound Daemon)
[-    ] jack - Adds support for the JACK Audio Connection Kit
[-    ] oss - Adds support for OSS (Open Sound System)
[-    ] pulseaudio - Adds support for PulseAudio sound server