Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 223447 - packages depcleaned just after world emerge
Summary: packages depcleaned just after world emerge
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
Depends on:
Blocks: 216231
  Show dependency tree
Reported: 2008-05-24 14:07 UTC by Imre Péntek
Modified: 2008-06-07 16:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

emerge --info (emergeinfo.txt,3.52 KB, text/plain)
2008-05-24 14:19 UTC, Imre Péntek
emerge --update --deep --newuse --verbose --ask --debug world 2>&1|tee worldemergedebug.txt (worldemergedebug.txt,1.15 MB, text/plain)
2008-05-24 19:12 UTC, Imre Péntek
emerge --depclean --debug 2>&1|tee depcleandebug.txt (depcleandebug.txt,1.07 MB, text/plain)
2008-05-24 19:13 UTC, Imre Péntek
maybe just my fault, but got the same result now, after an emerge --sync (worldemergedebug2.txt,1.18 MB, text/plain)
2008-06-07 00:52 UTC, Imre Péntek
depclean as second step (depcleandebug2.txt,1.05 MB, text/plain)
2008-06-07 00:54 UTC, Imre Péntek
usual emerge --info and such (emergeinfo2.txt,4.64 KB, text/plain)
2008-06-07 00:54 UTC, Imre Péntek

Note You need to log in before you can comment on or make changes to this bug.
Description Imre Péntek 2008-05-24 14:07:38 UTC
boborjan ~ # emerge --update --deep --newuse --verbose --ask world

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild  N    ] dev-python/pycrypto-2.0.1-r6  USE="-bindist -gmp -test" 0 kB 
[ebuild  N    ] dev-python/pysqlite-2.3.5  USE="-examples" 0 kB 

Total: 2 packages (2 new), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] 

but after answerring yes, emerge --depclean select both to be removed.

Reproducible: Always
Comment 1 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2008-05-24 14:14:50 UTC
Post the output of:
emerge --info
Comment 2 Imre Péntek 2008-05-24 14:19:46 UTC
Created attachment 154133 [details]
emerge --info
Comment 3 Zac Medico gentoo-dev 2008-05-24 18:06:47 UTC
Please attach --debug output for both the installation command and the uninstallation (--depclean) command.
Comment 4 Imre Péntek 2008-05-24 19:12:18 UTC
Created attachment 154179 [details]
emerge --update --deep --newuse --verbose --ask --debug world 2>&1|tee worldemergedebug.txt
Comment 5 Imre Péntek 2008-05-24 19:13:56 UTC
Created attachment 154181 [details]
emerge --depclean --debug 2>&1|tee depcleandebug.txt
Comment 6 Zac Medico gentoo-dev 2008-05-24 22:32:04 UTC
This seems to be sort of an instance of bug 1343. As a workaround, you can mask those packages to prevent them from being selected:

echo "dev-python/pycrypto
dev-python/pysqlite" >> /etc/portage/package.mask
Comment 7 Zac Medico gentoo-dev 2008-05-24 22:37:30 UTC
I don't yet understand why it's making the wrong decision in these cases:

|| ( >=dev-lang/python-2.5 >=dev-python/pysqlite-2 )
|| ( >=dev-lang/python-2.5 >=dev-python/pycrypto-2.0.1-r6 )

Perhaps the installed version of python is masked somehow?

cat /var/db/pkg/dev-lang/python-2.5*/KEYWORDS
Comment 8 Imre Péntek 2008-05-25 12:00:28 UTC
imi@boborjan ~ $ cat /var/db/pkg/dev-lang/python-2.5*/KEYWORDS
~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd
imi@boborjan ~ $ 
Comment 9 Zac Medico gentoo-dev 2008-05-25 19:25:28 UTC
Does `emerge -p \>=dev-lang/python-2.5` pull in the python-2.5 package as expected? Have you keyworded that package in /etc/portage/package.keywords? If not, does keywording it help?
Comment 10 Imre Péntek 2008-05-25 20:10:37 UTC
At current state
All ebuilds that could satisfy ">=dev-lang/python-2.5" have been masked.

boborjan ~ # eix -i python
[D] dev-lang/python
     Available versions:  
        (2.3)   2.3.5-r2 2.3.5-r3 ~2.3.6 2.3.6-r3 2.3.6-r4 ~2.3.6-r5
        (2.4)   2.4.4-r5 2.4.4-r6 2.4.4-r9 ~2.4.4-r10 ~2.4.4-r11
        (2.5)   ~2.5.2-r1 ~2.5.2-r2
        {+cxx +threads berkdb bootstrap build doc elibc_uclibc examples gdbm ipv6 ncurses nocxx nothreads readline sqlite ssl tk ucs2 wininst}
     Installed versions:  2.4.4-r9(2.4)(18.31.55 2008-04-29)(berkdb gdbm ipv6 ncurses readline ssl -bootstrap -build -doc -elibc_uclibc -examples -nocxx -nothreads -tk -ucs2)
                          2.5.1-r5(2.5)(15.04.09 2008-02-15)(berkdb gdbm ipv6 ncurses readline sqlite ssl -bootstrap -build -doc -elibc_uclibc -examples -nothreads -tk -ucs2)
     Description:         Python is an interpreted, interactive, object-oriented programming language.

I had:
imi@boborjan ~ $ grep python /etc/portage/package.keywords 
=dev-lang/python-2.5.1-r5 ~amd64

Well maybe when some of my apps needed python-2.5 I supposed there will be an unmasked python soonly. It was long time ago...

now modifying to:
dev-lang/python ~amd64

boborjan ~ # emerge -p \>=dev-lang/python-2.5

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] dev-lang/python-2.5.2-r4 [2.5.1-r5] USE="threads%* -wininst%" 
boborjan ~ # 
Comment 11 Zac Medico gentoo-dev 2008-05-27 23:31:37 UTC
You seem to have triggered the same type of case described in bug #219369, Comment #16. If emerge shows a warning about python-2.5 being masked then that should help you know how to correct the problem.
Comment 12 Imre Péntek 2008-05-28 08:50:57 UTC
(In reply to comment #11)
During normal operation, there were no warning. When it really happened to warn me about masked package, I was able to handle the case afaik.
Comment 13 Zac Medico gentoo-dev 2008-06-01 10:43:25 UTC
It's fixed so that the update command will warn you about python-2.5 being masked.
Comment 14 Imre Péntek 2008-06-01 10:46:55 UTC
(In reply to comment #13)
Ok. Thanks.
Comment 15 Imre Péntek 2008-06-07 00:52:42 UTC
Created attachment 155771 [details]
maybe just my fault, but got the same result now, after an emerge --sync
Comment 16 Imre Péntek 2008-06-07 00:54:29 UTC
Created attachment 155773 [details]
depclean as second step
Comment 17 Imre Péntek 2008-06-07 00:54:55 UTC
Created attachment 155775 [details]
usual emerge --info and such
Comment 18 Zac Medico gentoo-dev 2008-06-07 06:48:55 UTC
(In reply to comment #17)
> Created an attachment (id=155775) [edit]
> usual emerge --info and such

Your --info shows version, but you need at least to get the new warning message.
Comment 19 Imre Péntek 2008-06-07 16:38:29 UTC
okay, when using sys-apps/portage- depclean unmerges dev-python/pycrypto and dev-python/pysqlite, but world emerge does not emerge any of them, so it seems to be consistent. Thanks for supporting my bug.