Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 222373 - request for syslog support in www-servers/nginx
Summary: request for syslog support in www-servers/nginx
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Konstantin Arkhipov (RETIRED)
URL: http://thread.gmane.org/gmane.comp.we...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-16 10:27 UTC by marlon
Modified: 2010-02-19 02:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
nginx syslog support (nginx_syslog.patch,7.25 KB, patch)
2008-05-16 10:27 UTC, marlon
Details | Diff
made use of LOG_CRIT + LOG_NOTICE (nginx_syslog.patch,7.25 KB, patch)
2008-05-16 11:03 UTC, marlon
Details | Diff
used format function for syslog() to allow %s, %d, etc in the string (nginx_syslog.patch,7.26 KB, patch)
2008-05-16 14:59 UTC, marlon
Details | Diff
add syslog support to ebuild (nginx-0.8.4.ebuild-syslog.patch,950 bytes, patch)
2009-07-08 10:32 UTC, Ben Taitelbaum
Details | Diff
syslog patch for nginx 0.8.4 (nginx-0.8.4-syslog.patch,6.53 KB, patch)
2009-07-08 13:02 UTC, Ben Taitelbaum
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description marlon 2008-05-16 10:27:03 UTC
I've written a patch which allows the use of syslog in nginx.See http://article.gmane.org/gmane.comp.web.nginx.english/5057

Reproducible: Always
Comment 1 marlon 2008-05-16 10:27:43 UTC
Created attachment 153307 [details, diff]
nginx syslog support
Comment 2 marlon 2008-05-16 11:03:43 UTC
Created attachment 153311 [details, diff]
made use of LOG_CRIT + LOG_NOTICE

new patch with different log facilities, instead of logging everything to LOG_CRIT
Comment 3 marlon 2008-05-16 14:59:10 UTC
Created attachment 153345 [details, diff]
used format function for syslog() to allow %s, %d, etc in the string
Comment 4 Fabian Groffen gentoo-dev 2008-09-25 11:54:35 UTC
would be cool if Igor could at least make a response there :/
Comment 5 Vasiliy Tolstov 2009-03-03 13:15:39 UTC
(In reply to comment #4)
> would be cool if Igor could at least make a response there :/
> 

Author of Nginx (Igor) does not like logging to syslog in nginx - see mail archive
Comment 6 Ben Taitelbaum 2009-07-07 16:49:20 UTC
I'm trying to write an ebuild that includes this patch with the syslog USE flag, but the patch isn't fully working (about half of the hunks fail) with nginx 0.8.4

Any chance there's an updated patch?
Comment 7 Ben Taitelbaum 2009-07-08 10:32:17 UTC
Created attachment 197160 [details, diff]
add syslog support to ebuild

This patch adds the syslog nginx patch and compiles nginx with syslog support when the syslog USE flag is present.
Comment 8 marlon 2009-07-08 10:35:55 UTC
I'll take a look to make it working against the latest 0.7 and 0.8 branch
Comment 9 Ben Taitelbaum 2009-07-08 13:02:26 UTC
Created attachment 197180 [details, diff]
syslog patch for nginx 0.8.4

I updated the patch to work with nginx-0.8.4

I've tested this with the ebuild patch attached to this ticket, and it works with my nginx configs, but the patch might be messy (when I tried compiling by hand, it had some warnings), so if someone could check it out, that'd be great.
Comment 10 Johan Bergström 2009-07-21 13:09:02 UTC
I'm a bit biased toward third party patching in Nginx. For instance - if this goes through, do we also accept mod_wsgi patches or perhaps passenger? This small and easy to use web server can easily grow into something more complex.
Comment 11 Dirkjan Ochtman gentoo-dev 2010-01-03 21:01:20 UTC
At this time I don't want to increase the maintenance load by pulling in more stuff from outside the distribution, so closing as WONTFIX.
Comment 12 Ed Wildgoose 2010-02-18 01:28:38 UTC
Dirkjan, Can we give some thought to some way to compromise on this a bit and perhaps look at how some extensions could be handled/maintained, even if some bits of that solution remain outside the gentoo tree?

I guess you are either an nginx fan or not, but those who are find it an incredibly versatile little tool. It's "weakness" is this requirement to build all extensions at build time

I don't have a problem with the extensions living outside of portage, but it would be useful to be able to inject these patches/modules into the normal ebuild without needing to maintain a local customised ebuild everywhere

Thoughts on how appreciated...
Comment 13 Dirkjan Ochtman gentoo-dev 2010-02-19 02:02:05 UTC
I appreciate the need for it (in fact, at some point I had an ebuild in my overlay that just added one external module), I'm just not using nginx myself at this point. I just picked it up because it wasn't being maintained, and while bumping it and adding use flags here and there seems straightforward enough, I simply don't have the time to do all kinds of other stuff. I could maybe maintain it as a proxy if there was someone committed who had a clear path forward that started by fixing out all the existing bugs, modularized the current ebuild, and *then* added some external modules...