Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 222357 - [science overlay] sci-chemistry/modeller
Summary: [science overlay] sci-chemistry/modeller
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: Normal enhancement (vote)
Assignee: Default Assignee for New Packages
Whiteboard: Science overlay
Keywords: EBUILD, InOverlay
Depends on:
Reported: 2008-05-16 09:27 UTC by Justin Lecher (RETIRED)
Modified: 2011-06-20 06:18 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

modeller-9.4.diff (modeller-9.4.diff,6.20 KB, text/plain)
2008-05-16 09:30 UTC, Justin Lecher (RETIRED)
modeller-9.4.diff (modeller-9.4.diff,6.34 KB, text/plain)
2008-05-16 11:32 UTC, Justin Lecher (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Lecher (RETIRED) gentoo-dev 2008-05-16 09:27:15 UTC
Version bump to 9.4.
The provided diff is adapted to the new version and includes the updates proposed in bug #127628.
Tested on x86 where it runs fine.
Comment 1 Justin Lecher (RETIRED) gentoo-dev 2008-05-16 09:30:41 UTC
Created attachment 153301 [details]

Sorry, the ebuild for modeller is still in the science overlay, so I should report it to them. Nevertheless here is the diff towards the new version.
Comment 2 Justin Lecher (RETIRED) gentoo-dev 2008-05-16 11:32:54 UTC
Created attachment 153315 [details]

Added python USE Flag,
this is needed if one wants to import python modules, because modeller needs them from version 2.3.
Comment 3 Donnie Berkholz (RETIRED) gentoo-dev 2008-05-16 17:51:34 UTC
Gotta find something to do about python 2.3, it's getting masked.
Comment 4 Justin Lecher (RETIRED) gentoo-dev 2008-05-16 18:05:01 UTC
Thats an upstream thing. Modeller runs fine as long you don't want do use modules from python.

The mod9v4 script uses a built-in copy of the Python 2.3 interpreter, but not the accompanying modules. To fix this problem, you could install Python 2.3 on your system (however, you only need the Python 2.3 modules if you are trying to import non-Modeller modules; you don't need them to run regular Modeller scripts, so you can ignore these warnings). Alternatively, don't use the mod9v4 script to run Modeller, but see the instructions above for running Modeller with Python.

There is a workaround as mentioned (If you have Python 2.3 or 2.4 installed, then "/opt/mod/bin/ python" will run Python on the same script.). How should this be included in the ebuild? Just a ewarn?
Comment 5 Mathias Weigt 2008-10-22 05:33:00 UTC
Version 9v5 is out
See the Modeller manual for a full change log:
Comment 6 Justin Lecher (RETIRED) gentoo-dev 2010-06-16 11:47:01 UTC
I bumped the version in the overlay.