Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 221817 - >=gnome-extra/sensors-applet-2.2.1 needs to filter LDFLAG --as-needed when USE=nvidia is used
Summary: >=gnome-extra/sensors-applet-2.2.1 needs to filter LDFLAG --as-needed when US...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Keywords: NeedPatch
Depends on:
Blocks: as-needed
  Show dependency tree
Reported: 2008-05-12 11:48 UTC by haarp
Modified: 2009-03-08 11:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

sensors-applet-2.2.1-nvidia-check.patch (sensors-applet-2.2.1-nvidia-check.patch,778 bytes, patch)
2009-01-31 12:04 UTC, Gilles Dartiguelongue (RETIRED)
Details | Diff
sensors-applet-2.2.1.ebuild.patch (sensors-applet-2.2.1.ebuild.patch,1.07 KB, patch)
2009-01-31 12:05 UTC, Gilles Dartiguelongue (RETIRED)
Details | Diff
sensors-applet-2.2.1.ebuild.patch (sensors-applet-2.2.1.ebuild.patch,1.34 KB, text/plain)
2009-02-28 11:21 UTC, Gilles Dartiguelongue (RETIRED)
compilation output (pastefile,3.23 KB, text/plain)
2009-02-28 13:18 UTC, haarp

Note You need to log in before you can comment on or make changes to this bug.
Description haarp 2008-05-12 11:48:30 UTC
Using the LDFLAG --as-needed breaks compatibility with nvidia cards for this sensor reading program (its configure script to be more precise). This is only relevant when USE=nvidia is used.

Using this LDFLAG results in:
checking for XNVCTRLQueryExtension in -lXNVCtrl... no
although it's there. Without you get:
checking for XNVCTRLQueryExtension in -lXNVCtrl... yes

Simply filtering the LDFLAG will do the job. I don't possess enough knowledge to determine if bug 207543 is related in any kind of way.
Comment 1 Daniel Gryniewicz (RETIRED) gentoo-dev 2008-05-17 03:11:22 UTC
Fixed, thanks.
Comment 2 Rémi Cardona (RETIRED) gentoo-dev 2008-05-17 18:10:02 UTC
Closing, then :)
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-11-16 16:36:05 UTC
No this is NOT FIXED since it's just worked around in the tree.
Comment 4 Gilles Dartiguelongue (RETIRED) gentoo-dev 2009-01-31 12:04:40 UTC
Created attachment 180397 [details, diff]

could you try this patch ?
Comment 5 Gilles Dartiguelongue (RETIRED) gentoo-dev 2009-01-31 12:05:50 UTC
Created attachment 180399 [details, diff]

here is the ebuild patch. Since nvidia is proprietary crap, I don't want to impose eautoreconf on all users.
Comment 6 Gilles Dartiguelongue (RETIRED) gentoo-dev 2009-02-22 18:12:23 UTC
hey there, I really need this patch tested before I start to revert the fix in tree blindly and you complaining things broke again.
Comment 7 haarp 2009-02-23 11:55:37 UTC
Oh, I'm sorry. I completely forgot about this bug :(

Yes, I've tested the patches. The ebuild fails though. It tries to apply the patch before the sources are unpacked.
Comment 8 Gilles Dartiguelongue (RETIRED) gentoo-dev 2009-02-23 12:18:10 UTC
d'oh, my bad, could you put those lines in a src_unpack (and make sure to remove the append-ldflags line) ?
Comment 9 haarp 2009-02-23 12:33:32 UTC
I'm sorry I couldn't figure this out, but in src_unpack emerge says "Unpacking Sources" and then proceeds to try to patch. So we still have no sources to base the patch on :(

And what do you mean by remove append-ldflags? The ebuild-patch already did this :)
Comment 10 Gilles Dartiguelongue (RETIRED) gentoo-dev 2009-02-28 11:21:44 UTC
Created attachment 183465 [details]

here is the updated ebuild patch, sorry for delay.
Comment 11 Gilles Dartiguelongue (RETIRED) gentoo-dev 2009-02-28 11:23:00 UTC
oops, you want to stick EAPI="2" before the inherit line too.
Comment 12 haarp 2009-02-28 13:18:56 UTC
Created attachment 183469 [details]
compilation output

Ah, it was src_prepare. Should've tried that aswell :[

Well, okay. Both hunks in the patch fail for some reason, although I don't see why. So I patched by hand. 
Compilation fails tho (see attachment)
Comment 13 Gilles Dartiguelongue (RETIRED) gentoo-dev 2009-02-28 13:37:33 UTC
then that would be bug #207543.

Thanks for testing, I'll include that to the tree as soon as possible (with a fix for the other bug if possible).
Comment 14 Gilles Dartiguelongue (RETIRED) gentoo-dev 2009-03-08 11:33:06 UTC
2.2.2 in tree with this fix. Thanks for testing. Please reopen if it's still an issue for you.