Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 221149 - xfce-extra/xfce4-taskmanager build fails on autoconf
Summary: xfce-extra/xfce4-taskmanager build fails on autoconf
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: XFCE Team
URL:
Whiteboard:
Keywords:
: 227357 (view as bug list)
Depends on: 235407
Blocks: libtool-2.2
  Show dependency tree
 
Reported: 2008-05-10 04:06 UTC by Bob Raitz
Modified: 2008-09-21 19:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Raitz 2008-05-10 04:06:29 UTC
While attempting to emerge xfce-base/xfce4-extras, four of the included packages fail at autoconf. Due to the nature of the last error listed in each autoconf log, I am of the opinion that fixing one will fix them all. The packages that fail are, in no particular order; xfce-extra/xfce4-taskmanager, xfce-extra/xfce4-systemload, xfce-extra/xfce4-eyes, and xfce-extra/xfce4-xkb. 

Reproducible: Always

Steps to Reproduce:
1. attempt to install xfce-extra/xfce4-taskmanager, xfce-extra/xfce4-systemload, xfce-extra/xfce4-eyes, and xfce-extra/xfce4-xkb. 
2. build fails at autoconf.
3.

Actual Results:  
>>> Emerging (1 of 5) xfce-extra/xfce4-taskmanager-0.3.2-r1 to /
 * xfce4-taskmanager-0.3.2.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...        [ ok ]
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * checking xfce4-taskmanager-0.3.2.tar.bz2 ;-) ...                       [ ok ]
>>> Unpacking source...
>>> Unpacking xfce4-taskmanager-0.3.2.tar.bz2 to /var/tmp/portage/xfce-extra/xfce4-taskmanager-0.3.2-r1/work
 * Running eautoreconf in '/var/tmp/portage/xfce-extra/xfce4-taskmanager-0.3.2-r1/work/xfce4-taskmanager-0.3.2' ...
 * Running aclocal -I /usr/share/xfce4/dev-tools/m4macros ...             [ ok ]
 * Running autoconf ...                                                   [ !! ]

 * Failed Running autoconf !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/xfce-extra/xfce4-taskmanager-0.3.2-r1/temp/autoconf-20941.out

 *
 * ERROR: xfce-extra/xfce4-taskmanager-0.3.2-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 2700:  Called eautoreconf
 *             environment, line  865:  Called eautoconf
 *             environment, line  808:  Called autotools_run_tool 'autoconf'
 *             environment, line  353:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *  The die message:
 *   Failed Running autoconf !
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/xfce-extra/xfce4-taskmanager-0.3.2-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/xfce-extra/xfce4-taskmanager-0.3.2-r1/temp/environment'. 

Expected Results:  
A full emerge of all packages contained in the xfce-base/xfce4-extras meta-package

Pappy-lap's emerge --info
pappy-lap ~ # emerge --info
Portage 2.1.5_rc7 (default-linux/x86/2007.0, gcc-4.2.3, glibc-2.7-r2, 2.6.22.19 i686)
=================================================================
System uname: 2.6.22.19 i686 Intel(R) Celeron(R) M CPU 440 @ 1.86GHz
Timestamp of tree: Fri, 09 May 2008 06:33:01 +0000
distcc 2.18.3 i486-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.5.2-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.12
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i486-pc-linux-gnu"
CFLAGS="-march=pentium4 -O2 -pipe"
CHOST="i486-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=pentium4 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distcc distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS=""
LINGUAS="en"
MAKEOPTS="-j256"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl alsa ao audiofile avi bash-completion berkdb bitmap-fonts bzip2 cairo cdr cli cracklib crypt css cups dbus dlloader dri dts dv dvd dvdr dvdread eds encode esd fam fbcon ffmpeg fftw firefox flac foomaticdb fortran gdbm gif gimp gpm gsl gstreamer gtk hal iconv ipv6 isdnlog jack jpeg kde kdexdeltas kdgraphics ladspa lame ldap libg++ libsamplerate live mad midi mikmod mp3 mpeg mudflap nas ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pdcre pdf pdflib perl php png ppds pppd python qt3 quicktime readline reflection samba sdl session slang slp sndfile spell spl sse2 ssl swat tcpd theora tiff truetype truetype-fonts type1-fonts udev unicode usb vidix vorbis wifi win32codecs wxwindows x264 x86 xine xml xorg xscreensaver xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1     emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m       maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="i810"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Bob Raitz 2008-05-10 04:13:27 UTC
contents of /var/tmp/portage/xfce-extra/xfce4-taskmanager-0.3.2-r1/temp/autoconf-12859.out


***** autoconf *****
***** autoconf

configure:5418: error: possibly undefined macro: m4_ifval
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
Comment 2 Bob Raitz 2008-05-10 04:23:28 UTC
Contents of the autoconf-*.out files generated when trying to emerge the individual packages in xfce-extra

Contents of  /var/tmp/portage/xfce-extra/xfce4-systemload-0.4.2/temp/autoconf-13962.out 

***** autoconf *****
***** autoconf

configure:3676: error: possibly undefined macro: m4_ifval
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

Contents of  /var/tmp/portage/xfce-extra/xfce4-eyes-4.4.0/temp/autoconf-15101.out

***** autoconf *****
***** autoconf

configure:3728: error: possibly undefined macro: m4_ifval
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

Contents of /var/tmp/portage/xfce-extra/xfce4-xkb-0.4.3-r1/temp/autoconf-16213.out

***** autoconf *****
***** autoconf

configure:3741: error: possibly undefined macro: m4_ifval
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
 
Comment 3 Bob Raitz 2008-05-11 09:51:45 UTC
The bug was caused by libtool-2.2.4. Upon having it masked, my system downgraded to libtool-1.5.26. That allowed me to finish emerging the packages in question. I am calling this one fixed.
Comment 4 Jeroen Roovers gentoo-dev 2008-06-16 04:07:12 UTC
*** Bug 227357 has been marked as a duplicate of this bug. ***
Comment 5 Jeroen Roovers gentoo-dev 2008-06-16 04:09:32 UTC
This bug certainly won't be fixed by masking a libtool version that is bound to be marked stable.
Comment 6 trefoil 2008-06-17 01:51:17 UTC
Just a note that 0.4.0 was released May 18th, but this bug still occurs with that version.
Comment 7 Bob Raitz 2008-06-17 07:26:42 UTC
(In reply to comment #5)
> This bug certainly won't be fixed by masking a libtool version that is bound to
> be marked stable.
> 
I agree, but I am not the one that coded the package. The fix has to come from either someone who knows how to code who can patch the problem, or from upstream. It is clear that it's a libtool issue. I just recently did an emerge -aev world, and compilation failed again because I accidentally put a # before the line in my /etc/portage/package.mask to mask it. Once it was masked and I was back to libtoo1-1.5.26, those programs compiled properly.
Comment 8 trefoil 2008-06-18 20:43:28 UTC
I no longer hit this bug with version 0.4.0 now in Portage.
Comment 9 Christoph Mende (RETIRED) gentoo-dev 2008-06-18 21:28:26 UTC
so let's get xfce4-taskmanager-0.4.0 stable as soon as possible, target date is 2008-07-17
Comment 10 Roman Garnett 2008-07-09 15:08:57 UTC
http://bugs.gentoo.org/show_bug.cgi?id=230271 had a similar problem with libtool 2.2 and m4_ifval being undefined; it was caused due to refactoring in libtool with the jump to 2.2.  It was fixed by modifying the relevant eclass to cat the new files in libtool-2.2 into libtool.ac

Not sure whether it's exactly the same problem here.

Incidentally I experienced this bug with xfce4-systemload-0.4.2 and libtool-2.2.4.
Comment 11 Barry Gear 2008-07-12 05:00:40 UTC
So those packages apparently had issues with their configure.in and have a sed, intltoolize, and an eautoreconf in each of their src_unpacks. I don't see the '()'s that they are trying to remove anymore and then I comment the 3 lines out it builds and installs fine. Doesn't change the fact that an eautoreconf will fail though. (Notice that the xfce-extra/xfce4-taskmanager-0.3.2 ebuild has the the 3 lines in question and the taskmanager-0.4.0 ebuild does not).
Comment 12 Christoph Mende (RETIRED) gentoo-dev 2008-07-12 07:21:04 UTC
well, I do see the () that are removed in xfce4-taskmanager-0.3.2:
AC_INIT([xfce4-taskmanager], [taskmanager_version()], ...
-------------------------------------------------^^

Commenting out said lines will make the test suite fail
Comment 13 Christoph Mende (RETIRED) gentoo-dev 2008-09-21 19:05:53 UTC
xfce4-taskmanager-0.4 is stable on most archs and -systemload, -eyes and -xkb are fixed, thanks for reporting