Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 220825 - x11-misc/rss-glx-0.8.1-r4 configure error
Summary: x11-misc/rss-glx-0.8.1-r4 configure error
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Desktop Misc. Team
Whiteboard: "Patches awaiting review"
: 248578 (view as bug list)
Depends on:
Blocks: bad-autotools libtool-2.2
  Show dependency tree
Reported: 2008-05-07 22:47 UTC by subs
Modified: 2009-02-01 05:34 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---

config.log (config.log,15.59 KB, text/plain)
2008-05-07 22:48 UTC, subs
Updated gentoo patch to modify autotools source files rather than their output (rss-glx-0.8.1-gentoo.patch,1.43 KB, patch)
2008-05-11 05:18 UTC, Nick Bowler
Details | Diff
Updated imagemagick patch to modify autotools source files rather than their output (rss-glx-0.8.1-imagemagick.patch,484 bytes, patch)
2008-05-11 05:19 UTC, Nick Bowler
Details | Diff
Patch for the ebuild. (rss-glx-libtool22.patch,890 bytes, patch)
2008-05-11 05:23 UTC, Nick Bowler
Details | Diff
Include string.h in ImpSurface.cpp (rss-glx-0.8.1-impSurface-include.patch,329 bytes, patch)
2008-09-11 07:13 UTC, tao
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description subs 2008-05-07 22:47:52 UTC
When emerging rss-glx, it fails on the configure stage saying:

checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
checking for x86_64-pc-linux-gnu-gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of x86_64-pc-linux-gnu-gcc... gcc3
checking for x86_64-pc-linux-gnu-g++... x86_64-pc-linux-gnu-g++
checking whether we are using the GNU C++ compiler... yes
checking whether x86_64-pc-linux-gnu-g++ accepts -g... yes
checking dependency style of x86_64-pc-linux-gnu-g++... gcc3
checking for a BSD-compatible install... /usr/bin/install -c
configure: error: cannot run /bin/sh ./config.sub

config.log to follow
Comment 1 subs 2008-05-07 22:48:46 UTC
Created attachment 152391 [details]
Comment 2 subs 2008-05-07 22:49:39 UTC
emerge --info
Portage 2.1.5_rc7 (default/linux/amd64/2008.0/desktop, gcc-4.2.3, glibc-2.7-r2, 2.6.25-gentoo-r2 x86_64)
System uname: 2.6.25-gentoo-r2 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
Timestamp of tree: Wed, 07 May 2008 21:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r2
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.3
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe -march=athlon64 -msse3"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=athlon64 -msse3"
FEATURES="ccache distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="en en_US"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/portage/local/layman/desktop-effects /usr/local/portage"
USE="X a52 aac acl alsa amd64 berkdb branding bzip2 cairo cdr cli cracklib cups curl dbus dri dvd dvdr dvdread eds emboss encode esd evo exif fam ffmpeg firefox flac fortran gdbm gedit gif gimp gnome gnome-keyring gnutls gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile hal hddtemp howl iconv idn imagemagick imlib ipv6 isdnlog java joystick jpeg jpeg2k lcms libnotify lm_sensors logrotate mad midi mikmod mmx mmxext mng mp3 mpeg mudflap multilib nautilus ncurses nls nptl nptlonly nsplugin offensive ogg openal opengl openmp pam pcre pdf perl png ppds pppd python quicktime readline reflection samba sdl seamonkey session smp speex spell spl sse sse2 ssl startup-notification svg tcltk tcpd theora threads tiff totem truetype unicode usb vorbis wavpack wma wmf x264 xine xml xorg xscreensaver xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="nvidia"
Comment 3 Vasiliy Levykin 2008-05-10 08:43:07 UTC
Try reverting to stable sys-devel/libtool-1.5.26.
Comment 4 subs 2008-05-10 22:56:01 UTC
Yes it builds with 1.5.26, I've added a reference to this bug in the libtool 2.2.X bug tracker.
Comment 5 Nick Bowler 2008-05-11 05:17:04 UTC
I looked into this, and it turns out that the only thing needed to get this to build is to run eautoreconf after unpacking.

However, most of the patches applied by the ebuild change configure and files directly.  Thus, their changes get clobbered by eautoreconf.

I have updated the patches to instead modify and files, and the ebuild accordingly, and this package now builds and runs with libtool-2.2.

P.S. I tried to set this bug to block the tracker (bug #212763) (which, afaik, it should be doing), but bugzilla wouldn't let me.  The summary should probably be updated to reflect the libtool-2.2 nature of this bug, as well.
Comment 6 Nick Bowler 2008-05-11 05:18:48 UTC
Created attachment 152809 [details, diff]
Updated gentoo patch to modify autotools source files rather than their output
Comment 7 Nick Bowler 2008-05-11 05:19:31 UTC
Created attachment 152811 [details, diff]
Updated imagemagick patch to modify autotools source files rather than their output
Comment 8 Nick Bowler 2008-05-11 05:23:20 UTC
Created attachment 152813 [details, diff]
Patch for the ebuild.
Comment 9 subs 2008-06-10 22:53:14 UTC
Thanks, those patches worked perfectly. Hopefully they can get committed to the tree.
Comment 10 Alec Meyers 2008-09-07 02:06:51 UTC
Thanks, your patches worked for me too.

I had a problem, though, but it was easily fixed:
It gave me an error that memcpy was undeclared, so I added "#include <string.h> to reallyslick/Implicit/impSurface.cpp

Now it works great!
Comment 11 tao 2008-09-10 23:47:35 UTC
(In reply to comment #10)I can confirm this, with additional #include these patches works for me.
Comment 12 tao 2008-09-11 07:13:28 UTC
Created attachment 165188 [details, diff]
Include string.h in ImpSurface.cpp

To use, add epatch "${FILESDIR}"/${P}-impSurface-include.patch_ line in _rss-glx-libtool22.patch patched_ ebuild.
Comment 13 Alec Meyers 2008-09-12 18:57:57 UTC
Thanks for making the patch!
Comment 14 Alec Meyers 2008-10-28 21:53:01 UTC,

Could you please put the message "Patches awaiting review" into the "Status Whiteboard", as recommended by Diego Pettenò ("Flameeyes") on his blog?

Comment 15 subs 2008-10-28 22:37:05 UTC
(In reply to comment #14)
> Could you please put the message "Patches awaiting review" into the "Status
> Whiteboard", as recommended by Diego Pettenò ("Flameeyes") on his blog?
> Thanks!

Done ;)
Comment 16 Alec Meyers 2008-10-28 22:45:30 UTC

Hopefully now someone might fix it in the tree!
Comment 17 Ildar Sagdejev 2009-01-23 20:48:19 UTC
I just stumbled on the impSurface.cpp problem.  0.8.1-r4 is the only e-build, and it's marked stable?  And there has been a known patch for months?  I'm definitely putting in some votes for this one =/
Comment 18 Ryan Hill (RETIRED) gentoo-dev 2009-02-01 03:33:43 UTC
*** Bug 248578 has been marked as a duplicate of this bug. ***
Comment 19 Ryan Hill (RETIRED) gentoo-dev 2009-02-01 05:15:17 UTC
Fixed in -r5.  Thanks for the patches and sorry about the wait.
Comment 20 Alec Meyers 2009-02-01 05:34:00 UTC
Thank you!