Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 220759 - app-editors/geresh-0.4.1 fails w/ gcc-4.3.0; bump->0.6.3 and patch
Summary: app-editors/geresh-0.4.1 fails w/ gcc-4.3.0; bump->0.6.3 and patch
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-05-07 14:16 UTC by Peter Alfredsen (RETIRED)
Modified: 2008-05-12 05:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
geresh-0.4.1--0.6.3.ebuild.patch (geresh-0.4.1--0.6.3.ebuild.patch,794 bytes, patch)
2008-05-07 14:17 UTC, Peter Alfredsen (RETIRED)
Details | Diff
geresh-0.6.3-gcc4.y.patch (geresh-0.6.3-gcc4.y.patch,1.73 KB, patch)
2008-05-07 14:18 UTC, Peter Alfredsen (RETIRED)
Details | Diff
fribidi -Wl,--as-needed configure time detection fix. (geresh-0.6.3-asneeded.patch,645 bytes, patch)
2008-05-11 18:34 UTC, Samuli Suominen
Details | Diff
geresh-0.4.1--0.6.3.ebuild.patch (geresh-0.4.1--0.6.3.ebuild.patch,1.35 KB, patch)
2008-05-11 20:19 UTC, Peter Alfredsen (RETIRED)
Details | Diff
geresh-0.6.3-as-needed.patch (geresh-0.6.3-as-needed.patch,3.54 KB, patch)
2008-05-11 20:20 UTC, Peter Alfredsen (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Alfredsen (RETIRED) gentoo-dev 2008-05-07 14:16:36 UTC
c++ -DHAVE_CONFIG_H -I. -I. -I. -DLOCALEDIR=\"/usr/share/locale\" -DPKGDATADIR=\"/usr/share/geresh\"    -O2 -march=i686 -mtune=athlon-xp -msse -mmmx -pipe -ggdb3 -c editbox.cc
In file included from inputline.h:23,
                 from dialogline.h:22,
                 from dialogline.cc:23:
editbox.h: In member function ‘virtual bool EditBox::do_action(const char*)’:
editbox.h:485: error: ‘strcmp’ was not declared in this scope
editbox.h: In member function ‘virtual const char* EditBox::get_action_description(const char*)’:
editbox.h:485: error: ‘strcmp’ was not declared in this scope
In file included from dialogline.h:22,
                 from dialogline.cc:23:
inputline.h: In member function ‘virtual bool InputLine::do_action(const char*)’:
inputline.h:121: error: ‘strcmp’ was not declared in this scope
inputline.h: In member function ‘virtual const char* InputLine::get_action_description(const char*)’:
inputline.h:121: error: ‘strcmp’ was not declared in this scope
In file included from dialogline.cc:23:
dialogline.h: In member function ‘virtual bool DialogLine::do_action(const char*)’:
dialogline.h:44: error: ‘strcmp’ was not declared in this scope
dialogline.h: In member function ‘virtual const char* DialogLine::get_action_description(const char*)’:
dialogline.h:44: error: ‘strcmp’ was not declared in this scope
In file included from editor.h:25,
                 from dialogline.cc:24:
speller.h: In member function ‘virtual bool SpellerWnd::do_action(const char*)’:
speller.h:50: error: ‘strcmp’ was not declared in this scope
speller.h: In member function ‘virtual const char* SpellerWnd::get_action_description(const char*)’:
speller.h:50: error: ‘strcmp’ was not declared in this scope
In file included from dialogline.cc:24:
editor.h: In member function ‘virtual bool Editor::do_action(const char*)’:
editor.h:59: error: ‘strcmp’ was not declared in this scope
editor.h: In member function ‘virtual const char* Editor::get_action_description(const char*)’:
editor.h:59: error: ‘strcmp’ was not declared in this scope
editor.h: In member function ‘virtual bool HelpBox::do_action(const char*)’:
editor.h:181: error: ‘strcmp’ was not declared in this scope
editor.h: In member function ‘virtual const char* HelpBox::get_action_description(const char*)’:
editor.h:181: error: ‘strcmp’ was not declared in this scope
make: *** [dialogline.o] Error 1
make: *** Waiting for unfinished jobs....
In file included from editbox.cc:22:
editbox.h: In member function ‘virtual bool EditBox::do_action(const char*)’:
editbox.h:485: error: ‘strcmp’ was not declared in this scope
editbox.h: In member function ‘virtual const char* EditBox::get_action_description(const char*)’:
editbox.h:485: error: ‘strcmp’ was not declared in this scope
make: *** [editbox.o] Error 1
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2008-05-07 14:17:31 UTC
Created attachment 152275 [details, diff]
geresh-0.4.1--0.6.3.ebuild.patch
Comment 2 Peter Alfredsen (RETIRED) gentoo-dev 2008-05-07 14:18:31 UTC
Created attachment 152277 [details, diff]
geresh-0.6.3-gcc4.y.patch

Fixes the problem. Snatched from Debian. Merged fixes for gcc-4.1 into the same file.
Comment 3 Samuli Suominen gentoo-dev 2008-05-11 18:34:35 UTC
Created attachment 152863 [details, diff]
fribidi -Wl,--as-needed configure time detection fix.

Unfortunately, it fails to autotoolize due to other problems..

Howto reproduce:

LDFLAGS="-Wl,--as-needed" emerge -av geresh

Problem:

checking for  in -lfribidi... no
checking for fribidi_log2vis... no
configure: error: A required FriBiDi function doesn't exist
Comment 4 Samuli Suominen gentoo-dev 2008-05-11 18:35:40 UTC
So obviously geresh needs some more love..
Comment 5 Peter Alfredsen (RETIRED) gentoo-dev 2008-05-11 20:19:30 UTC
Created attachment 152873 [details, diff]
geresh-0.4.1--0.6.3.ebuild.patch

Ebuild for great loving.
Comment 6 Peter Alfredsen (RETIRED) gentoo-dev 2008-05-11 20:20:38 UTC
Created attachment 152875 [details, diff]
geresh-0.6.3-as-needed.patch

As-needed ricer lovin' ;-)
Comment 7 Samuli Suominen gentoo-dev 2008-05-12 05:25:14 UTC
bumped with minor ebuild changes (no need to go all that trouble to die on documentation, it's just documentation) and drop unused libtool from inherit

keyworded also ~amd64

thanks