Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 220549 - dev-db/mysql-5.0.56 failes to compile with automake error
Summary: dev-db/mysql-5.0.56 failes to compile with automake error
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux MySQL bugs team
URL:
Whiteboard:
Keywords:
: 220675 221041 (view as bug list)
Depends on:
Blocks: libtool-2.2
  Show dependency tree
 
Reported: 2008-05-06 10:15 UTC by Jure Repinc
Modified: 2008-11-13 12:22 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch file. (900_all_libtool_2_2_4.patch,381 bytes, patch)
2008-05-06 12:22 UTC, Ioan Marius Curelariu
Details | Diff
The new patch index file (000_index.txt,11.33 KB, text/plain)
2008-05-06 12:23 UTC, Ioan Marius Curelariu
Details
Modified ebuild using mysql-extras-20080310-libtool (mysql-5.0.56.ebuild,3.20 KB, text/plain)
2008-05-06 12:24 UTC, Ioan Marius Curelariu
Details
Convenience patch archive I've been using. (mysql-extras-20080310-libtool.tar.bz2,104.14 KB, application/octet-stream)
2008-05-06 12:24 UTC, Ioan Marius Curelariu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jure Repinc 2008-05-06 10:15:23 UTC
When I try to compile dev-db/mysql-5.0.56 I get this output:

 * Done with patching
 * Reconfiguring dir '.'
 * Running eautoreconf in '/var/tmp/portage/dev-db/mysql-5.0.56/work/mysql/innobase' ...
 * Running aclocal ...                                                                                                                                                                                                                 [ ok ]
 * Running libtoolize --copy --force --install --automake ...                                                                                                                                                                          [ ok ]
 * Running aclocal ...                                                                                                                                                                                                                 [ ok ]
 * Running autoconf ...                                                                                                                                                                                                                [ ok ]
 * Running autoheader ...                                                                                                                                                                                                              [ ok ]
 * Running automake --add-missing --copy --foreign ...                                                                                                                                                                                 [ !! ]

 * Failed Running automake !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/dev-db/mysql-5.0.56/temp/automake-17090.out

 *
 * ERROR: dev-db/mysql-5.0.56 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 3650:  Called mysql_src_unpack
 *             environment, line 3302:  Called eautoreconf
 *             environment, line 1200:  Called eautoreconf
 *             environment, line 1216:  Called eautomake
 *             environment, line 1190:  Called autotools_run_tool 'automake' '--add-missing' '--copy' '--foreign'
 *             environment, line  507:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *  The die message:
 *   Failed Running automake !
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-db/mysql-5.0.56/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-db/mysql-5.0.56/temp/environment'.
 *



contents of automake-17090.out:
***** automake *****
***** automake --add-missing --copy --foreign

configure.in:37: required file `../ltmain.sh' not found



# emerge --info
Portage 2.1.5_rc6 (default-linux/amd64/2007.0/no-multilib, gcc-4.2.3, glibc-2.7-r2, 2.6.24-gentoo-r7 x86_64)
=================================================================
System uname: 2.6.24-gentoo-r7 x86_64 AMD Athlon(tm) 64 Processor 3000+
Timestamp of tree: Mon, 05 May 2008 23:06:21 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r11, 2.5.2-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.3
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -pipe -O2 -fomit-frame-pointer -frename-registers"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /usr/share/cursors/xorg-x11/default"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -pipe -O2 -fomit-frame-pointer -frename-registers"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo http://distfiles.gentoo.org/"
LANG="sl_SI"
LDFLAGS=""
LINGUAS="en sl"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/thousand-parsec /root/portageoverlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apache2 arts audiofile avi berkdb bzip2 cairo cdr cli cracklib crypt cups curl dbus dri dts dvd dvdr dvdread eds encode esd exif expat fam fbcon ffmpeg flac foomaticdb fortran freetype ftp gdbm gif gmpgnome gphoto2 gpm gstreamer gtk gtk2 hal iconv idn imagemagick ipv6 isdnlog jabber jpeg kde kdehiddenvisibility lcms lm_sensors mad matroska midi mmx mng mozilla mp3 mpeg mplayer mudflap mysql ncurses nls nptl nptlonly nvidia ogg openglopenmp pam pcre pdf perl php png posix ppds pppd python qt3 qt4 quicktime readline reflection samba scanner sdl session slp speex spell spl sqlite sse sse2 ssl stream subversion svg tcpd tetex theora tiff truetype unicode usb vhosts videos vorbis xcomposite xine xml xml2 xorg xosd xprint xscreensaver xv xvid zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_httprewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en sl" USERLAND="GNU" VIDEO_CARDS="radeon vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Ioan Marius Curelariu 2008-05-06 11:36:52 UTC
Having the same problem.
Comment 2 Ioan Marius Curelariu 2008-05-06 12:18:14 UTC
The following lines should be added on top of the ./innobase/configure.in

AC_CONFIG_AUX_DIR(.)
AC_CONFIG_MACRO_DIR(.)
Comment 3 Ioan Marius Curelariu 2008-05-06 12:22:09 UTC
Created attachment 152105 [details, diff]
Patch file.

Should be added in the mysql-extras archive.
Comment 4 Ioan Marius Curelariu 2008-05-06 12:23:02 UTC
Created attachment 152107 [details]
The new patch index file
Comment 5 Ioan Marius Curelariu 2008-05-06 12:24:01 UTC
Created attachment 152109 [details]
Modified ebuild using mysql-extras-20080310-libtool
Comment 6 Ioan Marius Curelariu 2008-05-06 12:24:46 UTC
Created attachment 152111 [details]
Convenience patch archive I've been using.
Comment 7 Carsten Lohrke (RETIRED) gentoo-dev 2008-05-07 00:21:40 UTC
*** Bug 220675 has been marked as a duplicate of this bug. ***
Comment 8 Steffen Bergner 2008-05-07 09:34:17 UTC
Problem exists for dev-db/mysql-community-5.0.51a too.

 * Running automake --add-missing --copy --foreign ...
  [ !! ]

 * Failed Running automake !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/dev-db/mysql-community-5.0.51a/temp/automake-30219.out

 *
 * ERROR: dev-db/mysql-community-5.0.51a failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 3581:  Called mysql_src_unpack
 *             environment, line 3242:  Called eautoreconf
 *             environment, line 1177:  Called eautoreconf
 *             environment, line 1193:  Called eautomake
 *             environment, line 1167:  Called autotools_run_tool 'automake' '--add-missing' '--copy' '--foreign'
 *             environment, line  488:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *  The die message:
 *   Failed Running automake !
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-db/mysql-community-5.0.51a/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-db/mysql-community-5.0.51a/temp/environment'.
 *


cat /var/tmp/portage/dev-db/mysql-community-5.0.51a/temp/automake-30219.out
 ***** automake *****
 ***** automake --add-missing --copy --foreign

 configure.in:37: required file `../ltmain.sh' not found

Comment 9 Jan Kundrát (RETIRED) gentoo-dev 2008-05-09 22:08:16 UTC
*** Bug 221041 has been marked as a duplicate of this bug. ***
Comment 10 MasterC 2008-05-20 00:01:41 UTC
Is there a chance any of these fixes might be committed soon?  I continue to have to mask any updates or manually apply this fix on every machine I use...
Comment 11 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2008-05-22 18:29:30 UTC
I don't get this here. When did it start?
Comment 12 Steffen Bergner 2008-05-23 06:30:40 UTC
With newer automake/auto*-versions, I suppose.
Comment 13 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2008-05-29 05:17:44 UTC
Fixed for 5.0.60
Comment 14 Volker Hemmann 2008-11-11 22:58:00 UTC
but not fixed for dev-db/mysql-community-5.0.51a
Comment 15 Vladimir Lushnikov 2008-11-13 12:22:33 UTC
(In reply to comment #14)
> but not fixed for dev-db/mysql-community-5.0.51a
> 

Agreed. Please reopen (the patch works for 5.0.51a too)