Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 219955 - media-gfx/inkscape-0.46-r2 and dev-util/intltool-0.37.1 emerged stopped because of XML::Parser... configure
Summary: media-gfx/inkscape-0.46-r2 and dev-util/intltool-0.37.1 emerged stopped becau...
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-01 18:10 UTC by David Voge
Modified: 2013-12-19 15:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Voge 2008-05-01 18:10:20 UTC
I had emerged in past inkscape and works fine. because of didn't start i tried to remerge but it hang in configure.

The same with dev-util/intltool-0.37.1 when i try this to remerge.

Reproducible: Always

Steps to Reproduce:
1. had inkscape in past emerge
2. try to remerge

Actual Results:  
>>> Unpacking inkscape-0.46.tar.gz to /var/tmp/portage/media-gfx/inkscape-0.46-r2/work
 * Fixing OMF Makefiles ...
  [ ok ]
 * Applying inkscape-0.46-gcc43.patch ...
  [ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/media-gfx/inkscape-0.46-r2/work/inkscape-0.46 ...
 * econf: updating inkscape-0.46/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating inkscape-0.46/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --with-xft --with-gtkspell --disable-inkboard --disable-mmx --without-inkjar --with-gnome-vfs --with-gnome-print --disable-lcms --without-perl --enable-gtk-doc --libdir=/usr/lib64 --build=x86_64-pc-linux-gnu
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking how to create a pax tar archive... gnutar
checking for style of include used by make... GNU
checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking dependency style of x86_64-pc-linux-gnu-gcc... gcc3
checking for intltool >= 0.22... 0.37.1 found
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for msgfmt... /usr/bin/msgfmt
checking for perl... /usr/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/media-gfx/inkscape-0.46-r2/work/inkscape-0.46/config.log
 * 
 * ERROR: media-gfx/inkscape-0.46-r2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2668:  Called gnome2_src_compile
 *             environment, line 2027:  Called gnome2_src_configure
 *             environment, line 2041:  Called econf '--with-xft' '--with-gtkspell' '--disable-inkboard' '--disable-mmx' '--without-inkjar' '--with-gnome-vfs' '--with-gnome-print' '--disable-lcms' '--without-perl' '--enable-gtk-doc'
 *               ebuild.sh, line  513:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *  The die message:
 *   econf failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-gfx/inkscape-0.46-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/inkscape-0.46-r2/temp/environment'.
 * 



# emerge --info
Portage 2.1.5_rc6 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.7-r2, 2.6.25-gentoo-r1 x86_64)
=================================================================
System uname: 2.6.25-gentoo-r1 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4600+
Timestamp of tree: Thu, 01 May 2008 10:15:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p33
dev-lang/python:     2.4.4-r9, 2.5.2-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.3
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.25-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.0/env /usr/kde/4.0/share/config /usr/kde/4.0/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/distfiles"
FEATURES="distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="de_DE.UTF-8"
LDFLAGS=""
LINGUAS="de"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/svn"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi addbookmarks agg alias alsa amd64 apache2 applet arts artworkextra asyncns audacious autoreplace bash-completion berkdb bluetooth branding bzip2 cairo caps captury cdda cddb cdio cdparanoia cdr cli color-console cpudetection cracklib crypt cscope cups cursors dbus doc dri dts dv dvd dvdr dvdread eds emboss encode esd evo fam fbcon ffmpeg firefox flac fortran fuse gdbm gdm gif gnokii gnome gnutls gpgme gphoto2 gpm gstreamer gtk hal htmlhandbook ical icons iconv id3tag imap imlib ipv6 irc irda isdnlog ithreads jack jpeg kde keyring kig-scripting lame ldap libnotify libsamplerate libwww live mad midi mikmod mmx modplug mono mp3 mpeg mudflap multilib mysql nautilus ncurses nls nova nptl nptlonly nsplugin nvtv ogg openal openexr opengl openmp pam pcre pda pdf perl php plugins png pop posix ppds pppd pulseaudio python qt3 qt3support quicktime readline reflection ruby sbig scanner sdl session shout skins smime sms smtp snmp speex spell spl sqlite sse sse2 ssl ssse3 startup-notification stream svg taglib tcl tcpd texteffect theora tiff tk translator truetype unicode usb v4l v4l2 vcd vcdx vim vim-pager vim-syntax vim-with-x vlm vorbis winpopup xcomposite xinerama xml xorg xscreensaver xv xvid yahoo zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="aiptek" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 David Voge 2008-05-03 16:48:45 UTC
it't ok. the ebuilds are all ok, after a `emerge -e world` all is ok, works fine and emerge run's fine.
Comment 2 Jeroen Roovers gentoo-dev 2013-12-19 15:13:21 UTC

*** This bug has been marked as a duplicate of bug 41124 ***