Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 219450 - app-text/htmltidy bump to 8.3.22
Summary: app-text/htmltidy bump to 8.3.22
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo SGML herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-27 11:59 UTC by Michael Cramer
Modified: 2009-07-22 17:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Cramer 2008-04-27 11:59:03 UTC
please bump to a newer version, the one in portage is now nearly 2,5 years old

Reproducible: Always
Comment 1 Jesse Adelman 2008-11-18 22:54:29 UTC
The Tidy project's version scheme is very opaque, but here's the SVN revision info: http://tidy.cvs.sourceforge.net/tidy/tidy/src/version.h?view=markup

The project has been active, adding new features and fixing bugs, but by "hiding" progress in SVN (versus releasing "stable" version tarballs), it is no wonder that Gentoo hasn't updated it in a long time. That said, I hope to see updates soon! :)

From the Tidy news, since last ebuild update:
'18 June 2008

The configuration option anchor-as-name has been added.

13 August 2007

The configuration option merge-spans has been added.

14 June 2007

The configuration option sort-attributes has been added. Additionally, the option show-body-only has been extended to accept "auto".'

Thanks.
Comment 2 Robert Buchholz (RETIRED) gentoo-dev 2009-07-22 17:29:12 UTC
+  22 Jul 2009; Robert Buchholz <rbu@gentoo.org>
+  +files/htmltidy-20090325-tidyrc.patch, htmltidy-4.8.6.ebuild,
+  htmltidy-5.10.26-r2.ebuild, +htmltidy-20090325.ebuild:
+  Version bump to latest CVS sources. Remove xml use flag and html2db as it was
+  never integrated upstream and does not compile due to usage of internal tidy
+  API. Enable /etc/tidyrc and ~/.tidyrc config paths and build autotools
+  properly, closes bugs 154834, 219450, 226437 and 278604.