Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 219412 - =app-misc/mc-4.7.0_pre1 can't handle .tbz2 filetype
Summary: =app-misc/mc-4.7.0_pre1 can't handle .tbz2 filetype
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Samuli Suominen
URL: http://www.midnight-commander.org/tic...
Whiteboard:
Keywords:
: 237195 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-04-27 04:59 UTC by Xavian-Anderson Macpherson
Modified: 2009-08-05 11:40 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
LZMA patch from Larzhu. (mc-4.6.1.lzma.patch,7.53 KB, patch)
2008-05-05 17:07 UTC, Samuli Suominen
Details | Diff
Version of patch that applies to mc-4.6.2-pre1 (mc-4.6.2-pre1-lzma.patch,8.17 KB, patch)
2008-08-22 18:09 UTC, Ian Abbott
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Xavian-Anderson Macpherson 2008-04-27 04:59:46 UTC
The current app-shells/mc package as provided by Gentoo, does not provide the ability to view the contents of files compressed with either .lzma or .tbz2 extensions. I know  that this is possible using the vfs, mc simply needs to be patched to do so.

Thanks to a patch provided by Lasse "Larzhu" Collin, my Slackware/Slamd64 system is able to do this. He can be reached on freenode/#tukaani for assistance if needed.

Shingoshi

Reproducible: Always

Steps to Reproduce:
1. Open mc
2. Select any file having the above mentioned extension.
3. press return, or F3.
4. Either of these will yield an incomprehensible output.

Actual Results:  
Incomprehensible output.

Expected Results:  
It needs to be possible to view these files directly, as can be done with .gz and .bz2 extensions.

I am attempting to get Larzhu write a script to create the patch for lzma for any version of mc. You'll likely be on your own to do the same for .tbz2 files.

This is essential to me, especially since I build .tbz2 binaries of all my packages, and use .lzma for all of my manpages and bug reports.

Thank you!
Shingoshi
Comment 1 Samuli Suominen gentoo-dev 2008-04-28 13:32:45 UTC
Yes, I'm aware syntaxes need more work and I will be working on them..
Comment 2 Xavian-Anderson Macpherson 2008-04-29 02:36:47 UTC
I just realized that mc doesn't need any special code to provide a view of lzma file. All that's needed, is to do the following:

lzma=lzcat

Shingoshi
Comment 3 Samuli Suominen gentoo-dev 2008-05-05 17:07:09 UTC
Created attachment 151953 [details, diff]
LZMA patch from Larzhu.

Needs some work..
Comment 4 Xavian-Anderson Macpherson 2008-05-06 01:48:29 UTC
(In reply to comment #3)
> Created an attachment (id=151953) [edit]
> LZMA patch from Larzhu.
> 
> Needs some work..
> 

(In reply to comment #3)
> Created an attachment (id=151953) [edit]
> LZMA patch from Larzhu.
> 
> Needs some work..
> 

(In reply to comment #3)
> Created an attachment (id=151953) [edit]
> LZMA patch from Larzhu.
> 
> Needs some work..
> 

Does "needing some work", mean it doesn't?
Shignoshi
Comment 5 Ian Abbott 2008-08-22 18:09:06 UTC
Created attachment 163563 [details, diff]
Version of patch that applies to mc-4.6.2-pre1

The patch for mc-4.6.1 failed to apply on the file edit/edit.c due to whitespace changes in mc-4.6.2-pre1.  I have changed that section of the patch and rebased it to mc-4.6.2-pre1.

I also changed mc.ext.in slightly to allow *.tbgz2 files to be opened and viewed.
Comment 6 Samuli Suominen gentoo-dev 2008-11-28 03:05:53 UTC
*** Bug 237195 has been marked as a duplicate of this bug. ***
Comment 7 Samuli Suominen gentoo-dev 2009-08-02 14:47:58 UTC
Try 4.7.0_pre1. If there's still issues, please reopen and open a bug at:

http://www.midnight-commander.org

So it will be included in _pre2 or final 4.7.0.
Comment 8 Ian Abbott 2009-08-03 10:50:28 UTC
mc-4.7.0-pre1 doesn't handle .tbz2 files, but I added a ticket with a patch:

http://www.midnight-commander.org/ticket/1452
Comment 9 Samuli Suominen gentoo-dev 2009-08-03 10:54:04 UTC
Reopening to handle .tbz2 support.
Comment 10 Samuli Suominen gentoo-dev 2009-08-03 11:00:12 UTC
+  03 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> mc-4.7.0_pre1.ebuild,
+  +files/mc-4.7.0_pre1-tbz2_filetype.patch:
+  .tbz2 filetype support wrt #219412 by Ian Abbott